aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/libpano13/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/graphics/libpano13/Makefile b/graphics/libpano13/Makefile
index 75e76d5a4907..b2cce7c4f113 100644
--- a/graphics/libpano13/Makefile
+++ b/graphics/libpano13/Makefile
@@ -3,13 +3,16 @@
PORTNAME= libpano13
PORTVERSION= 2.9.18
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics java
MASTER_SITES= SF/panotools/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= vd@FreeBSD.org
COMMENT= Cross-platform library behind Panorama Tools and other photo stitchers
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
@@ -29,15 +32,18 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-.if !defined(WITHOUT_JAVA)
+OPTIONS_DEFINE= JAVA
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MJAVA}
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
CONFIGURE_ARGS+= --with-java=${JAVA_HOME}
-PLIST_SUB= JAVA=""
.else
CONFIGURE_ARGS+= --without-java
-PLIST_SUB= JAVA="@comment "
.endif
.include <bsd.port.mk>