aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/lastfm-desktop/Makefile1
-rw-r--r--audio/mumble/Makefile2
-rw-r--r--deskutils/fbreader/Makefile2
-rw-r--r--deskutils/libopensync-plugin-evolution2-devel/Makefile8
-rw-r--r--devel/py-statgrab/Makefile7
-rw-r--r--editors/openoffice-3/Makefile3
-rw-r--r--editors/openoffice-4/Makefile2
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--games/pink-pony/Makefile1
-rw-r--r--games/trophy/Makefile2
-rw-r--r--games/uqm/Makefile2
-rw-r--r--irc/minbif/Makefile2
-rw-r--r--lang/neko/Makefile2
-rw-r--r--multimedia/miro/Makefile3
-rw-r--r--multimedia/xbmc-addon-pvr/Makefile1
-rw-r--r--net-p2p/gnunet-gtk/Makefile10
-rw-r--r--net/xrdp-devel/Makefile1
-rw-r--r--print/kover/Makefile2
-rw-r--r--security/razorback-fsMonitor/Makefile8
-rw-r--r--sysutils/gigolo/Makefile2
-rw-r--r--sysutils/libfvde/Makefile1
-rw-r--r--x11-themes/gtk-qt4-engine/Makefile2
-rw-r--r--x11-themes/kde-gtk-config/Makefile2
-rw-r--r--x11-toolkits/vtkfox/Makefile2
24 files changed, 30 insertions, 40 deletions
diff --git a/audio/lastfm-desktop/Makefile b/audio/lastfm-desktop/Makefile
index 72c2dfbb68d5..99425be768c2 100644
--- a/audio/lastfm-desktop/Makefile
+++ b/audio/lastfm-desktop/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= lastfm:${PORTSDIR}/audio/liblastfm \
avcodec1:${PORTSDIR}/multimedia/ffmpeg1 \
gpod:${PORTSDIR}/audio/libgpod
+USES= pkgconfig
USE_BZIP2= yes
USE_QT4= gui linguist_build moc_build network phonon qmake_build \
rcc_build uic_build webkit xml
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index a57fe951da63..38867f852dcd 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex \
protoc:${PORTSDIR}/devel/protobuf \
opus:${PORTSDIR}/audio/opus
-USES= gmake
+USES= gmake pkgconfig
USE_QT4= gui svg iconengines_run xml sql network l10n \
linguist_build qmake_build moc_build rcc_build uic_build \
opengl sql-sqlite3_run
diff --git a/deskutils/fbreader/Makefile b/deskutils/fbreader/Makefile
index 628fdfeb430d..b6a43990b964 100644
--- a/deskutils/fbreader/Makefile
+++ b/deskutils/fbreader/Makefile
@@ -32,7 +32,7 @@ STATUS= debug
STATUS= release
.endif
-USES= iconv gmake
+USES= iconv gmake pkgconfig
USE_SQLITE= yes
USE_LDCONFIG= yes
diff --git a/deskutils/libopensync-plugin-evolution2-devel/Makefile b/deskutils/libopensync-plugin-evolution2-devel/Makefile
index 25c82ed3aec9..9154f9ddf53a 100644
--- a/deskutils/libopensync-plugin-evolution2-devel/Makefile
+++ b/deskutils/libopensync-plugin-evolution2-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopensync-plugin-evolution2
-# Date created: 18 July 2008
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= libopensync-plugin-evolution2
PORTVERSION= 0.36
@@ -21,7 +17,7 @@ RUN_DEPENDS= vconvert:${PORTSDIR}/deskutils/libopensync-plugin-vformat-devel
CONFLICTS= libopensync-plugin-evolution2-0.2*
USE_BZIP2= yes
-USES= cmake
+USES= cmake pkgconfig
USE_GNOME= evolutiondataserver gconf2
CMAKE_ARGS+= -Wno-dev
diff --git a/devel/py-statgrab/Makefile b/devel/py-statgrab/Makefile
index 04b83fa9e317..323f914c1fa5 100644
--- a/devel/py-statgrab/Makefile
+++ b/devel/py-statgrab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-statgrab
-# Date created: 20 March 2004
-# Whom: Tim Bishop <tim@bishnet.net>
-#
+# Created by: Tim Bishop <tim@bishnet.net>
# $FreeBSD$
-#
PORTNAME= statgrab
PORTVERSION= 0.5
@@ -22,6 +18,7 @@ COMMENT= A set of Python bindings for libstatgrab
LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
DIST_SUBDIR= i-scream
+USES= pkgconfig
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= pystatgrab
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 2c440f193aeb..dff4fe147f47 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -25,11 +25,10 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
USE_GL= gl glu
USE_GSTREAMER= yes
#USE_GCC= yes
-USE_GMAKE= yes
USE_PYTHON= yes
USE_PERL5= build
USE_BZIP2= yes
-USES+= bison perl5
+USES+= bison perl5 pkgconfig gmake
WITHOUT_CPU_CFLAGS= true
OPTIONS_DEFINE= GCONF GNOMEVFS
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index cdd1a44290d1..34eaaad2ed2f 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -26,7 +26,7 @@ USE_GSTREAMER= yes
#USE_GCC= 4.6+
USE_PYTHON= yes
USE_BZIP2= yes
-USES+= bison perl5 gmake
+USES+= bison perl5 gmake pkgconfig
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 0b6597a55829..33de22bbbe73 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -27,7 +27,7 @@ USE_GSTREAMER= yes
#USE_GCC= 4.6+
USE_PYTHON= yes
USE_BZIP2= yes
-USES+= bison perl5 gmake
+USES+= bison perl5 gmake pkgconfig
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
diff --git a/games/pink-pony/Makefile b/games/pink-pony/Makefile
index f412c463b378..226d90127a5a 100644
--- a/games/pink-pony/Makefile
+++ b/games/pink-pony/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
BUILD_DEPENDS= ${LOCALBASE}/lib/libaudiere.so:${PORTSDIR}/audio/audiere
RUN_DEPENDS= ${LOCALBASE}/lib/libaudiere.so:${PORTSDIR}/audio/audiere
+USES= pkgconfig
USE_BZIP2= yes
USE_SCONS= yes
USE_GL= gl glu
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index 4b65bf26a4dc..0f7ffc9d6cc6 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib1
+USES= pkgconfig
+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index c279066038ad..5d21c256db0d 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2
LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
mikmod:${PORTSDIR}/audio/libmikmod
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_SDL= image sdl
NO_INSTALL_MANPAGES= yes
DATAVERSION= 0.7.0
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index ab5a8bd6977b..6451053f5d3c 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -24,7 +24,7 @@ PLUGINS_DESC= Compile additional libpurple-plugins
USE_RC_SUBR= minbif
USE_GNOME= glib20
USE_EFL= imlib2
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DENABLE_IMLIB:BOOL=ON
CFLAGS+= ${PTHREAD_CFLAGS} -DX_DISPLAY_MISSING
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index 009bbbb4b840..8f6e1d91688d 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= gc-threaded.1:${PORTSDIR}/devel/boehm-gc-threaded
ONLY_FOR_ARCHS= i386 amd64
-USES= gmake
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool:env
USE_DOS2UNIX= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/multimedia/miro/Makefile b/multimedia/miro/Makefile
index 97c16b13b3ef..d71742f4c66c 100644
--- a/multimedia/miro/Makefile
+++ b/multimedia/miro/Makefile
@@ -32,10 +32,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb \
BUILD_WRKSRC= ${WRKSRC}/linux
INSTALL_WRKSRC= ${WRKSRC}/linux
-USE_GMAKE= yes
USE_GNOME= gconf2 gtk20
USE_GSTREAMER= python gconf
-USES= gettext
+USES= gettext gmake pkgconfig
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
USE_LDCONFIG= yes
diff --git a/multimedia/xbmc-addon-pvr/Makefile b/multimedia/xbmc-addon-pvr/Makefile
index b35d7db929e0..b39142f42479 100644
--- a/multimedia/xbmc-addon-pvr/Makefile
+++ b/multimedia/xbmc-addon-pvr/Makefile
@@ -13,6 +13,7 @@ COMMENT= XBMC PVR addons for various backends
BUILD_DEPENDS+= xbmc:${PORTSDIR}/multimedia/xbmc
RUN_DEPENDS+= xbmc:${PORTSDIR}/multimedia/xbmc
+USES= pkgconfig
USE_GL= gl
USE_AUTOTOOLS= libtoolize aclocal libtool automake autoconf
MAKE_JOBS_SAFE= yes
diff --git a/net-p2p/gnunet-gtk/Makefile b/net-p2p/gnunet-gtk/Makefile
index ed92ba70addf..7a38cb821a3d 100644
--- a/net-p2p/gnunet-gtk/Makefile
+++ b/net-p2p/gnunet-gtk/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gnunet-gtk
-# Date created: Dec. 19, 2011
-# Whom: bf
-#
+# Created by: bf
# $FreeBSD$
-#
PORTNAME= gnunet-gtk
DISTVERSION= 0.9.3
@@ -22,8 +17,7 @@ LIB_DEPENDS= gladeui-1:${PORTSDIR}/devel/glade3 \
INSTALLS_ICONS = yes
USE_AUTOTOOLS= libltdl libtool
-USE_GMAKE= yes
-USES= pathfix iconv
+USES= pathfix iconv gmake pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS = --with-extractor=${LOCALBASE} \
diff --git a/net/xrdp-devel/Makefile b/net/xrdp-devel/Makefile
index 5bab053e03b5..f31dd514c33d 100644
--- a/net/xrdp-devel/Makefile
+++ b/net/xrdp-devel/Makefile
@@ -18,6 +18,7 @@ COMMENT= An open source Remote Desktop Protocol (RDP) server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= pkgconfig
USE_XORG= x11 xfixes
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
diff --git a/print/kover/Makefile b/print/kover/Makefile
index 068b8e5a3f45..b1d415fb9e89 100644
--- a/print/kover/Makefile
+++ b/print/kover/Makefile
@@ -19,7 +19,7 @@ USE_KDE4= automoc4 kdehier kdeprefix kdelibs sharedmime
USE_QT4= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
USE_PERL5= build
-USES= cmake gettext perl5
+USES= cmake gettext perl5 pkgconfig
MAN1= kover.1
diff --git a/security/razorback-fsMonitor/Makefile b/security/razorback-fsMonitor/Makefile
index 3561261d0a40..3f5659c0df0b 100644
--- a/security/razorback-fsMonitor/Makefile
+++ b/security/razorback-fsMonitor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-fsMonitor
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= fsMonitor
PORTVERSION= 0.5.0
@@ -21,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api \
fam.0:${PORTSDIR}/devel/fam
+USES= pkgconfig
+
OPTIONS_DEFINE= DEBUG ASSERT
.include <bsd.port.options.mk>
diff --git a/sysutils/gigolo/Makefile b/sysutils/gigolo/Makefile
index c1d61a9ac674..7941e9bb8c4e 100644
--- a/sysutils/gigolo/Makefile
+++ b/sysutils/gigolo/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
USE_BZIP2= yes
-USES= fuse
+USES= fuse pkgconfig
USE_GNOME= gtk20 gvfs
USE_XORG= x11
USE_PYTHON= yes
diff --git a/sysutils/libfvde/Makefile b/sysutils/libfvde/Makefile
index cd130360e12b..66930816b620 100644
--- a/sysutils/libfvde/Makefile
+++ b/sysutils/libfvde/Makefile
@@ -12,6 +12,7 @@ COMMENT= Library and tools for reading FileVault (FVDE) encrypted volumes
LICENSE= LGPL3
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= libxml2 gnomehack
USE_LDCONFIG= yes
diff --git a/x11-themes/gtk-qt4-engine/Makefile b/x11-themes/gtk-qt4-engine/Makefile
index da25f0aba569..12fe65d7fa50 100644
--- a/x11-themes/gtk-qt4-engine/Makefile
+++ b/x11-themes/gtk-qt4-engine/Makefile
@@ -13,7 +13,7 @@ COMMENT= GTK+ 2.x theme engine allowing to use Qt/KDE styles
USE_BZIP2= yes
USE_GNOME= gtk20
USE_QT4= corelib gui moc_build rcc_build uic_build qmake_build
-USES= cmake gettext
+USES= cmake gettext pkgconfig
USE_KDE4= kdelibs kdeprefix automoc4
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/x11-themes/kde-gtk-config/Makefile b/x11-themes/kde-gtk-config/Makefile
index 9e5115d39ad6..fe577edcb7e2 100644
--- a/x11-themes/kde-gtk-config/Makefile
+++ b/x11-themes/kde-gtk-config/Makefile
@@ -9,7 +9,7 @@ MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
MAINTAINER= kde@FreeBSD.org
COMMENT= GTK2 and GTK3 Configurator for KDE
-USES= cmake:outsource
+USES= cmake:outsource pkgconfig
USE_GNOME= gtk20 gtk30
USE_KDE4= automoc4 kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/x11-toolkits/vtkfox/Makefile b/x11-toolkits/vtkfox/Makefile
index f28d36ba202c..db247f19d168 100644
--- a/x11-toolkits/vtkfox/Makefile
+++ b/x11-toolkits/vtkfox/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS+= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
CMAKE_ARGS+= -DFOX17:BOOL=TRUE
.endif
-USES= cmake:outsource
+USES= cmake:outsource pkgconfig
USE_LDCONFIG= yes
PLIST_FILES= include/vtkfox/FXVTKCanvas.h \