aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pure-audio/Makefile46
-rw-r--r--audio/pure-audio/distinfo2
-rw-r--r--audio/pure-audio/pkg-descr7
-rw-r--r--audio/pure-audio/pkg-plist11
5 files changed, 67 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ae938338a5b5..22e5fcb18cbd 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -613,6 +613,7 @@
SUBDIR += prokyon3
SUBDIR += puddletag
SUBDIR += pulseaudio
+ SUBDIR += pure-audio
SUBDIR += py-ao
SUBDIR += py-apetag
SUBDIR += py-cddb
diff --git a/audio/pure-audio/Makefile b/audio/pure-audio/Makefile
new file mode 100644
index 000000000000..f37e812fa525
--- /dev/null
+++ b/audio/pure-audio/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: pure-gtk
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-audio
+PORTVERSION= 0.4
+CATEGORIES= audio
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A digital audio interface for the Pure language
+
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure \
+ portaudio.2:${PORTSDIR}/audio/portaudio2 \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ fftw3:${PORTSDIR}/math/fftw3
+
+#RUN_DEPENDS+= ${LOCALBASE}/lib/pure/ffi.pure:${PORTSDIR}/devel/pure-ffi
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GMAKE= yes
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib CFLAGS="${CFLAGS}"
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s|-lportaudio|-I${LOCALBASE}/include/portaudio2 -L${LOCALBASE}/lib/portaudio2 -lportaudio|" \
+ -e "s|portaudio.h|portaudio2/portaudio.h|g" \
+ ${WRKSRC}/Makefile
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/pure-audio/distinfo b/audio/pure-audio/distinfo
new file mode 100644
index 000000000000..cd131f6af792
--- /dev/null
+++ b/audio/pure-audio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-audio-0.4.tar.gz) = f6d96436415805778fb138fb7efe7588c9460e4f5bf26b50e2ec9b73d2564d38
+SIZE (pure-audio-0.4.tar.gz) = 38730
diff --git a/audio/pure-audio/pkg-descr b/audio/pure-audio/pkg-descr
new file mode 100644
index 000000000000..519e9cde8413
--- /dev/null
+++ b/audio/pure-audio/pkg-descr
@@ -0,0 +1,7 @@
+pure-audio is a digital audio interface for the Pure programming language.
+It currently includes wrappers for PortAudio, FFTW3, libsndfile and
+libsamplerate, as well as a realtime module which gives Pure scripts access
+to realtime scheduling on systems which have a pthreads library with the
+POSIX realtime threads extension.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-audio.html
diff --git a/audio/pure-audio/pkg-plist b/audio/pure-audio/pkg-plist
new file mode 100644
index 000000000000..eb2c87fdd2cb
--- /dev/null
+++ b/audio/pure-audio/pkg-plist
@@ -0,0 +1,11 @@
+lib/pure/audio.pure
+lib/pure/audio.so
+lib/pure/fftw.pure
+lib/pure/fftw.so
+lib/pure/portaudio.pure
+lib/pure/realtime.pure
+lib/pure/realtime.so
+lib/pure/samplerate.pure
+lib/pure/sfinfo.so
+lib/pure/sndfile.pure
+lib/pure/srcprocess.so