aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/hashish/Makefile2
-rw-r--r--security/hashish/files/patch-src::main.cpp14
2 files changed, 14 insertions, 2 deletions
diff --git a/security/hashish/Makefile b/security/hashish/Makefile
index 2167f331c223..13f99df3f9f6 100644
--- a/security/hashish/Makefile
+++ b/security/hashish/Makefile
@@ -25,8 +25,6 @@ LIB_DEPENDS= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
.endif
-BROKEN= "Does not compile"
-
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/security/hashish/files/patch-src::main.cpp b/security/hashish/files/patch-src::main.cpp
new file mode 100644
index 000000000000..2d6e98418f03
--- /dev/null
+++ b/security/hashish/files/patch-src::main.cpp
@@ -0,0 +1,14 @@
+--- src/main.cpp.orig Sun Dec 12 21:15:50 2004
++++ src/main.cpp Sun Dec 12 21:16:30 2004
+@@ -398,9 +398,9 @@
+ hashFilter = new HashFilter(*hash, new Base64Encoder(new StringSink(outstring), false));
+
+ if ((m_rbox->GetSelection() == 0))
+- FileSource file1(m_filename->GetValue().c_str(), true, new Redirector(*hashFilter, false));
++ FileSource file1(m_filename->GetValue().c_str(), true, new Redirector(*hashFilter));
+ else
+- StringSource string1(m_string->GetValue().c_str(), true, new Redirector(*hashFilter, false));
++ StringSource string1(m_string->GetValue().c_str(), true, new Redirector(*hashFilter));
+
+ hashFilter->MessageEnd();
+