aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gmpc-mdcover/Makefile25
-rw-r--r--audio/gmpc-mdcover/distinfo3
-rw-r--r--audio/gmpc-mdcover/pkg-descr4
-rw-r--r--audio/gmpc-mdcover/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ac3b111bdba4..5916012b7e06 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -198,6 +198,7 @@
SUBDIR += gmidimonitor
SUBDIR += gmixer
SUBDIR += gmpc
+ SUBDIR += gmpc-mdcover
SUBDIR += gmpc-osd
SUBDIR += gmpc-qosd
SUBDIR += gmpc-serverstats
diff --git a/audio/gmpc-mdcover/Makefile b/audio/gmpc-mdcover/Makefile
new file mode 100644
index 000000000000..2b03ac9e9079
--- /dev/null
+++ b/audio/gmpc-mdcover/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-lyrics
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-mdcover
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Directory artist/song plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-mdcover/distinfo b/audio/gmpc-mdcover/distinfo
new file mode 100644
index 000000000000..664696802eb6
--- /dev/null
+++ b/audio/gmpc-mdcover/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-mdcover-0.15.0.tar.gz) = db87cdd47b5179013ed90a63cc22ece2
+SHA256 (gmpc-mdcover-0.15.0.tar.gz) = 3b166cabcd0d4a0d122715f81dbd62ee6511847b386d13f3e7001d9457d2b8cc
+SIZE (gmpc-mdcover-0.15.0.tar.gz) = 308903
diff --git a/audio/gmpc-mdcover/pkg-descr b/audio/gmpc-mdcover/pkg-descr
new file mode 100644
index 000000000000..689d184b7edc
--- /dev/null
+++ b/audio/gmpc-mdcover/pkg-descr
@@ -0,0 +1,4 @@
+This plugin fetches cover art, artist art,album and artist information
+from the file system.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-mdcover/pkg-plist b/audio/gmpc-mdcover/pkg-plist
new file mode 100644
index 000000000000..1cf0bb8e3712
--- /dev/null
+++ b/audio/gmpc-mdcover/pkg-plist
@@ -0,0 +1,3 @@
+share/gmpc/plugins/mdcaplugin.so
+@dirrm share/gmpc/plugins
+@dirrm share/gmpc
2008-07-202-4/+4 * - Update to 2.20 (2.2)clsung2008-04-213-4/+6 * - Update to 2.10 (2.1)clsung2008-04-072-5/+5 * - Update to 2.01clsung2008-01-05