aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/adodb/Makefile1
-rw-r--r--databases/adodb/files/patch-adodb-odbc.inc.php20
2 files changed, 21 insertions, 0 deletions
diff --git a/databases/adodb/Makefile b/databases/adodb/Makefile
index 5c6740d5005f..11b14d74f0f1 100644
--- a/databases/adodb/Makefile
+++ b/databases/adodb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= adodb
PORTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= http://phplens.com/lens/dl/
DISTNAME= ${PORTNAME}112
diff --git a/databases/adodb/files/patch-adodb-odbc.inc.php b/databases/adodb/files/patch-adodb-odbc.inc.php
new file mode 100644
index 000000000000..159b2488a12e
--- /dev/null
+++ b/databases/adodb/files/patch-adodb-odbc.inc.php
@@ -0,0 +1,20 @@
+--- adodb-odbc.inc.php.orig Wed Jun 6 06:17:56 2001
++++ adodb-odbc.inc.php Thu Jun 28 10:00:41 2001
+@@ -310,7 +310,7 @@
+ {
+ if ($this->_numOfRows != 0 && !$this->EOF) {
+ $this->_currentRow++;
+- if (odbc_fetch_into($this->_queryID,0,$this->fields)) return true;
++ if (odbc_fetch_into($this->_queryID,$row=0,$this->fields)) return true;
+ }
+ $this->EOF = true;
+ return false;
+@@ -318,7 +318,7 @@
+
+ function _fetch($ignore_fields=false)
+ {
+- return odbc_fetch_into($this->_queryID,0,$this->fields);
++ return odbc_fetch_into($this->_queryID,$row=0,$this->fields);
+ }
+
+ function _close() {