aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/crashecho/Makefile31
-rw-r--r--mail/crashecho/distinfo1
-rw-r--r--mail/crashecho/pkg-descr4
-rw-r--r--mail/crashecho/pkg-plist10
5 files changed, 47 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b48f6d4730a6..3400fe0973e6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -26,6 +26,7 @@
SUBDIR += coolmail
SUBDIR += courier
SUBDIR += courier-imap
+ SUBDIR += crashecho
SUBDIR += cucipop
SUBDIR += cvsmail
SUBDIR += cyrus
diff --git a/mail/crashecho/Makefile b/mail/crashecho/Makefile
new file mode 100644
index 000000000000..1b81b3a56547
--- /dev/null
+++ b/mail/crashecho/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: crashecho
+# Date created: 15 November 2002
+# Whom: CyrilM <cyrilm@tower.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crashecho
+PORTVERSION= 0.2.14
+CATEGORIES= mail
+MASTER_SITES= http://hell.binec.ru/crashecho/
+
+MAINTAINER= cyrilm@tower.pp.ru
+COMMENT= An FTN JAM and *.MSG tosser
+
+LIB_DEPENDS= jam.2:${PORTSDIR}/mail/jamlib
+
+USE_LIBTOOL=yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= crashecho.1 \
+ crashexport.1 \
+ crashmaint.1 \
+ crashstats.1 \
+ crashwrite.1
+MAN5= crashecho.conf.5
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/ftn
+ ${INSTALL_DATA} ${WRKSRC}/doc/crashecho.conf ${PREFIX}/etc/ftn/crashecho.conf.sample
+.include <bsd.port.mk>
diff --git a/mail/crashecho/distinfo b/mail/crashecho/distinfo
new file mode 100644
index 000000000000..adb595f7bd03
--- /dev/null
+++ b/mail/crashecho/distinfo
@@ -0,0 +1 @@
+MD5 (crashecho-0.2.14.tar.gz) = c1df52abdef84d28cdfe46b5feeaa77c
diff --git a/mail/crashecho/pkg-descr b/mail/crashecho/pkg-descr
new file mode 100644
index 000000000000..71795c829e1c
--- /dev/null
+++ b/mail/crashecho/pkg-descr
@@ -0,0 +1,4 @@
+CrashEcho is a successor of a CrashMail II tosser originally written
+by Johan Billing.
+
+WWW: http://hell.binec.ru/crashecho
diff --git a/mail/crashecho/pkg-plist b/mail/crashecho/pkg-plist
new file mode 100644
index 000000000000..01ea3c7ca8ec
--- /dev/null
+++ b/mail/crashecho/pkg-plist
@@ -0,0 +1,10 @@
+bin/crashecho
+bin/crashexport
+bin/crashstats
+bin/crashwrite
+bin/crashmaint
+bin/crashconvdupebase
+etc/ftn/crashecho.conf.sample
+share/crashecho/AreafixHelp.txt
+@dirrm etc/ftn
+@dirrm share/crashecho