aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/squid/Makefile11
-rw-r--r--www/squid22/Makefile11
-rw-r--r--www/squid23/Makefile11
-rw-r--r--www/squid24/Makefile11
-rw-r--r--www/squid25/Makefile11
-rw-r--r--www/squid26/Makefile11
-rw-r--r--www/squid27/Makefile11
-rw-r--r--www/squid30/Makefile11
-rw-r--r--www/squid31/Makefile11
9 files changed, 90 insertions, 9 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid22/Makefile b/www/squid22/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid22/Makefile
+++ b/www/squid22/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid23/Makefile b/www/squid23/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid23/Makefile
+++ b/www/squid23/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid24/Makefile b/www/squid24/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid24/Makefile
+++ b/www/squid24/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}