aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gmpc-stopbutton/Makefile25
-rw-r--r--audio/gmpc-stopbutton/distinfo3
-rw-r--r--audio/gmpc-stopbutton/pkg-descr4
-rw-r--r--audio/gmpc-stopbutton/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f3987cd424f2..5f5e5e6ec333 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -203,6 +203,7 @@
SUBDIR += gmpc-osd
SUBDIR += gmpc-qosd
SUBDIR += gmpc-serverstats
+ SUBDIR += gmpc-stopbutton
SUBDIR += gmpccaa
SUBDIR += gnapster
SUBDIR += gnomad2
diff --git a/audio/gmpc-stopbutton/Makefile b/audio/gmpc-stopbutton/Makefile
new file mode 100644
index 000000000000..0dce52f7f0ff
--- /dev/null
+++ b/audio/gmpc-stopbutton/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpccaa
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-stopbutton
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Stop button for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-stopbutton/distinfo b/audio/gmpc-stopbutton/distinfo
new file mode 100644
index 000000000000..2ed5f7d55f34
--- /dev/null
+++ b/audio/gmpc-stopbutton/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-stopbutton-0.15.0.tar.gz) = d6fa3c171d9ba18c70ee096faf69ed5e
+SHA256 (gmpc-stopbutton-0.15.0.tar.gz) = da98c487b5156c5f8b12ebfc0ef448f01f014da827c4981f3821fc2db9658223
+SIZE (gmpc-stopbutton-0.15.0.tar.gz) = 299504
diff --git a/audio/gmpc-stopbutton/pkg-descr b/audio/gmpc-stopbutton/pkg-descr
new file mode 100644
index 000000000000..b1af59a76ccf
--- /dev/null
+++ b/audio/gmpc-stopbutton/pkg-descr
@@ -0,0 +1,4 @@
+This is the simplest plugin of the lot, it adds a stop button to the controls
+in the main window. It's an easy solution to keep everybody happy.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-stopbutton/pkg-plist b/audio/gmpc-stopbutton/pkg-plist
new file mode 100644
index 000000000000..f486873735e5
--- /dev/null
+++ b/audio/gmpc-stopbutton/pkg-plist
@@ -0,0 +1,3 @@
+share/gmpc/plugins/libstopbutton.so
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc