aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/calligra/Makefile4
-rw-r--r--editors/calligra/files/patch-filters-kword-msword14
-rw-r--r--editors/koffice-kde3/Makefile4
-rw-r--r--editors/koffice-kde3/files/patch-filters-kword-msword14
-rw-r--r--editors/koffice-kde4/Makefile4
-rw-r--r--editors/koffice-kde4/files/patch-filters-kword-msword14
-rw-r--r--textproc/wv2/Makefile2
-rw-r--r--textproc/wv2/distinfo6
-rw-r--r--textproc/wv2/pkg-plist4
9 files changed, 54 insertions, 12 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index be942e9d1c82..36d08acd55a9 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 1.6.3
-PORTREVISION= 10
+PORTREVISION= 11
PORTEPOCH= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -28,7 +28,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
paper.2:${PORTSDIR}/print/libpaper \
poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
- wv2.3:${PORTSDIR}/textproc/wv2
+ wv2.4:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:22
diff --git a/editors/calligra/files/patch-filters-kword-msword b/editors/calligra/files/patch-filters-kword-msword
index 6fbec03cc5a2..070bdacc3903 100644
--- a/editors/calligra/files/patch-filters-kword-msword
+++ b/editors/calligra/files/patch-filters-kword-msword
@@ -67,3 +67,17 @@
m_tap->rgtc[ m_column + 1 ].brcLeft
: tc.brcRight;
+--- filters/kword/msword/texthandler.cpp.orig 2007-05-31 08:39:22.000000000 +1100
++++ filters/kword/msword/texthandler.cpp 2009-10-11 15:50:25.000000000 +1100
+@@ -322,9 +322,9 @@
+ format.setAttribute( "pos", pos );
+ format.setAttribute( "len", len );
+
+- if ( !refChp || refChp->ico != chp->ico )
++ if ( !refChp || refChp->cv != chp->cv )
+ {
+- QColor color = Conversion::color( chp->ico, -1 );
++ QColor color = Conversion::color( chp->cv, -1 );
+ QDomElement colorElem( mainDocument().createElement( "COLOR" ) );
+ colorElem.setAttribute( "red", color.red() );
+ colorElem.setAttribute( "blue", color.blue() );
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index be942e9d1c82..36d08acd55a9 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 1.6.3
-PORTREVISION= 10
+PORTREVISION= 11
PORTEPOCH= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -28,7 +28,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
paper.2:${PORTSDIR}/print/libpaper \
poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
- wv2.3:${PORTSDIR}/textproc/wv2
+ wv2.4:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:22
diff --git a/editors/koffice-kde3/files/patch-filters-kword-msword b/editors/koffice-kde3/files/patch-filters-kword-msword
index 6fbec03cc5a2..070bdacc3903 100644
--- a/editors/koffice-kde3/files/patch-filters-kword-msword
+++ b/editors/koffice-kde3/files/patch-filters-kword-msword
@@ -67,3 +67,17 @@
m_tap->rgtc[ m_column + 1 ].brcLeft
: tc.brcRight;
+--- filters/kword/msword/texthandler.cpp.orig 2007-05-31 08:39:22.000000000 +1100
++++ filters/kword/msword/texthandler.cpp 2009-10-11 15:50:25.000000000 +1100
+@@ -322,9 +322,9 @@
+ format.setAttribute( "pos", pos );
+ format.setAttribute( "len", len );
+
+- if ( !refChp || refChp->ico != chp->ico )
++ if ( !refChp || refChp->cv != chp->cv )
+ {
+- QColor color = Conversion::color( chp->ico, -1 );
++ QColor color = Conversion::color( chp->cv, -1 );
+ QDomElement colorElem( mainDocument().createElement( "COLOR" ) );
+ colorElem.setAttribute( "red", color.red() );
+ colorElem.setAttribute( "blue", color.blue() );
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index be942e9d1c82..36d08acd55a9 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 1.6.3
-PORTREVISION= 10
+PORTREVISION= 11
PORTEPOCH= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -28,7 +28,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
paper.2:${PORTSDIR}/print/libpaper \
poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
- wv2.3:${PORTSDIR}/textproc/wv2
+ wv2.4:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:22
diff --git a/editors/koffice-kde4/files/patch-filters-kword-msword b/editors/koffice-kde4/files/patch-filters-kword-msword
index 6fbec03cc5a2..070bdacc3903 100644
--- a/editors/koffice-kde4/files/patch-filters-kword-msword
+++ b/editors/koffice-kde4/files/patch-filters-kword-msword
@@ -67,3 +67,17 @@
m_tap->rgtc[ m_column + 1 ].brcLeft
: tc.brcRight;
+--- filters/kword/msword/texthandler.cpp.orig 2007-05-31 08:39:22.000000000 +1100
++++ filters/kword/msword/texthandler.cpp 2009-10-11 15:50:25.000000000 +1100
+@@ -322,9 +322,9 @@
+ format.setAttribute( "pos", pos );
+ format.setAttribute( "len", len );
+
+- if ( !refChp || refChp->ico != chp->ico )
++ if ( !refChp || refChp->cv != chp->cv )
+ {
+- QColor color = Conversion::color( chp->ico, -1 );
++ QColor color = Conversion::color( chp->cv, -1 );
+ QDomElement colorElem( mainDocument().createElement( "COLOR" ) );
+ colorElem.setAttribute( "red", color.red() );
+ colorElem.setAttribute( "blue", color.blue() );
diff --git a/textproc/wv2/Makefile b/textproc/wv2/Makefile
index b6e51d861f56..2c46cb242e21 100644
--- a/textproc/wv2/Makefile
+++ b/textproc/wv2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wv2
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.2
CATEGORIES= textproc
MASTER_SITES= SF/wvware/
diff --git a/textproc/wv2/distinfo b/textproc/wv2/distinfo
index d124c3a5433c..fe8d532dbbe1 100644
--- a/textproc/wv2/distinfo
+++ b/textproc/wv2/distinfo
@@ -1,3 +1,3 @@
-MD5 (wv2-0.4.0.tar.bz2) = e0acd7a551c898aab3fb6afafc606bb4
-SHA256 (wv2-0.4.0.tar.bz2) = 0c6595e16cf9c5ec33ba0d653d3a980ac9df96f12f416645e01119bb299525d1
-SIZE (wv2-0.4.0.tar.bz2) = 452586
+MD5 (wv2-0.4.2.tar.bz2) = 850ed8e44a84e7bf0610747827018cbc
+SHA256 (wv2-0.4.2.tar.bz2) = 9f2b6d3910cb0e29c9ff432f935a594ceec0101bca46ba2fc251aff251ee38dc
+SIZE (wv2-0.4.2.tar.bz2) = 452759
diff --git a/textproc/wv2/pkg-plist b/textproc/wv2/pkg-plist
index 95579f3e83fe..c39b12fb8ec6 100644
--- a/textproc/wv2/pkg-plist
+++ b/textproc/wv2/pkg-plist
@@ -27,8 +27,8 @@ include/wv2/wvlog.h
include/wv2/zcodec.hxx
lib/libwv2.la
lib/libwv2.so
-lib/libwv2.so.3
-lib/libwv2.so.3.0.0
+lib/libwv2.so.4
+lib/libwv2.so.4.0.1
lib/wvWare/wv2.cmake
lib/wvWare/wv2-noconfig.cmake
@dirrm lib/wvWare