aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/cherokee/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index ad461f7813a0..8c790e472a0b 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -74,8 +74,9 @@ OPTIONS= WWWUSER "Run as www:www user" on \
FFMPEG "FFMpeg Support" off \
NLS "NLS Support" on \
INTPCRE "Use Internal PCRE Library" off \
- ADMIN "Build the Admin Interface" on \
- RRDTOOL "Usage Graphs Support" off
+ ADMIN "Build the Admin Interface" on \
+ RRDTOOL "Usage Graphs Support" off \
+ UWSGI "uWSGI Support" off
.include <bsd.port.options.mk>
@@ -150,6 +151,10 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool
.endif
+.ifdef WITH_UWSGI
+RUN_DEPENDS+= uwsgi:${PORTSDIR}/www/uwsgi
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|@mkdir_p@|${MKDIR} --|g'