aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/erlslang/Makefile2
-rw-r--r--devel/esdl/Makefile1
-rw-r--r--devel/syntax_tools/Makefile1
-rw-r--r--graphics/wings-devel/Makefile3
-rw-r--r--graphics/wings/Makefile3
-rw-r--r--net/erlang_xmlrpc/Makefile2
-rw-r--r--textproc/xmerl/Makefile1
-rw-r--r--x11-toolkits/erlgtk/Makefile2
8 files changed, 11 insertions, 4 deletions
diff --git a/devel/erlslang/Makefile b/devel/erlslang/Makefile
index 8a8811087590..67ad2f7b99ed 100644
--- a/devel/erlslang/Makefile
+++ b/devel/erlslang/Makefile
@@ -20,7 +20,7 @@ COMMENT= SLang binding for Erlang/OTP
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
-RUN_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index 2b2cf172b961..5cb77b65b4e9 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= A library for accessing SDL and OpenGL through Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/devel/syntax_tools/Makefile b/devel/syntax_tools/Makefile
index f5dda5840b76..6eea63d0d24b 100644
--- a/devel/syntax_tools/Makefile
+++ b/devel/syntax_tools/Makefile
@@ -19,6 +19,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Erlang modules for code manipulation
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/graphics/wings-devel/Makefile b/graphics/wings-devel/Makefile
index 48da52c363c5..99d4bc7baeff 100644
--- a/graphics/wings-devel/Makefile
+++ b/graphics/wings-devel/Makefile
@@ -17,7 +17,8 @@ COMMENT= A polygon mesh modeler written in Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
-RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ ${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
MAKE_ENV= ESDL_PATH=${LOCALBASE}/lib/erlang/lib/esdl
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/graphics/wings/Makefile b/graphics/wings/Makefile
index 48da52c363c5..99d4bc7baeff 100644
--- a/graphics/wings/Makefile
+++ b/graphics/wings/Makefile
@@ -17,7 +17,8 @@ COMMENT= A polygon mesh modeler written in Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
-RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ ${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
MAKE_ENV= ESDL_PATH=${LOCALBASE}/lib/erlang/lib/esdl
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/net/erlang_xmlrpc/Makefile b/net/erlang_xmlrpc/Makefile
index be9ab936e58e..8c3c296367cf 100644
--- a/net/erlang_xmlrpc/Makefile
+++ b/net/erlang_xmlrpc/Makefile
@@ -18,6 +18,8 @@ COMMENT= A library for XMLRPC support in Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
${LOCALBASE}/lib/erlang/lib/xmerl/inc/xmerl.hrl:${PORTSDIR}/textproc/xmerl
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ ${LOCALBASE}/lib/erlang/lib/xmerl/inc/xmerl.hrl:${PORTSDIR}/textproc/xmerl
USE_GMAKE= yes
USE_REINPLACE= yes
diff --git a/textproc/xmerl/Makefile b/textproc/xmerl/Makefile
index 401274725950..96c7ca86a937 100644
--- a/textproc/xmerl/Makefile
+++ b/textproc/xmerl/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= A library for XML processing in Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erlc:${PORTSDIR}/lang/erlang
USE_GMAKE= yes
diff --git a/x11-toolkits/erlgtk/Makefile b/x11-toolkits/erlgtk/Makefile
index 0e29a0a8377e..4fe708838163 100644
--- a/x11-toolkits/erlgtk/Makefile
+++ b/x11-toolkits/erlgtk/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= chris_pressey@yahoo.ca
COMMENT= GTK+ 1.2 binding for Erlang/OTP
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
-RUN_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
PLIST_SUB= VERSION="${PORTVERSION}"