aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/courier-imap/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index fcf9dd829438..be5c52453a40 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -64,7 +64,8 @@ CONFIGURE_ARGS= --without-authshadow \
--libexecdir=${LIBEXECDIR} \
--enable-workarounds-for-imap-client-bugs \
--enable-unicode \
- --disable-root-check
+ --disable-root-check \
+ --with-locking-method=fcntl
.if !defined(WITH_VPOPMAIL)
CONFIGURE_ARGS+= --without-authvchkpw
@@ -157,9 +158,12 @@ EXTRA_DOCS= README INSTALL AUTHORS imap/ChangeLog
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -Ee \
- '/^ imapd.cnf pop3d.cnf/s/(imapd.cnf|pop3d.cnf)//g' \
+ @${REINPLACE_CMD} -e 's/^ imapd.cnf pop3d.cnf //' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^case x$$lockmethod in|${TEST} \&\& &|g' \
+ ${WRKSRC}/liblock/configure
+ @${REINPLACE_CMD} -e 's|$$VPOPMAILLIBS|& -lcrypt|g' \
+ ${WRKSRC}/authlib/configure
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/authlib/authtest ${PREFIX}/bin/