aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Simple/Makefile40
-rw-r--r--security/p5-Authen-Simple/distinfo3
-rw-r--r--security/p5-Authen-Simple/pkg-descr4
-rw-r--r--security/p5-Authen-Simple/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d350eb44d1d6..5c34dc949191 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -290,6 +290,7 @@
SUBDIR += p5-Authen-Radius
SUBDIR += p5-Authen-SASL
SUBDIR += p5-Authen-SASL-Cyrus
+ SUBDIR += p5-Authen-Simple
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
SUBDIR += p5-Authen-Ticket
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
new file mode 100644
index 000000000000..7aa944d03eb5
--- /dev/null
+++ b/security/p5-Authen-Simple/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Authen-Simple
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple
+PORTVERSION= 0.4
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple authentication framework
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple.3 \
+ Authen::Simple::Adapter.3 \
+ Authen::Simple::Apache.3 \
+ Authen::Simple::Log.3 \
+ Authen::Simple::Password.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple/distinfo b/security/p5-Authen-Simple/distinfo
new file mode 100644
index 000000000000..e0af5ba03bd2
--- /dev/null
+++ b/security/p5-Authen-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-0.4.tar.gz) = ca2ebc687e9282c92f488fa79e3e8723
+SHA256 (Authen-Simple-0.4.tar.gz) = be57f93ee087b86cb359796a86f48922b7a27300714b3070f16971b206eb8b05
+SIZE (Authen-Simple-0.4.tar.gz) = 8304
diff --git a/security/p5-Authen-Simple/pkg-descr b/security/p5-Authen-Simple/pkg-descr
new file mode 100644
index 000000000000..1f8b49eb32e2
--- /dev/null
+++ b/security/p5-Authen-Simple/pkg-descr
@@ -0,0 +1,4 @@
+Simple and consistent framework for authentication.
+
+WWW: http://search.cpan.org/dist/Authen-Simple
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple/pkg-plist b/security/p5-Authen-Simple/pkg-plist
new file mode 100644
index 000000000000..3071a14ce48e
--- /dev/null
+++ b/security/p5-Authen-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Authen/Simple.pm
+%%SITE_PERL%%/Authen/Simple/Adapter.pm
+%%SITE_PERL%%/Authen/Simple/Apache.pm
+%%SITE_PERL%%/Authen/Simple/Log.pm
+%%SITE_PERL%%/Authen/Simple/Password.pm
+@dirrm %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen
an> * - Update to 0.86.1 release [1]ale2004-11-011-5/+2 * Update to 0.84.2 release.ale2004-07-051-1/+0 * Mark IGNORE, since the new thunderbird extension manager doesn't allowale2004-06-291-0/+2 * - Update enigmail-thunderbird to 0.84.1ale2004-06-271-1/+4 * Use slave pkg-message for slave port.ale2004-05-251-0/+1 * - Update to 0.84.0 releaseale2004-05-101-1/+0 * - support for thunderbird 0.6ale2004-05-041-1/+2 * Fix location for Thunderbird 0.5.ale2004-02-281-1/+1 * Try to fix bento error (the correct way to locate the wrkdir ofale2004-02-231-5/+3 * BROKEN: Does not compilekris2004-02-231-0/+2 * Respect WRKDIRPREFIX.ale2004-02-161-1/+1 * mozilla-thunderbird is now just thunderbird.marcus2004-02-151-1/+1 * - Fix build, restoring my original intention of copying the mozilla WRKSRCale2004-01-301-1/+1