aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/queryperf/Makefile32
-rw-r--r--dns/queryperf/distinfo2
-rw-r--r--dns/queryperf/files/patch-contrib::queryperf::Makefile.in11
-rw-r--r--dns/queryperf/pkg-descr8
-rw-r--r--dns/queryperf/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 2ce0b1109069..19d94173de78 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -78,6 +78,7 @@
SUBDIR += py-dns
SUBDIR += py-dnspython
SUBDIR += py-twistedNames
+ SUBDIR += queryperf
SUBDIR += rbldnsd
SUBDIR += rbllookup
SUBDIR += scavenge
diff --git a/dns/queryperf/Makefile b/dns/queryperf/Makefile
new file mode 100644
index 000000000000..809a7308c31f
--- /dev/null
+++ b/dns/queryperf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: qyeryfile
+# Date created: 28 August 2005
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= queryperf
+PORTVERSION= 1.1.1.2.2.5.4.3
+CATEGORIES= dns net benchmarks
+MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITE_SUBDIR= bind9/${BINDVERSION}
+DISTNAME= bind-${BINDVERSION}
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= DNS Query Perforamnce Testing Tool
+
+BINDVERSION= 9.3.1
+WRKSRC= ${WRKDIR}/bind-${BINDVERSION}/contrib/queryperf/
+HAS_CONFIGURE= yes
+USE_PYTHON_RUN= yes
+PORTDOCS= queryperf.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/queryperf ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/utils/gen-data-queryperf.py ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/queryperf.txt
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/queryperf/distinfo b/dns/queryperf/distinfo
new file mode 100644
index 000000000000..531f36b6f21d
--- /dev/null
+++ b/dns/queryperf/distinfo
@@ -0,0 +1,2 @@
+MD5 (bind-9.3.1.tar.gz) = 9ff3204eea27184ea0722f37e43fc95d
+SIZE (bind-9.3.1.tar.gz) = 4673603
diff --git a/dns/queryperf/files/patch-contrib::queryperf::Makefile.in b/dns/queryperf/files/patch-contrib::queryperf::Makefile.in
new file mode 100644
index 000000000000..4d62eb0adcd6
--- /dev/null
+++ b/dns/queryperf/files/patch-contrib::queryperf::Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Aug 21 18:28:34 2005
++++ Makefile.in Sun Aug 21 18:29:20 2005
+@@ -5,6 +5,8 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@
+
++all: queryperf
++
+ queryperf: queryperf.o $(LIBOBJS)
+ $(CC) $(CFLAGS) $(DEFS) $(LDFLAGS) queryperf.o $(LIBOBJS) $(LIBS) -lm -o queryperf
+
diff --git a/dns/queryperf/pkg-descr b/dns/queryperf/pkg-descr
new file mode 100644
index 000000000000..866b78e3e156
--- /dev/null
+++ b/dns/queryperf/pkg-descr
@@ -0,0 +1,8 @@
+This is queryperf, a DNS server query performance testing tool.
+
+It is primarily intended for measuring the performance of authoritative
+DNS servers, but it has also been used for measuring caching server
+performance.
+
+See /usr/local/share/docs/queryperf//queryperf.txt for more information
+on the command line option and the required configuration files.
diff --git a/dns/queryperf/pkg-plist b/dns/queryperf/pkg-plist
new file mode 100644
index 000000000000..41b3f4c61fd4
--- /dev/null
+++ b/dns/queryperf/pkg-plist
@@ -0,0 +1,2 @@
+bin/queryperf
+bin/gen-data-queryperf.py