aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile2
-rw-r--r--databases/rubygem-activemodel/Makefile23
-rw-r--r--databases/rubygem-activemodel/distinfo3
-rw-r--r--databases/rubygem-activemodel/pkg-descr6
-rw-r--r--databases/rubygem-activerecord/Makefile29
-rw-r--r--databases/rubygem-activerecord/distinfo6
-rw-r--r--databases/rubygem-arel/Makefile21
-rw-r--r--databases/rubygem-arel/distinfo3
-rw-r--r--databases/rubygem-arel/pkg-descr6
-rw-r--r--devel/rubygem-activesupport/Makefile5
-rw-r--r--devel/rubygem-activesupport/distinfo6
-rw-r--r--mail/rubygem-actionmailer/Makefile5
-rw-r--r--mail/rubygem-actionmailer/distinfo6
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-actionpack/Makefile12
-rw-r--r--www/rubygem-actionpack/distinfo6
-rw-r--r--www/rubygem-activeresource/Makefile5
-rw-r--r--www/rubygem-activeresource/distinfo6
-rw-r--r--www/rubygem-rails/Makefile46
-rw-r--r--www/rubygem-rails/distinfo6
-rw-r--r--www/rubygem-railties/Makefile24
-rw-r--r--www/rubygem-railties/distinfo3
-rw-r--r--www/rubygem-railties/pkg-descr3
23 files changed, 178 insertions, 55 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 686fc88f2b61..d816d33e521f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -693,6 +693,8 @@
SUBDIR += rubygem-activerecord
SUBDIR += rubygem-activerecord-jdbc-adapter
SUBDIR += rubygem-activerecord-jdbcmysql-adapter
+ SUBDIR += rubygem-activemodel
+ SUBDIR += rubygem-arel
SUBDIR += rubygem-bigrecord
SUBDIR += rubygem-data_objects
SUBDIR += rubygem-datamapper
diff --git a/databases/rubygem-activemodel/Makefile b/databases/rubygem-activemodel/Makefile
new file mode 100644
index 000000000000..b03adfdfe45f
--- /dev/null
+++ b/databases/rubygem-activemodel/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-activemodel
+# Date created: 1 September 2010
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= activemodel
+PORTVERSION= 3.0.0
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A toolkit for building modeling frameworks
+
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-builder>=2.1.2:${PORTSDIR}/devel/rubygem-builder \
+ rubygem-i18n>=0.4.1:${PORTSDIR}/devel/rubygem-i18n
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activemodel/distinfo b/databases/rubygem-activemodel/distinfo
new file mode 100644
index 000000000000..0e4dbbf47a91
--- /dev/null
+++ b/databases/rubygem-activemodel/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/activemodel-3.0.0.gem) = b3d661c545c8474bfe9e99af50c2778a
+SHA256 (rubygem/activemodel-3.0.0.gem) = 66d7f23e794b7959c7ba87091bcbe4294538b817a33984677b1715035d44e1b6
+SIZE (rubygem/activemodel-3.0.0.gem) = 37888
diff --git a/databases/rubygem-activemodel/pkg-descr b/databases/rubygem-activemodel/pkg-descr
new file mode 100644
index 000000000000..78901e699f22
--- /dev/null
+++ b/databases/rubygem-activemodel/pkg-descr
@@ -0,0 +1,6 @@
+A toolkit for building modeling frameworks like Active Record and
+Active Resource. Rich support for attributes, callbacks,
+validations, observers, serialization, internationalization,
+and testing.
+
+WWW: http://rubygems.org/gems/activemodel
diff --git a/databases/rubygem-activerecord/Makefile b/databases/rubygem-activerecord/Makefile
index 70d67462df1b..d4f8b025ae00 100644
--- a/databases/rubygem-activerecord/Makefile
+++ b/databases/rubygem-activerecord/Makefile
@@ -5,29 +5,32 @@
# $FreeBSD$
PORTNAME= activerecord
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Object-relational mapping layer for Rails MVC Framework
-RUN_DEPENDS= rubygem-activesupport>=2.3.4:${PORTSDIR}/devel/rubygem-activesupport
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-activemodel>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activemodel \
+ rubygem-tzinfo>=0.3.23:${PORTSDIR}/devel/rubygem-tzinfo \
+ rubygem-arel>=1.0.0:${PORTSDIR}/databases/rubygem-arel
-OPTIONS= NATIVE_MYSQL "Use native MySQL bindings" Off\
- NATIVE_POSTGRESQL "Use native PostgreSQL bindings" Off\
- NATIVE_SQLITE3 "Use native SQLite3 bindings" Off
-OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
-# to get RUBY_SITEARCHLIBDIR
-USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+OPTIONS= \
+ NATIVE_MYSQL "Use native MySQL bindings" Off \
+ NATIVE_POSTGRESQL "Use native PostgreSQL bindings" Off \
+ NATIVE_SQLITE3 "Use native SQLite3 bindings" Off
+OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_NATIVE_MYSQL)
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/mysql.so:${PORTSDIR}/databases/ruby-mysql
+RUN_DEPENDS+= ${RUBY_PKGNAMEPREFIX}mysql>0:${PORTSDIR}/databases/ruby-mysql
.endif
.if defined(WITH_NATIVE_POSTGRESQL)
@@ -38,4 +41,4 @@ RUN_DEPENDS+= rubygem-pg>=0:${PORTSDIR}/databases/rubygem-pg
RUN_DEPENDS+= rubygem-sqlite3>=1.2.1:${PORTSDIR}/databases/rubygem-sqlite3
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord/distinfo b/databases/rubygem-activerecord/distinfo
index f730095491fe..3b97e7bf931a 100644
--- a/databases/rubygem-activerecord/distinfo
+++ b/databases/rubygem-activerecord/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/activerecord-2.3.8.gem) = 16311c40a988bd9f8ffeb44799d9f488
-SHA256 (rubygem/activerecord-2.3.8.gem) = 0511305d423f450ffdeee89f0e52a390a34c224e5bd356fce1e0885279df2e76
-SIZE (rubygem/activerecord-2.3.8.gem) = 965120
+MD5 (rubygem/activerecord-3.0.0.gem) = 7f659a7783b48b506164c36d02385529
+SHA256 (rubygem/activerecord-3.0.0.gem) = 99f2f81dc836c0fad485c18163b00358e2971309ca6a7dfb195e2decab3046d0
+SIZE (rubygem/activerecord-3.0.0.gem) = 339968
diff --git a/databases/rubygem-arel/Makefile b/databases/rubygem-arel/Makefile
new file mode 100644
index 000000000000..ed88d87c40de
--- /dev/null
+++ b/databases/rubygem-arel/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-arel
+# Date created: 1 September 2010
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= arel
+PORTVERSION= 1.0.1
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Relational Algebra for Ruby.
+
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-arel/distinfo b/databases/rubygem-arel/distinfo
new file mode 100644
index 000000000000..d8a9d9b80b65
--- /dev/null
+++ b/databases/rubygem-arel/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/arel-1.0.1.gem) = 8bf74dfd1c7c9d18d743f558c732b9c7
+SHA256 (rubygem/arel-1.0.1.gem) = e09f061d176a35b6e5d26d4762952bf677c807964a918965000061cac047f284
+SIZE (rubygem/arel-1.0.1.gem) = 45568
diff --git a/databases/rubygem-arel/pkg-descr b/databases/rubygem-arel/pkg-descr
new file mode 100644
index 000000000000..695cf6e5076c
--- /dev/null
+++ b/databases/rubygem-arel/pkg-descr
@@ -0,0 +1,6 @@
+A toolkit for building modeling frameworks like Active Record and
+Active Resource. Rich support for attributes, callbacks,
+validations, observers, serialization, internationalization,
+and testing.
+
+WWW: http://rubygems.org/gems/arel
diff --git a/devel/rubygem-activesupport/Makefile b/devel/rubygem-activesupport/Makefile
index 51ba1a5f7d88..e97b948d395b 100644
--- a/devel/rubygem-activesupport/Makefile
+++ b/devel/rubygem-activesupport/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= activesupport
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -13,8 +13,9 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Utility classes and extension that are required by Rails MVC Framework
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+USE_RUBY_FEATURES= iconv
+
.include <bsd.port.mk>
diff --git a/devel/rubygem-activesupport/distinfo b/devel/rubygem-activesupport/distinfo
index a7be3199c3dc..43951ebe69d1 100644
--- a/devel/rubygem-activesupport/distinfo
+++ b/devel/rubygem-activesupport/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/activesupport-2.3.8.gem) = 1211d35bb0489764fd1fcac19d081a47
-SHA256 (rubygem/activesupport-2.3.8.gem) = 89a7587b25bc312aa07638543f42ef34c974d026c4ccdc0367e9376e3233f661
-SIZE (rubygem/activesupport-2.3.8.gem) = 425472
+MD5 (rubygem/activesupport-3.0.0.gem) = 4c3b2911cfc73c4a41aed0064f4eac59
+SHA256 (rubygem/activesupport-3.0.0.gem) = 7d57a36ab037e1e7bdb11e467c8e23f83b461ad011123f83f19f4a8571344d2d
+SIZE (rubygem/activesupport-3.0.0.gem) = 302080
diff --git a/mail/rubygem-actionmailer/Makefile b/mail/rubygem-actionmailer/Makefile
index cae5994390ba..a36a181b38c9 100644
--- a/mail/rubygem-actionmailer/Makefile
+++ b/mail/rubygem-actionmailer/Makefile
@@ -5,14 +5,15 @@
# $FreeBSD$
PORTNAME= actionmailer
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= mail rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Easy email delivery and testing for Ruby
-RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/actionpack-${PORTVERSION}.gemspec:${PORTSDIR}/www/rubygem-actionpack
+RUN_DEPENDS= rubygem-actionpack>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-mail>=2.2.5:${PORTSDIR}/mail/rubygem-mail
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/mail/rubygem-actionmailer/distinfo b/mail/rubygem-actionmailer/distinfo
index 825d112eff1e..3fb9cdd86680 100644
--- a/mail/rubygem-actionmailer/distinfo
+++ b/mail/rubygem-actionmailer/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/actionmailer-2.3.8.gem) = 6e4d123b144ae091be91ac761bf6087f
-SHA256 (rubygem/actionmailer-2.3.8.gem) = 119311395de19d13c5c60eff39aa6899da4862c12147e45b3b734a18afefb706
-SIZE (rubygem/actionmailer-2.3.8.gem) = 273408
+MD5 (rubygem/actionmailer-3.0.0.gem) = e25858fa6df4a53c8ff02aa6c3caebb4
+SHA256 (rubygem/actionmailer-3.0.0.gem) = 7858ec4af2fd5afe8155a81bf983db42e2734dcd97a1d3b2a5d59c75ee8c4795
+SIZE (rubygem/actionmailer-3.0.0.gem) = 30208
diff --git a/www/Makefile b/www/Makefile
index a7b5a0f94545..8aed9d37c022 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1551,6 +1551,7 @@
SUBDIR += rubygem-rack-mount
SUBDIR += rubygem-rack-test
SUBDIR += rubygem-rails
+ SUBDIR += rubygem-railties
SUBDIR += rubygem-rails-app-installer
SUBDIR += rubygem-ramaze
SUBDIR += rubygem-redcloth
diff --git a/www/rubygem-actionpack/Makefile b/www/rubygem-actionpack/Makefile
index f465e206bcdc..1c7ff86ab440 100644
--- a/www/rubygem-actionpack/Makefile
+++ b/www/rubygem-actionpack/Makefile
@@ -5,15 +5,21 @@
# $FreeBSD$
PORTNAME= actionpack
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= www rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Action Controller and Action View of Rails MVC Framework
-RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
- rubygem-rack>=1.1.0:${PORTSDIR}/www/rubygem-rack
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-activemodel>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activemodel \
+ rubygem-tzinfo>=0.3.23:${PORTSDIR}/devel/rubygem-tzinfo \
+ rubygem-erubis>=2.6.6:${PORTSDIR}/www/rubygem-erubis \
+ rubygem-rack-mount>=0.6.12:${PORTSDIR}/www/rubygem-rack-mount \
+ rubygem-rack-test>=0.5.4:${PORTSDIR}/www/rubygem-rack-test \
+ rubygem-builder>=2.1.2:${PORTSDIR}/devel/rubygem-builder \
+ rubygem-i18n>=0.4.1:${PORTSDIR}/devel/rubygem-i18n
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-actionpack/distinfo b/www/rubygem-actionpack/distinfo
index 5c6a7822588a..90658c233717 100644
--- a/www/rubygem-actionpack/distinfo
+++ b/www/rubygem-actionpack/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/actionpack-2.3.8.gem) = 75d7e35afa5a5bfaac5c8fe5f8967ed7
-SHA256 (rubygem/actionpack-2.3.8.gem) = 98bff14ff6981f5709b3d43f47bb25fcfeff70b2b75a93cf9aa74a12ba6fd14f
-SIZE (rubygem/actionpack-2.3.8.gem) = 743424
+MD5 (rubygem/actionpack-3.0.0.gem) = e87bc47d7f3c2a79e4694bbccf6e6506
+SHA256 (rubygem/actionpack-3.0.0.gem) = ff68121ae685d063828a1c6e1c8d9b4048a71d1bffef565374d6c649d5e855e2
+SIZE (rubygem/actionpack-3.0.0.gem) = 344576
diff --git a/www/rubygem-activeresource/Makefile b/www/rubygem-activeresource/Makefile
index 96f5aa51fecb..efcd01dcb7aa 100644
--- a/www/rubygem-activeresource/Makefile
+++ b/www/rubygem-activeresource/Makefile
@@ -5,14 +5,15 @@
# $FreeBSD$
PORTNAME= activeresource
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= www rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= A coherent wrapper object-relational mapping for REST web services
-RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-activemodel>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activemodel
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-activeresource/distinfo b/www/rubygem-activeresource/distinfo
index 1b83d097e1fd..5cae57ddf720 100644
--- a/www/rubygem-activeresource/distinfo
+++ b/www/rubygem-activeresource/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/activeresource-2.3.8.gem) = 7318e7652bd17433e4fec17fe9a201b7
-SHA256 (rubygem/activeresource-2.3.8.gem) = 494ded425c5d2d3b0b337330d82bb0318cb74ad74f63a05e1323b6036836c1ec
-SIZE (rubygem/activeresource-2.3.8.gem) = 483328
+MD5 (rubygem/activeresource-3.0.0.gem) = f82f2b0e600593e1cdcfc379222a2a00
+SHA256 (rubygem/activeresource-3.0.0.gem) = 5e745f7579329674b9d6089f09bd1cac8b73877920a6efe23c6950b83875ad30
+SIZE (rubygem/activeresource-3.0.0.gem) = 34304
diff --git a/www/rubygem-rails/Makefile b/www/rubygem-rails/Makefile
index 0f05b55212a4..c739e606d189 100644
--- a/www/rubygem-rails/Makefile
+++ b/www/rubygem-rails/Makefile
@@ -5,31 +5,35 @@
# $FreeBSD$
PORTNAME= rails
-PORTVERSION= 2.3.8
+PORTVERSION= 3.0.0
CATEGORIES= www rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= MVC web application framework
-RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
- ${LOCALBASE}/${SPEC_DIR}/activerecord-${PORTVERSION}.gemspec:${PORTSDIR}/databases/rubygem-activerecord \
- ${LOCALBASE}/${SPEC_DIR}/actionpack-${PORTVERSION}.gemspec:${PORTSDIR}/www/rubygem-actionpack \
- ${LOCALBASE}/${SPEC_DIR}/actionmailer-${PORTVERSION}.gemspec:${PORTSDIR}/mail/rubygem-actionmailer \
- ${LOCALBASE}/${SPEC_DIR}/activeresource-${PORTVERSION}.gemspec:${PORTSDIR}/www/rubygem-activeresource
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-activerecord>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activerecord \
+ rubygem-actionpack>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-actionmailer>=${PORTVERSION}:${PORTSDIR}/mail/rubygem-actionmailer \
+ rubygem-activeresource>=${PORTVERSION}:${PORTSDIR}/www/rubygem-activeresource \
+ rubygem-railties>=${PORTVERSION}:${PORTSDIR}/www/rubygem-railties \
+ rubygem-bundler>=1.0.0:${PORTSDIR}/sysutils/rubygem-bundler
-OPTIONS= FCGI "FastCGI support" Off\
- MEMCACHE_CLIENT "MemCache-Client support" Off
-OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
-
-# to get RUBY_SITEARCHLIBDIR
USE_RUBY= yes
-USE_RAKE= yes
USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/rails
-.include <bsd.port.pre.mk>
+OPTIONS= \
+ FCGI "FastCGI backend" Off \
+ MONGREL "Mongrel backend" Off \
+ MONGRELCLUSTER "Mongrel Cluster backend" Off \
+ PASSENGER "Passenger backend" Off \
+ MEMCACHE_CLIENT "MemCache-Client support" Off
+OPTIONSFILE= {PORT_DBDIR}/rubygem-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
.if defined(WITH_FCGI)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/fcgi.so:${PORTSDIR}/www/ruby-fcgi
@@ -39,4 +43,16 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/fcgi.so:${PORTSDIR}/www/ruby-fcgi
RUN_DEPENDS+= rubygem-memcache-client>=1.2.0:${PORTSDIR}/databases/rubygem-memcache-client
.endif
-.include <bsd.port.post.mk>
+.if defined(WITH_MONGREL)
+RUN_DEPENDS+= rubygem-mongrel>=1.1.5:${PORTSDIR}/www/rubygem-mongrel
+.endif
+
+.if defined(WITH_MONGRELCLUSTER)
+RUN_DEPENDS+= rubygem-mongre_clusterl>=1.0.5:${PORTSDIR}/www/rubygem-mongrel_cluster
+.endif
+
+.if defined(WITH_PASSENGER)
+RUN_DEPENDS+= rubygem-passenger>=2.2.15:${PORTSDIR}/www/rubygem-passenger
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rails/distinfo b/www/rubygem-rails/distinfo
index 0e8672d74bb8..a39d2bcdc4e9 100644
--- a/www/rubygem-rails/distinfo
+++ b/www/rubygem-rails/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/rails-2.3.8.gem) = a3061ceadf8877d9cdfd2a6d80387ae7
-SHA256 (rubygem/rails-2.3.8.gem) = 59efc4532e0886ad4912dc06a113ba2d455f7a380f972b24da8414df1dfb377d
-SIZE (rubygem/rails-2.3.8.gem) = 1259008
+MD5 (rubygem/rails-3.0.0.gem) = 4942e721d24f299a04319b519e5230ff
+SHA256 (rubygem/rails-3.0.0.gem) = 5a9a2c14077d27d849ae660c03dd9427b8cd9c3151135968d89b0454be8c5efe
+SIZE (rubygem/rails-3.0.0.gem) = 3584
diff --git a/www/rubygem-railties/Makefile b/www/rubygem-railties/Makefile
new file mode 100644
index 000000000000..f6708a3882b8
--- /dev/null
+++ b/www/rubygem-railties/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: rubygem-railties
+# Date created: 1 September 2010
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= railties
+PORTVERSION= 3.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Rails internals bootup, plugins, generators, and rake tasks
+
+RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-actionpack>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-thor>=0.14.0:${PORTSDIR}/devel/rubygem-thor \
+ rubygem-rake>=0.8.4:${PORTSDIR}/devel/rubygem-rake
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-railties/distinfo b/www/rubygem-railties/distinfo
new file mode 100644
index 000000000000..794973017668
--- /dev/null
+++ b/www/rubygem-railties/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/railties-3.0.0.gem) = 9b034f3716b381d37cd5a8d8a9b798c0
+SHA256 (rubygem/railties-3.0.0.gem) = 23ad1cb85daae67e5762a6f7acb2709a854a7369c6003025a4d21fbda109427e
+SIZE (rubygem/railties-3.0.0.gem) = 1504768
diff --git a/www/rubygem-railties/pkg-descr b/www/rubygem-railties/pkg-descr
new file mode 100644
index 000000000000..f387d59ef82d
--- /dev/null
+++ b/www/rubygem-railties/pkg-descr
@@ -0,0 +1,3 @@
+Rails internals: application bootup, plugins, generators, and rake tasks.
+
+WWW: http://rubygems.org/gems/railties