aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/tomcat55/Makefile1
-rw-r--r--www/tomcat55/files/tomcat55.sh.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index f55cb383bea7..e2b9d745b2e3 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.28
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat55/files/tomcat55.sh.in b/www/tomcat55/files/tomcat55.sh.in
index 1ac100ed9f5b..fc634f090997 100644
--- a/www/tomcat55/files/tomcat55.sh.in
+++ b/www/tomcat55/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o ucomm= -p $rc_pid`
+ procname=`ps -o command= -p $rc_pid | cut -f 1 -d ' '`
fi
fi
if [ -z "$procname" ]; then