aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/drweb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index 7946c7e4ae5d..fb0544f007b6 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: tas
+# New ports collection makefile for: drweb
# Date created: 14 August 2001
# Whom: Anton Voronin <anton@urc.ac.ru>
#
@@ -16,6 +16,7 @@ MAINTAINER= anton@urc.ac.ru
NO_BUILD= YES
+# Needed for update.pl
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
DRWEB_PREFIX= ${PREFIX}/${PORTNAME}
@@ -25,7 +26,7 @@ do-install:
${TAR} -xzf ${WRKSRC}/${DISTNAME}.tar.gz -C ${DRWEB_PREFIX} --exclude *.ini
${TAR} -xzOf ${WRKSRC}/${DISTNAME}.tar.gz drweb32.ini >${DRWEB_PREFIX}/drweb32.ini.sample
${SED} 's#!!PREFIX!!#${DRWEB_PREFIX}#' < ${FILESDIR}/drwebd.sh >${WRKSRC}/drwebd.sh
- cd ${DRWEB_PREFIX}/update; patch < ${FILESDIR}/update-patch
+ cd ${DRWEB_PREFIX}/update; patch -s < ${FILESDIR}/update-patch && ${RM} update.pl.orig
${INSTALL_SCRIPT} ${WRKSRC}/drwebd.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>