aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw32-binutils/Makefile94
-rw-r--r--devel/mingw32-binutils/distinfo3
-rw-r--r--devel/mingw32-binutils/files/fdl.texi403
-rw-r--r--devel/mingw32-binutils/pkg-descr6
-rw-r--r--devel/mingw32-binutils/pkg-plist141
6 files changed, 557 insertions, 91 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f3db348a3fe9..c5c552f7499d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -384,6 +384,7 @@
SUBDIR += mingw-binutils
SUBDIR += mingw-gcc
SUBDIR += mingw-opengl-headers
+ SUBDIR += mingw32-binutils
SUBDIR += mips-rtems-binutils
SUBDIR += mips-rtems-g77
SUBDIR += mips-rtems-gcc
diff --git a/devel/mingw32-binutils/Makefile b/devel/mingw32-binutils/Makefile
index 0f5881e21dad..694700f15c5e 100644
--- a/devel/mingw32-binutils/Makefile
+++ b/devel/mingw32-binutils/Makefile
@@ -1,58 +1,74 @@
-# New ports collection makefile for: mingw-binutils
-# Date created: 6 June 2000
-# Whom: Toshihiro Inoue <tino@pa2.so-net.ne.jp>
+# New ports collection makefile for: mingw2-binutils
+# Date created: 24 Oct 2002
+# Whom: Lev Serebryakov <lev@serebryakov.spb.ru>
#
# $FreeBSD$
#
PORTNAME= binutils
-PORTVERSION= 2.11.92
+PORTVERSION= ${BINUTILVERSION}.${PATCHVERSION}
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mingw
-PKGNAMEPREFIX= mingw-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-20011113-src${EXTRACT_SUFFIX}
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= binutils/releases
+PKGNAMEPREFIX= mingw32-
+DISTNAME= ${PORTNAME}-${BINUTILVERSION}
DIST_SUBDIR= mingw
-MAINTAINER= doc@hisio.safenet.pl
-COMMENT= FSF binutils-2.11.90 for Windows cross-development
+PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}
+PATCH_SITE_SUBDIR= mingw
+PATCHFILES= ${PORTNAME}-${BINUTILVERSION}-${PATCHVERSION:S/./-/}.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= lev@serebryakov.spb.ru
+COMMENT= FSF binutils-2.13 for Windows cross-development
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-20011113
+BINUTILVERSION= 2.13
+PATCHVERSION= 20020903.1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${BINUTILVERSION}
+USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --target=i386-mingw32msvc
-
-MAN1= i386-mingw32msvc-addr2line.1 \
- i386-mingw32msvc-ar.1 \
- i386-mingw32msvc-as.1 \
- i386-mingw32msvc-dlltool.1 \
- i386-mingw32msvc-c++filt.1 \
- i386-mingw32msvc-ld.1 \
- i386-mingw32msvc-nlmconv.1 \
- i386-mingw32msvc-nm.1 \
- i386-mingw32msvc-objcopy.1 \
- i386-mingw32msvc-objdump.1 \
- i386-mingw32msvc-ranlib.1 \
- i386-mingw32msvc-readelf.1 \
- i386-mingw32msvc-size.1 \
- i386-mingw32msvc-strings.1 \
- i386-mingw32msvc-strip.1 \
- i386-mingw32msvc-windres.1
+CONFIGURE_ARGS= --target=${PKGNAMEPREFIX:S/-$//} \
+ --with-gcc --with-gnu-ld --with-gnu-as \
+ --disable-nls --disable-win32-registry \
+ --disable-shared
-post-install:
- @for file in \
- addr2line ar as c++filt dlltool gasp ld nm \
- objcopy objdump ranlib size strings strip windres; \
- do \
- strip ${PREFIX}/bin/i386-mingw32msvc-$${file}; \
- done
- @for file in ar as dlltool ld nm ranlib strip; \
- do \
- strip ${PREFIX}/i386-mingw32msvc/bin/$${file}; \
+MAN1= ${PKGNAMEPREFIX}addr2line.1 ${PKGNAMEPREFIX}ar.1 \
+ ${PKGNAMEPREFIX}as.1 ${PKGNAMEPREFIX}dlltool.1 \
+ ${PKGNAMEPREFIX}c++filt.1 ${PKGNAMEPREFIX}ld.1 \
+ ${PKGNAMEPREFIX}nlmconv.1 ${PKGNAMEPREFIX}nm.1 \
+ ${PKGNAMEPREFIX}objcopy.1 ${PKGNAMEPREFIX}objdump.1 \
+ ${PKGNAMEPREFIX}ranlib.1 ${PKGNAMEPREFIX}readelf.1 \
+ ${PKGNAMEPREFIX}size.1 ${PKGNAMEPREFIX}strings.1 \
+ ${PKGNAMEPREFIX}strip.1 ${PKGNAMEPREFIX}windres.1
+
+PLIST_SUB+= BINUTILS_TARG=${PKGNAMEPREFIX:S/-$//}
+
+BINARIES= addr2line ar as c++filt ld nm objcopy objdump ranlib \
+ readelf size strings strip dlltool dllwrap windres
+
+# There may be original binutils sources already
+pre-fetch:
+ for F in ${DISTFILES}; do \
+ ${TEST} -f ${DISTDIR}/$${F} && \
+ ${TEST} ! -f ${DISTDIR}/${DIST_SUBDIR}/$${F} && \
+ ${LN} ${DISTDIR}/$${F} ${DISTDIR}/${DIST_SUBDIR}/$${F} || \
+ true ; \
done
+pre-install:
+ @${CP} ${FILESDIR}/fdl.texi ${WRKSRC}/etc
+
+post-install:
+.for F in ${BINARIES}
+ @strip ${PREFIX}/bin/${PKGNAMEPREFIX}$F
+ @${LN} -f ${PREFIX}/bin/${PKGNAMEPREFIX}$F \
+ ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/bin/$F
+.endfor
+
.include <bsd.port.mk>
diff --git a/devel/mingw32-binutils/distinfo b/devel/mingw32-binutils/distinfo
index a19422eefcc4..327685034151 100644
--- a/devel/mingw32-binutils/distinfo
+++ b/devel/mingw32-binutils/distinfo
@@ -1 +1,2 @@
-MD5 (mingw/binutils-2.11.92-20011113-src.tar.gz) = f7d5ffdfe568d08099640825f5d1a0ed
+MD5 (mingw/binutils-2.13.tar.bz2) = b01fd02592abb98405accbca52081088
+MD5 (mingw/binutils-2.13-20020903-1.diff.gz) = 3eefea8dda77bccd3877d7d4dca6a7fb
diff --git a/devel/mingw32-binutils/files/fdl.texi b/devel/mingw32-binutils/files/fdl.texi
new file mode 100644
index 000000000000..361f90f7bb53
--- /dev/null
+++ b/devel/mingw32-binutils/files/fdl.texi
@@ -0,0 +1,403 @@
+
+@node GNU Free Documentation License
+@appendixsec GNU Free Documentation License
+
+@cindex FDL, GNU Free Documentation License
+@center Version 1.1, March 2000
+
+@display
+Copyright @copyright{} 2000 Free Software Foundation, Inc.
+59 Temple Place, Suite 330, Boston, MA 02111-1307, USA
+
+Everyone is permitted to copy and distribute verbatim copies
+of this license document, but changing it is not allowed.
+@end display
+
+@enumerate 0
+@item
+PREAMBLE
+
+The purpose of this License is to make a manual, textbook, or other
+written document @dfn{free} in the sense of freedom: to assure everyone
+the effective freedom to copy and redistribute it, with or without
+modifying it, either commercially or noncommercially. Secondarily,
+this License preserves for the author and publisher a way to get
+credit for their work, while not being considered responsible for
+modifications made by others.
+
+This License is a kind of ``copyleft'', which means that derivative
+works of the document must themselves be free in the same sense. It
+complements the GNU General Public License, which is a copyleft
+license designed for free software.
+
+We have designed this License in order to use it for manuals for free
+software, because free software needs free documentation: a free
+program should come with manuals providing the same freedoms that the
+software does. But this License is not limited to software manuals;
+it can be used for any textual work, regardless of subject matter or
+whether it is published as a printed book. We recommend this License
+principally for works whose purpose is instruction or reference.
+
+@item
+APPLICABILITY AND DEFINITIONS
+
+This License applies to any manual or other work that contains a
+notice placed by the copyright holder saying it can be distributed
+under the terms of this License. The ``Document'', below, refers to any
+such manual or work. Any member of the public is a licensee, and is
+addressed as ``you''.
+
+A ``Modified Version'' of the Document means any work containing the
+Document or a portion of it, either copied verbatim, or with
+modifications and/or translated into another language.
+
+A ``Secondary Section'' is a named appendix or a front-matter section of
+the Document that deals exclusively with the relationship of the
+publishers or authors of the Document to the Document's overall subject
+(or to related matters) and contains nothing that could fall directly
+within that overall subject. (For example, if the Document is in part a
+textbook of mathematics, a Secondary Section may not explain any
+mathematics.) The relationship could be a matter of historical
+connection with the subject or with related matters, or of legal,
+commercial, philosophical, ethical or political position regarding
+them.
+
+The ``Invariant Sections'' are certain Secondary Sections whose titles
+are designated, as being those of Invariant Sections, in the notice
+that says that the Document is released under this License.
+
+The ``Cover Texts'' are certain short passages of text that are listed,
+as Front-Cover Texts or Back-Cover Texts, in the notice that says that
+the Document is released under this License.
+
+A ``Transparent'' copy of the Document means a machine-readable copy,
+represented in a format whose specification is available to the
+general public, whose contents can be viewed and edited directly and
+straightforwardly with generic text editors or (for images composed of
+pixels) generic paint programs or (for drawings) some widely available
+drawing editor, and that is suitable for input to text formatters or
+for automatic translation to a variety of formats suitable for input
+to text formatters. A copy made in an otherwise Transparent file
+format whose markup has been designed to thwart or discourage
+subsequent modification by readers is not Transparent. A copy that is
+not ``Transparent'' is called ``Opaque''.
+
+Examples of suitable formats for Transparent copies include plain
+@sc{ascii} without markup, Texinfo input format, La@TeX{} input format,
+@acronym{SGML} or @acronym{XML} using a publicly available
+@acronym{DTD}, and standard-conforming simple @acronym{HTML} designed
+for human modification. Opaque formats include PostScript,
+@acronym{PDF}, proprietary formats that can be read and edited only by
+proprietary word processors, @acronym{SGML} or @acronym{XML} for which
+the @acronym{DTD} and/or processing tools are not generally available,
+and the machine-generated @acronym{HTML} produced by some word
+processors for output purposes only.
+
+The ``Title Page'' means, for a printed book, the title page itself,
+plus such following pages as are needed to hold, legibly, the material
+this License requires to appear in the title page. For works in
+formats which do not have any title page as such, ``Title Page'' means
+the text near the most prominent appearance of the work's title,
+preceding the beginning of the body of the text.
+
+@item
+VERBATIM COPYING
+
+You may copy and distribute the Document in any medium, either
+commercially or noncommercially, provided that this License, the
+copyright notices, and the license notice saying this License applies
+to the Document are reproduced in all copies, and that you add no other
+conditions whatsoever to those of this License. You may not use
+technical measures to obstruct or control the reading or further
+copying of the copies you make or distribute. However, you may accept
+compensation in exchange for copies. If you distribute a large enough
+number of copies you must also follow the conditions in section 3.
+
+You may also lend copies, under the same conditions stated above, and
+you may publicly display copies.
+
+@item
+COPYING IN QUANTITY
+
+If you publish printed copies of the Document numbering more than 100,
+and the Document's license notice requires Cover Texts, you must enclose
+the copies in covers that carry, clearly and legibly, all these Cover
+Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on
+the back cover. Both covers must also clearly and legibly identify
+you as the publisher of these copies. The front cover must present
+the full title with all words of the title equally prominent and
+visible. You may add other material on the covers in addition.
+Copying with changes limited to the covers, as long as they preserve
+the title of the Document and satisfy these conditions, can be treated
+as verbatim copying in other respects.
+
+If the required texts for either cover are too voluminous to fit
+legibly, you should put the first ones listed (as many as fit
+reasonably) on the actual cover, and continue the rest onto adjacent
+pages.
+
+If you publish or distribute Opaque copies of the Document numbering
+more than 100, you must either include a machine-readable Transparent
+copy along with each Opaque copy, or state in or with each Opaque copy
+a publicly-accessible computer-network location containing a complete
+Transparent copy of the Document, free of added material, which the
+general network-using public has access to download anonymously at no
+charge using public-standard network protocols. If you use the latter
+option, you must take reasonably prudent steps, when you begin
+distribution of Opaque copies in quantity, to ensure that this
+Transparent copy will remain thus accessible at the stated location
+until at least one year after the last time you distribute an Opaque
+copy (directly or through your agents or retailers) of that edition to
+the public.
+
+It is requested, but not required, that you contact the authors of the
+Document well before redistributing any large number of copies, to give
+them a chance to provide you with an updated version of the Document.
+
+@item
+MODIFICATIONS
+
+You may copy and distribute a Modified Version of the Document under
+the conditions of sections 2 and 3 above, provided that you release
+the Modified Version under precisely this License, with the Modified
+Version filling the role of the Document, thus licensing distribution
+and modification of the Modified Version to whoever possesses a copy
+of it. In addition, you must do these things in the Modified Version:
+
+@enumerate A
+@item
+Use in the Title Page (and on the covers, if any) a title distinct
+from that of the Document, and from those of previous versions
+(which should, if there were any, be listed in the History section
+of the Document). You may use the same title as a previous version
+if the original publisher of that version gives permission.
+
+@item
+List on the Title Page, as authors, one or more persons or entities
+responsible for authorship of the modifications in the Modified
+Version, together with at least five of the principal authors of the
+Document (all of its principal authors, if it has less than five).
+
+@item
+State on the Title page the name of the publisher of the
+Modified Version, as the publisher.
+
+@item
+Preserve all the copyright notices of the Document.
+
+@item
+Add an appropriate copyright notice for your modifications
+adjacent to the other copyright notices.
+
+@item
+Include, immediately after the copyright notices, a license notice
+giving the public permission to use the Modified Version under the
+terms of this License, in the form shown in the Addendum below.
+
+@item
+Preserve in that license notice the full lists of Invariant Sections
+and required Cover Texts given in the Document's license notice.
+
+@item
+Include an unaltered copy of this License.
+
+@item
+Preserve the section entitled ``History'', and its title, and add to
+it an item stating at least the title, year, new authors, and
+publisher of the Modified Version as given on the Title Page. If
+there is no section entitled ``History'' in the Document, create one
+stating the title, year, authors, and publisher of the Document as
+given on its Title Page, then add an item describing the Modified
+Version as stated in the previous sentence.
+
+@item
+Preserve the network location, if any, given in the Document for
+public access to a Transparent copy of the Document, and likewise
+the network locations given in the Document for previous versions
+it was based on. These may be placed in the ``History'' section.
+You may omit a network location for a work that was published at
+least four years before the Document itself, or if the original
+publisher of the version it refers to gives permission.
+
+@item
+In any section entitled ``Acknowledgments'' or ``Dedications'',
+preserve the section's title, and preserve in the section all the
+substance and tone of each of the contributor acknowledgments
+and/or dedications given therein.
+
+@item
+Preserve all the Invariant Sections of the Document,
+unaltered in their text and in their titles. Section numbers
+or the equivalent are not considered part of the section titles.
+
+@item
+Delete any section entitled ``Endorsements''. Such a section
+may not be included in the Modified Version.
+
+@item
+Do not retitle any existing section as ``Endorsements''
+or to conflict in title with any Invariant Section.
+@end enumerate
+
+If the Modified Version includes new front-matter sections or
+appendices that qualify as Secondary Sections and contain no material
+copied from the Document, you may at your option designate some or all
+of these sections as invariant. To do this, add their titles to the
+list of Invariant Sections in the Modified Version's license notice.
+These titles must be distinct from any other section titles.
+
+You may add a section entitled ``Endorsements'', provided it contains
+nothing but endorsements of your Modified Version by various
+parties---for example, statements of peer review or that the text has
+been approved by an organization as the authoritative definition of a
+standard.
+
+You may add a passage of up to five words as a Front-Cover Text, and a
+passage of up to 25 words as a Back-Cover Text, to the end of the list
+of Cover Texts in the Modified Version. Only one passage of
+Front-Cover Text and one of Back-Cover Text may be added by (or
+through arrangements made by) any one entity. If the Document already
+includes a cover text for the same cover, previously added by you or
+by arrangement made by the same entity you are acting on behalf of,
+you may not add another; but you may replace the old one, on explicit
+permission from the previous publisher that added the old one.
+
+The author(s) and publisher(s) of the Document do not by this License
+give permission to use their names for publicity for or to assert or
+imply endorsement of any Modified Version.
+
+@item
+COMBINING DOCUMENTS
+
+You may combine the Document with other documents released under this
+License, under the terms defined in section 4 above for modified
+versions, provided that you include in the combination all of the
+Invariant Sections of all of the original documents, unmodified, and
+list them all as Invariant Sections of your combined work in its
+license notice.
+
+The combined work need only contain one copy of this License, and
+multiple identical Invariant Sections may be replaced with a single
+copy. If there are multiple Invariant Sections with the same name but
+different contents, make the title of each such section unique by
+adding at the end of it, in parentheses, the name of the original
+author or publisher of that section if known, or else a unique number.
+Make the same adjustment to the section titles in the list of
+Invariant Sections in the license notice of the combined work.
+
+In the combination, you must combine any sections entitled ``History''
+in the various original documents, forming one section entitled
+``History''; likewise combine any sections entitled ``Acknowledgments'',
+and any sections entitled ``Dedications''. You must delete all sections
+entitled ``Endorsements.''
+
+@item
+COLLECTIONS OF DOCUMENTS
+
+You may make a collection consisting of the Document and other documents
+released under this License, and replace the individual copies of this
+License in the various documents with a single copy that is included in
+the collection, provided that you follow the rules of this License for
+verbatim copying of each of the documents in all other respects.
+
+You may extract a single document from such a collection, and distribute
+it individually under this License, provided you insert a copy of this
+License into the extracted document, and follow this License in all
+other respects regarding verbatim copying of that document.
+
+@item
+AGGREGATION WITH INDEPENDENT WORKS
+
+A compilation of the Document or its derivatives with other separate
+and independent documents or works, in or on a volume of a storage or
+distribution medium, does not as a whole count as a Modified Version
+of the Document, provided no compilation copyright is claimed for the
+compilation. Such a compilation is called an ``aggregate'', and this
+License does not apply to the other self-contained works thus compiled
+with the Document, on account of their being thus compiled, if they
+are not themselves derivative works of the Document.
+
+If the Cover Text requirement of section 3 is applicable to these
+copies of the Document, then if the Document is less than one quarter
+of the entire aggregate, the Document's Cover Texts may be placed on
+covers that surround only the Document within the aggregate.
+Otherwise they must appear on covers around the whole aggregate.
+
+@item
+TRANSLATION
+
+Translation is considered a kind of modification, so you may
+distribute translations of the Document under the terms of section 4.
+Replacing Invariant Sections with translations requires special
+permission from their copyright holders, but you may include
+translations of some or all Invariant Sections in addition to the
+original versions of these Invariant Sections. You may include a
+translation of this License provided that you also include the
+original English version of this License. In case of a disagreement
+between the translation and the original English version of this
+License, the original English version will prevail.
+
+@item
+TERMINATION
+
+You may not copy, modify, sublicense, or distribute the Document except
+as expressly provided for under this License. Any other attempt to
+copy, modify, sublicense or distribute the Document is void, and will
+automatically terminate your rights under this License. However,
+parties who have received copies, or rights, from you under this
+License will not have their licenses terminated so long as such
+parties remain in full compliance.
+
+@item
+FUTURE REVISIONS OF THIS LICENSE
+
+The Free Software Foundation may publish new, revised versions
+of the GNU Free Documentation License from time to time. Such new
+versions will be similar in spirit to the present version, but may
+differ in detail to address new problems or concerns. See
+@uref{http://www.gnu.org/copyleft/}.
+
+Each version of the License is given a distinguishing version number.
+If the Document specifies that a particular numbered version of this
+License ``or any later version'' applies to it, you have the option of
+following the terms and conditions either of that specified version or
+of any later version that has been published (not as a draft) by the
+Free Software Foundation. If the Document does not specify a version
+number of this License, you may choose any version ever published (not
+as a draft) by the Free Software Foundation.
+@end enumerate
+
+@page
+@appendixsubsec ADDENDUM: How to use this License for your documents
+
+To use this License in a document you have written, include a copy of
+the License in the document and put the following copyright and
+license notices just after the title page:
+
+@smallexample
+@group
+ Copyright (C) @var{year} @var{your name}.
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the GNU Free Documentation License, Version 1.1
+ or any later version published by the Free Software Foundation;
+ with the Invariant Sections being @var{list their titles}, with the
+ Front-Cover Texts being @var{list}, and with the Back-Cover Texts being @var{list}.
+ A copy of the license is included in the section entitled ``GNU
+ Free Documentation License''.
+@end group
+@end smallexample
+
+If you have no Invariant Sections, write ``with no Invariant Sections''
+instead of saying which ones are invariant. If you have no
+Front-Cover Texts, write ``no Front-Cover Texts'' instead of
+``Front-Cover Texts being @var{list}''; likewise for Back-Cover Texts.
+
+If your document contains nontrivial examples of program code, we
+recommend releasing these examples in parallel under your choice of
+free software license, such as the GNU General Public License,
+to permit their use in free software.
+
+@c Local Variables:
+@c ispell-local-pdict: "ispell-dict"
+@c End:
+
diff --git a/devel/mingw32-binutils/pkg-descr b/devel/mingw32-binutils/pkg-descr
index aeff2a3ff3cc..640721df177c 100644
--- a/devel/mingw32-binutils/pkg-descr
+++ b/devel/mingw32-binutils/pkg-descr
@@ -1,3 +1,5 @@
-FSF binutils-2.11.90 for Windows cross-development.
+FSF binutils-2.13 for Windows cross-development.
-This port is needed by mingw-gcc/devel.
+This port is needed by devel/mingw32-gcc
+
+WWW: http://www.mingw.org/
diff --git a/devel/mingw32-binutils/pkg-plist b/devel/mingw32-binutils/pkg-plist
index 5db84f577455..6a1dc32116c1 100644
--- a/devel/mingw32-binutils/pkg-plist
+++ b/devel/mingw32-binutils/pkg-plist
@@ -1,50 +1,93 @@
-bin/i386-mingw32msvc-addr2line
-bin/i386-mingw32msvc-ar
-bin/i386-mingw32msvc-as
-bin/i386-mingw32msvc-c++filt
-bin/i386-mingw32msvc-dlltool
-bin/i386-mingw32msvc-dllwrap
-bin/i386-mingw32msvc-gasp
-bin/i386-mingw32msvc-ld
-bin/i386-mingw32msvc-nm
-bin/i386-mingw32msvc-objcopy
-bin/i386-mingw32msvc-objdump
-bin/i386-mingw32msvc-ranlib
-bin/i386-mingw32msvc-readelf
-bin/i386-mingw32msvc-size
-bin/i386-mingw32msvc-strings
-bin/i386-mingw32msvc-strip
-bin/i386-mingw32msvc-windres
-i386-mingw32msvc/bin/ar
-i386-mingw32msvc/bin/as
-i386-mingw32msvc/bin/dlltool
-i386-mingw32msvc/bin/ld
-i386-mingw32msvc/bin/nm
-i386-mingw32msvc/bin/ranlib
-i386-mingw32msvc/bin/strip
-i386-mingw32msvc/lib/ldscripts/i386pe.x
-i386-mingw32msvc/lib/ldscripts/i386pe.xbn
-i386-mingw32msvc/lib/ldscripts/i386pe.xn
-i386-mingw32msvc/lib/ldscripts/i386pe.xr
-i386-mingw32msvc/lib/ldscripts/i386pe.xu
-@dirrm i386-mingw32msvc/bin
-@dirrm i386-mingw32msvc/lib/ldscripts
-@unexec rmdir -p %D/i386-mingw32msvc/lib 2>/dev/null || true
-include/ansidecl.h
-include/bfd.h
-include/bfdlink.h
-include/symcat.h
-lib/libbfd.a
-lib/libbfd.la
+@comment $FreeBSD$
+%%BINUTILS_TARG%%/bin/addr2line
+%%BINUTILS_TARG%%/bin/ar
+%%BINUTILS_TARG%%/bin/as
+%%BINUTILS_TARG%%/bin/c++filt
+%%BINUTILS_TARG%%/bin/dlltool
+%%BINUTILS_TARG%%/bin/dllwrap
+%%BINUTILS_TARG%%/bin/ld
+%%BINUTILS_TARG%%/bin/nm
+%%BINUTILS_TARG%%/bin/objcopy
+%%BINUTILS_TARG%%/bin/objdump
+%%BINUTILS_TARG%%/bin/ranlib
+%%BINUTILS_TARG%%/bin/readelf
+%%BINUTILS_TARG%%/bin/strip
+%%BINUTILS_TARG%%/bin/size
+%%BINUTILS_TARG%%/bin/strings
+%%BINUTILS_TARG%%/bin/windres
+%%BINUTILS_TARG%%/lib/ldscripts/i386pe.x
+%%BINUTILS_TARG%%/lib/ldscripts/i386pe.xbn
+%%BINUTILS_TARG%%/lib/ldscripts/i386pe.xn
+%%BINUTILS_TARG%%/lib/ldscripts/i386pe.xr
+%%BINUTILS_TARG%%/lib/ldscripts/i386pe.xu
lib/libiberty.a
-lib/libopcodes.a
-lib/libopcodes.la
-share/locale/fr/LC_MESSAGES/bfd.mo
-share/locale/fr/LC_MESSAGES/binutils.mo
-share/locale/fr/LC_MESSAGES/gas.mo
-share/locale/fr/LC_MESSAGES/ld.mo
-share/locale/fr/LC_MESSAGES/opcodes.mo
-share/locale/sv/LC_MESSAGES/ld.mo
-share/locale/sv/LC_MESSAGES/opcodes.mo
-share/locale/tr/LC_MESSAGES/binutils.mo
-share/locale/tr/LC_MESSAGES/opcodes.mo
+bin/%%BINUTILS_TARG%%-addr2line
+bin/%%BINUTILS_TARG%%-ar
+bin/%%BINUTILS_TARG%%-as
+bin/%%BINUTILS_TARG%%-c++filt
+bin/%%BINUTILS_TARG%%-dlltool
+bin/%%BINUTILS_TARG%%-dllwrap
+bin/%%BINUTILS_TARG%%-ld
+bin/%%BINUTILS_TARG%%-nm
+bin/%%BINUTILS_TARG%%-objcopy
+bin/%%BINUTILS_TARG%%-objdump
+bin/%%BINUTILS_TARG%%-ranlib
+bin/%%BINUTILS_TARG%%-readelf
+bin/%%BINUTILS_TARG%%-strip
+bin/%%BINUTILS_TARG%%-size
+bin/%%BINUTILS_TARG%%-strings
+bin/%%BINUTILS_TARG%%-windres
+@unexec install-info --delete %D/info/bfd.info %D/info/dir
+@unexec install-info --delete %D/info/binutils.info %D/info/dir
+@unexec install-info --delete %D/info/standards.info %D/info/dir 2> /dev/null
+@unexec install-info --delete %D/info/configure.info %D/info/dir 2> /dev/null
+@unexec install-info --delete %D/info/as.info %D/info/dir
+@unexec install-info --delete %D/info/ld.info %D/info/dir
+info/bfd.info
+info/bfd.info-1
+info/bfd.info-2
+info/bfd.info-3
+info/bfd.info-4
+info/bfd.info-5
+info/bfd.info-6
+info/bfd.info-7
+info/bfd.info-8
+info/bfd.info-9
+info/binutils.info
+info/binutils.info-1
+info/binutils.info-2
+info/binutils.info-3
+info/standards.info
+info/configure.info
+info/configure.info-1
+info/configure.info-2
+info/configure.info-3
+info/as.info
+info/as.info-1
+info/as.info-2
+info/as.info-3
+info/as.info-4
+info/as.info-5
+info/as.info-6
+info/as.info-7
+info/as.info-8
+info/as.info-9
+info/as.info-10
+info/as.info-11
+info/ld.info
+info/ld.info-1
+info/ld.info-2
+info/ld.info-3
+info/ld.info-4
+info/ld.info-5
+info/ld.info-6
+@dirrm %%BINUTILS_TARG%%/bin
+@dirrm %%BINUTILS_TARG%%/lib/ldscripts
+@dirrm %%BINUTILS_TARG%%/lib
+@dirrm %%BINUTILS_TARG%%
+@exec install-info %D/info/bfd.info %D/info/dir
+@exec install-info %D/info/binutils.info %D/info/dir
+@exec install-info %D/info/standards.info %D/info/dir
+@exec install-info %D/info/configure.info %D/info/dir
+@exec install-info %D/info/as.info %D/info/dir
+@exec install-info %D/info/ld.info %D/info/dir