aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/tcl84/Makefile2
-rw-r--r--x11-toolkits/tk84/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 20008789e12f..d5cf59b428d8 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -22,7 +22,7 @@ PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/unix
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --includedir=${LOCALBASE}/include/tcl${TCL_VER}
+CONFIGURE_ARGS= --enable-shared --includedir=${PREFIX}/include/tcl${TCL_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
MAKE_ENV= SHORT_TCL_VER=84
PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index 6f68820b5d31..e4b0c41545f3 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -26,8 +26,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/unix
GNU_CONFIGURE= yes
TK_VER= 8.4
SHORT_TK_VER= 84
-CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl${TK_VER} \
- --includedir=${LOCALBASE}/include/tk${TK_VER}
+CONFIGURE_ARGS= --enable-shared --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --includedir=${PREFIX}/include/tk${TK_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR} TK_LIB_FILE=libtk${SHORT_TK_VER}.so.1
MAKE_ENV= SHORT_TK_VER=${SHORT_TK_VER}
PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}