aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/vobcopy/Makefile22
-rw-r--r--sysutils/vobcopy/distinfo2
-rw-r--r--sysutils/vobcopy/pkg-descr2
3 files changed, 15 insertions, 11 deletions
diff --git a/sysutils/vobcopy/Makefile b/sysutils/vobcopy/Makefile
index 1670abb310c3..65b1369c7aa9 100644
--- a/sysutils/vobcopy/Makefile
+++ b/sysutils/vobcopy/Makefile
@@ -6,14 +6,17 @@
#
PORTNAME= vobcopy
-PORTVERSION= 0.4.3
+PORTVERSION= 0.5.3
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= lin-prog-newbie
+MASTER_SITES= http://lpn.rnbhq.org/download/
MAINTAINER= lioux@FreeBSD.org
-LIB_DEPENDS= dvdread.2:${PORTSDIR}/graphics/libdvdread
+LIB_DEPENDS= dvdread.2:${PORTSDIR}/graphics/libdvdread \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+HAS_CONFIGURE= yes
+USE_REINPLACE= yes
ALL_TARGET= ${PORTNAME}
@@ -23,13 +26,14 @@ DOC_FILES= COPYING Changelog README Release-Notes \
alternative_programs.txt
post-patch:
- @${PERL} -pi.orig -e 's|^CC.+||; s|^PREFIX.+||; \
- s|/usr/local/|${LOCALBASE}/|; \
- s|-D_LARGEFILE\d?\d?_SOURCE||g; \
- s|-D_FILE_OFFSET_BITS=64||' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's|(fopen\("/etc/)mtab|\1fstab|; \
+ @${REINPLACE_CMD} -E -e 's|(fopen\("/etc/)mtab|\1fstab|; \
s|iso9660|cd9660|' ${WRKSRC}/dvd.c
+post-configure:
+ @${REINPLACE_CMD} -E -e 's|^CC.+||; s|^PREFIX.+||; \
+ s|/usr/local/|${LOCALBASE}/|' \
+ ${WRKSRC}/Makefile
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/vobcopy ${PREFIX}/bin/vobcopy
@${INSTALL_MAN} ${WRKSRC}/vobcopy.1 ${MANPREFIX}/man/man1/vobcopy.1
diff --git a/sysutils/vobcopy/distinfo b/sysutils/vobcopy/distinfo
index 2ae4595b5aac..b76d269efa6c 100644
--- a/sysutils/vobcopy/distinfo
+++ b/sysutils/vobcopy/distinfo
@@ -1 +1 @@
-MD5 (vobcopy-0.4.3.tar.gz) = 94eb92d1e6cea36ff8f62bd27336428d
+MD5 (vobcopy-0.5.3.tar.gz) = 94cfd38053daf60b767fa7072d4960e5
diff --git a/sysutils/vobcopy/pkg-descr b/sysutils/vobcopy/pkg-descr
index f3177f2e4ba1..9430da1de238 100644
--- a/sysutils/vobcopy/pkg-descr
+++ b/sysutils/vobcopy/pkg-descr
@@ -6,4 +6,4 @@ larger) with the name extracted from the DVD. It checks for enough
free space on the destination drive and compares the copied size
to the size on DVD (in case something went wrong during the copying).
-WWW: http://lin-prog-newbie.sf.net/
+WWW: http://linux-programming-newbie.org/