aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/c3270/Makefile153
-rw-r--r--net/c3270/distinfo2
-rw-r--r--net/c3270/pkg-descr22
4 files changed, 178 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f4ebbf1ad4fb..56d62b39bf73 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -51,6 +51,7 @@
SUBDIR += bounce
SUBDIR += bsdproxy
SUBDIR += btqueue
+ SUBDIR += c3270
SUBDIR += cacti
SUBDIR += callgen
SUBDIR += cap
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
new file mode 100644
index 000000000000..7c8e41555a69
--- /dev/null
+++ b/net/c3270/Makefile
@@ -0,0 +1,153 @@
+# New ports collection makefile for: c3270
+# Date created: 04 October 2004
+# Whom: pdseniura@techie.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= c3270
+PORTVERSION= 3.3.2p2
+CATEGORIES= net
+MASTER_SITES= http://x3270.bgp.nu/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pdseniura@techie.com
+COMMENT= Full-screen curses-based remote login to IBM mainframes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9]\.[0-9])(\..*)/\1/}
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_OPENSSL= yes
+
+USE_REINPLACE= yes
+
+MAN1= c3270.1 \
+ x3270if.1 \
+ x3270-script.1 \
+ pr3287.1
+MAN5= ibm_hosts.5
+MANCOMPRESSED= no
+
+PLIST_FILES= bin/c3270 \
+ bin/x3270if \
+ bin/pr3287 \
+ etc/x3270/ibm_hosts
+PLIST_DIRS= etc/x3270
+
+PORTDOCS= LICENSE \
+ README \
+ html/Bugs.html \
+ html/Build.html \
+ html/FAQ.html \
+ html/Intro.html \
+ html/Lineage.html \
+ html/New.html \
+ html/README.html \
+ html/Wishlist.html \
+ html/c3270-man.html \
+ html/x3270-script.html \
+ html/x3270.xbm \
+ html/x3270if.html
+
+# c3270's ./configure script supports these.
+# Within it all options except DBCS are enabled by default.
+
+OPTIONS=OPENSSL 'Build with OpenSSL support' on \
+ READLINE 'Use system Readline library' on \
+ PR3287 'Build pr3287 component' on \
+ ANSI 'Include NVT (ANSI) support' on \
+ APL 'Include APL support' on \
+ DBCS 'Include EBCDIC DBCS support' off \
+ FT 'Include IND\$$FILE support' on \
+ LOCAL_PROCESS 'Include Local Process support' on \
+ PRINTER 'Include printer session support' on \
+ SCRIPT 'Include scripting support' on \
+ TN3270E 'Include TN3270-Extended support' on \
+ TRACE 'Include trace support' on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_OPENSSL) && !defined(WITH_OPENSSL)
+CONFIGURE_ARGS+= --disable-ssl
+.undef USE_OPENSSL
+.endif
+
+.if defined(WITHOUT_READLINE) && !defined(WITH_READLINE)
+CONFIGURE_ARGS+= --without-readline
+.endif
+
+.if defined(WITHOUT_PR3287) && !defined(WITH_PR3287)
+CONFIGURE_ARGS+= --without-pr3287
+.endif
+
+.if defined(WITHOUT_ANSI) && !defined(WITH_ANSI)
+CONFIGURE_ARGS+= --disable-ansi
+.endif
+
+.if defined(WITHOUT_APL) && !defined(WITH_APL)
+CONFIGURE_ARGS+= --disable-apl
+.endif
+
+# EBCDIC double-byte character set support is disabled by default
+.if defined(WITH_DBCS) && !defined(WITHOUT_DBCS)
+CONFIGURE_ARGS+= --enable-dbcs
+BUILD_DEPENDS+= ${LOCALBASE}/include/unicode/ucnv.h:${PORTSDIR}/devel/icu2:install
+UCM_TABLES= ibm-1027_P100-1995 \
+ ibm-300_P110-1997 \
+ ibm-837_P100-2000
+.for table_name in ${UCM_TABLES}
+PLIST_FILES+= etc/x3270/icudt28l_${table_name}.cnv
+.endfor
+.endif
+
+.if defined(WITHOUT_FT) && !defined(WITH_FT)
+CONFIGURE_ARGS+= --disable-ft
+.endif
+
+.if defined(WITHOUT_LOCAL_PROCESS) && !defined(WITH_LOCAL_PROCESS)
+CONFIGURE_ARGS+= --disable-local-process
+.endif
+
+.if defined(WITHOUT_PRINTER) && !defined(WITH_PRINTER)
+CONFIGURE_ARGS+= --disable-printer
+.endif
+
+.if defined(WITHOUT_SCRIPT) && !defined(WITH_SCRIPT)
+CONFIGURE_ARGS+= --disable-script
+.endif
+
+.if defined(WITHOUT_TN3270E) && !defined(WITH_TN3270E)
+CONFIGURE_ARGS+= --disable-tn3270e
+.endif
+
+.if defined(WITHOUT_TRACE) && !defined(WITH_TRACE)
+CONFIGURE_ARGS+= --disable-trace
+.endif
+
+pre-patch:
+# icu2-2.8 gets choked with subchar1 tags
+.if defined(WITH_DBCS) && !defined(WITHOUT_DBCS)
+ ${REINPLACE_CMD} -e 's/^<subchar1>/#<subchar1>/g' \
+ ${WRKSRC}/*.ucm
+.endif
+
+post-install:
+ -( cd ${WRKSRC} && ${GMAKE} ${MAKE_FLAGS} Makefile install.man )
+.if !defined(NOPORTDOCS)
+ -${MKDIR} ${DOCSDIR}
+ -${MKDIR} ${DOCSDIR}/html
+.for i in ${PORTDOCS}
+ -${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+ @${ECHO_MSG} "===> Extra Documentation installed in ${DOCSDIR}/html ."
+.endif
+
+post-deinstall:
+ -${RMDIR} ${DOCSDIR}/html
+ -${RMDIR} ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/net/c3270/distinfo b/net/c3270/distinfo
new file mode 100644
index 000000000000..a598a7e5ce5a
--- /dev/null
+++ b/net/c3270/distinfo
@@ -0,0 +1,2 @@
+MD5 (c3270-332p2.tgz) = 4f348cff45a23e9021e713cfd94fd798
+SIZE (c3270-332p2.tgz) = 559993
diff --git a/net/c3270/pkg-descr b/net/c3270/pkg-descr
new file mode 100644
index 000000000000..8ee4d2bbed06
--- /dev/null
+++ b/net/c3270/pkg-descr
@@ -0,0 +1,22 @@
+ From html/Intro.html:
+
+ c3270 is a curses-based IBM 3270 terminal emulator. It can be used to
+ communicate with any IBM host that supports 3270-style connections
+ over TELNET. It can also communicate with hosts that use line-by-line
+ ASCII mode to do initial login negotiation before switching to
+ full-screen 3270 mode.
+
+ From "pr3287/README":
+
+ pr3287 is an IBM 3287 printer emulator. It connects to an IBM host via
+ TELNET, using TN3270 or TN3270E. It supports SCS (SNA Character Stream).
+
+
+ This release provides some support for SSL, Tcl, and DBCS.
+
+ Graphics not (yet) supported.
+
+ Some extended highlighting not (yet) supported.
+
+WWW: http://x3270.bgp.nu/
+ or http://www.geocities.com/SiliconValley/Peaks/7814