aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/projectionlib/Makefile30
-rw-r--r--misc/projectionlib/distinfo1
-rw-r--r--misc/projectionlib/files/Makefile11
-rw-r--r--misc/projectionlib/files/patch-aa11
-rw-r--r--misc/projectionlib/files/patch-ab17
-rw-r--r--misc/projectionlib/files/patch-ac11
-rw-r--r--misc/projectionlib/files/patch-ad11
-rw-r--r--misc/projectionlib/files/patch-ae17
-rw-r--r--misc/projectionlib/files/patch-af11
-rw-r--r--misc/projectionlib/files/patch-ag18
-rw-r--r--misc/projectionlib/files/patch-ah11
-rw-r--r--misc/projectionlib/files/patch-ai11
-rw-r--r--misc/projectionlib/files/patch-aj11
-rw-r--r--misc/projectionlib/files/patch-ak11
-rw-r--r--misc/projectionlib/pkg-comment1
-rw-r--r--misc/projectionlib/pkg-descr6
-rw-r--r--misc/projectionlib/pkg-plist34
18 files changed, 224 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index ed905c33f775..b550c6c843c7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -126,6 +126,7 @@
SUBDIR += pinfo
SUBDIR += pkg_tarup
SUBDIR += porteasy
+ SUBDIR += projectionlib
SUBDIR += proxyper
SUBDIR += py-distutils
SUBDIR += pybliographer
diff --git a/misc/projectionlib/Makefile b/misc/projectionlib/Makefile
new file mode 100644
index 000000000000..d810ce97d5f0
--- /dev/null
+++ b/misc/projectionlib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ProjectionLib library from VTP
+# Date created: 26 Apr 2001
+# Whom: Randall Hopper <aa8vb@nc.rr.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= projectionlib
+PORTVERSION= 3.7
+CATEGORIES= misc
+MASTER_SITES= ftp://ftpmcmc.er.usgs.gov/release/viewers/dlgv32/source/
+DISTNAME= Dlgv32v37
+
+MAINTAINER= aa8vb@nc.rr.com
+
+LIB_DEPENDS= gctpc.1:${PORTSDIR}/misc/gctpc
+
+EXTRACT_CMD= unzip -a
+
+WRKSRC= ${WRKDIR}/dlgv32/ProjectionLib
+
+USE_ZIP= yes
+INSTALLS_SHLIB= yes
+MAKEFILE= ${FILESDIR}/Makefile
+
+post-install:
+ ${MKDIR} ${PREFIX}/include/ProjectionLib
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/ProjectionLib
+
+.include <bsd.port.mk>
diff --git a/misc/projectionlib/distinfo b/misc/projectionlib/distinfo
new file mode 100644
index 000000000000..f64a45d9381c
--- /dev/null
+++ b/misc/projectionlib/distinfo
@@ -0,0 +1 @@
+MD5 (Dlgv32v37.zip) = 067dcd5a9b7be359b3275cf16d45ab17
diff --git a/misc/projectionlib/files/Makefile b/misc/projectionlib/files/Makefile
new file mode 100644
index 000000000000..1f6a592485a7
--- /dev/null
+++ b/misc/projectionlib/files/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+LIB= projection
+SRCS!= echo ${.CURDIR}/*.cpp
+CXXFLAGS+= -I${LOCALBASE}/include
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 0
+LIBDIR= ${PREFIX}/lib
+NOPROFILE= true
+
+.include <bsd.lib.mk>
diff --git a/misc/projectionlib/files/patch-aa b/misc/projectionlib/files/patch-aa
new file mode 100644
index 000000000000..b36ef2c6f34e
--- /dev/null
+++ b/misc/projectionlib/files/patch-aa
@@ -0,0 +1,11 @@
+diff -ruN ORIG/AlaskaConformalProjection.cpp AlaskaConformalProjection.cpp
+--- ORIG/AlaskaConformalProjection.cpp Fri May 5 07:24:56 2000
++++ AlaskaConformalProjection.cpp Fri Apr 27 19:07:38 2001
+@@ -8,6 +8,7 @@
+ #include "AlaskaConformalProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/gctp.h"
diff --git a/misc/projectionlib/files/patch-ab b/misc/projectionlib/files/patch-ab
new file mode 100644
index 000000000000..7fe6980bc010
--- /dev/null
+++ b/misc/projectionlib/files/patch-ab
@@ -0,0 +1,17 @@
+diff -ruN ORIG/AzimuthalProjection.cpp AzimuthalProjection.cpp
+--- ORIG/AzimuthalProjection.cpp Fri May 5 07:24:56 2000
++++ AzimuthalProjection.cpp Fri Apr 27 19:07:35 2001
+@@ -7,6 +7,7 @@
+ #include "AzimuthalProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/proj.h"
+@@ -257,4 +258,4 @@
+ {
+ return true;
+ }
+-}
++}
diff --git a/misc/projectionlib/files/patch-ac b/misc/projectionlib/files/patch-ac
new file mode 100644
index 000000000000..52f4c84b43f3
--- /dev/null
+++ b/misc/projectionlib/files/patch-ac
@@ -0,0 +1,11 @@
+diff -ruN ORIG/ConicProjection.cpp ConicProjection.cpp
+--- ORIG/ConicProjection.cpp Fri May 5 07:24:56 2000
++++ ConicProjection.cpp Fri Apr 27 19:07:21 2001
+@@ -7,6 +7,7 @@
+ #include "ConicProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/proj.h"
diff --git a/misc/projectionlib/files/patch-ad b/misc/projectionlib/files/patch-ad
new file mode 100644
index 000000000000..092e3c62a210
--- /dev/null
+++ b/misc/projectionlib/files/patch-ad
@@ -0,0 +1,11 @@
+diff -ruN ORIG/HotineObliqueMercatorProjection.cpp HotineObliqueMercatorProjection.cpp
+--- ORIG/HotineObliqueMercatorProjection.cpp Fri May 5 07:24:56 2000
++++ HotineObliqueMercatorProjection.cpp Fri Apr 27 19:07:19 2001
+@@ -5,6 +5,7 @@
+ //////////////////////////////////////////////////////////////////////
+
+ #include "HotineObliqueMercatorProjection.h"
++#include <stdio.h>
+
+ //////////////////////////////////////////////////////////////////////
+ // Construction/Destruction
diff --git a/misc/projectionlib/files/patch-ae b/misc/projectionlib/files/patch-ae
new file mode 100644
index 000000000000..e6754e65116a
--- /dev/null
+++ b/misc/projectionlib/files/patch-ae
@@ -0,0 +1,17 @@
+diff -ruN ORIG/MercatorProjection.cpp MercatorProjection.cpp
+--- ORIG/MercatorProjection.cpp Fri May 5 07:24:56 2000
++++ MercatorProjection.cpp Fri Apr 27 19:07:15 2001
+@@ -7,6 +7,7 @@
+ #include "MercatorProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/proj.h"
+@@ -240,4 +241,4 @@
+ }
+
+ return ( latitude >= -86.0 && latitude <= 86.0 );
+-}
++}
diff --git a/misc/projectionlib/files/patch-af b/misc/projectionlib/files/patch-af
new file mode 100644
index 000000000000..30f2c5738346
--- /dev/null
+++ b/misc/projectionlib/files/patch-af
@@ -0,0 +1,11 @@
+diff -ruN ORIG/PolarStereographicProjection.cpp PolarStereographicProjection.cpp
+--- ORIG/PolarStereographicProjection.cpp Fri May 5 07:24:56 2000
++++ PolarStereographicProjection.cpp Fri Apr 27 19:07:11 2001
+@@ -4,6 +4,7 @@
+ // Started: 2/26/98
+
+ #include "PolarStereographicProjection.h"
++#include <stdio.h>
+
+ PolarStereographicProjection::PolarStereographicProjection( double longPole, double trueScale,
+ double sMajor, double sMinor,
diff --git a/misc/projectionlib/files/patch-ag b/misc/projectionlib/files/patch-ag
new file mode 100644
index 000000000000..e1303a93a72d
--- /dev/null
+++ b/misc/projectionlib/files/patch-ag
@@ -0,0 +1,18 @@
+diff -ruN ORIG/Projection.cpp Projection.cpp
+--- ORIG/Projection.cpp Fri May 5 07:24:56 2000
++++ Projection.cpp Fri Apr 27 19:07:08 2001
+@@ -9,6 +9,8 @@
+ #include "GeographicProjection.h"
+ #include "gctpc/untfz.h"
+
++#include <stdio.h>
++
+ #ifndef NULL
+ #define NULL 0
+ #endif
+@@ -238,4 +240,4 @@
+ longitude /= factor;
+
+ return bResult;
+-}
++}
diff --git a/misc/projectionlib/files/patch-ah b/misc/projectionlib/files/patch-ah
new file mode 100644
index 000000000000..3fe3e55259a8
--- /dev/null
+++ b/misc/projectionlib/files/patch-ah
@@ -0,0 +1,11 @@
+diff -ruN ORIG/PseudocylindricalProjection.cpp PseudocylindricalProjection.cpp
+--- ORIG/PseudocylindricalProjection.cpp Fri May 5 07:24:56 2000
++++ PseudocylindricalProjection.cpp Fri Apr 27 19:07:04 2001
+@@ -7,6 +7,7 @@
+ #include "PseudocylindricalProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/proj.h"
diff --git a/misc/projectionlib/files/patch-ai b/misc/projectionlib/files/patch-ai
new file mode 100644
index 000000000000..ce3a9ab915df
--- /dev/null
+++ b/misc/projectionlib/files/patch-ai
@@ -0,0 +1,11 @@
+diff -ruN ORIG/StatePlaneProjection.cpp StatePlaneProjection.cpp
+--- ORIG/StatePlaneProjection.cpp Fri May 5 07:24:56 2000
++++ StatePlaneProjection.cpp Fri Apr 27 19:06:46 2001
+@@ -7,6 +7,7 @@
+ #include "StatePlaneProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctp.h"
+ #include "gctpc/gctpc.h"
diff --git a/misc/projectionlib/files/patch-aj b/misc/projectionlib/files/patch-aj
new file mode 100644
index 000000000000..30cd0551f47c
--- /dev/null
+++ b/misc/projectionlib/files/patch-aj
@@ -0,0 +1,11 @@
+diff -ruN ORIG/TransverseMercatorProjection.cpp TransverseMercatorProjection.cpp
+--- ORIG/TransverseMercatorProjection.cpp Fri May 5 07:24:56 2000
++++ TransverseMercatorProjection.cpp Fri Apr 27 19:07:00 2001
+@@ -7,6 +7,7 @@
+ #include "TransverseMercatorProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/gctp.h"
diff --git a/misc/projectionlib/files/patch-ak b/misc/projectionlib/files/patch-ak
new file mode 100644
index 000000000000..2938eb5853fd
--- /dev/null
+++ b/misc/projectionlib/files/patch-ak
@@ -0,0 +1,11 @@
+diff -ruN ORIG/UTMProjection.cpp UTMProjection.cpp
+--- ORIG/UTMProjection.cpp Fri May 5 07:24:56 2000
++++ UTMProjection.cpp Fri Apr 27 19:06:57 2001
+@@ -7,6 +7,7 @@
+ #include "UTMProjection.h"
+ #include "DatumConvertor.h"
+
++#include <stdio.h>
+ // GCTPC includes
+ #include "gctpc/gctpc.h"
+ #include "gctpc/gctp.h"
diff --git a/misc/projectionlib/pkg-comment b/misc/projectionlib/pkg-comment
new file mode 100644
index 000000000000..8e511b6b174f
--- /dev/null
+++ b/misc/projectionlib/pkg-comment
@@ -0,0 +1 @@
+A C++ wrapper for the USGS GCTP projection library
diff --git a/misc/projectionlib/pkg-descr b/misc/projectionlib/pkg-descr
new file mode 100644
index 000000000000..f053bc978165
--- /dev/null
+++ b/misc/projectionlib/pkg-descr
@@ -0,0 +1,6 @@
+C++ wrapper for the USGS GCTP projection library.
+
+This library is delivered as part of the USGS dlgv32 application used
+for viewing Digital Line Graph products.
+
+WWW: http://mcmcweb.er.usgs.gov/viewers/dlg_view.html
diff --git a/misc/projectionlib/pkg-plist b/misc/projectionlib/pkg-plist
new file mode 100644
index 000000000000..ced004405903
--- /dev/null
+++ b/misc/projectionlib/pkg-plist
@@ -0,0 +1,34 @@
+include/ProjectionLib/AlaskaConformalProjection.h
+include/ProjectionLib/AlbersConicProjection.h
+include/ProjectionLib/AzimuthalEquidistantProjection.h
+include/ProjectionLib/AzimuthalProjection.h
+include/ProjectionLib/ConicProjection.h
+include/ProjectionLib/DatumConvertor.h
+include/ProjectionLib/EquidistantConicProjection.h
+include/ProjectionLib/EquirectangularProjection.h
+include/ProjectionLib/GeographicProjection.h
+include/ProjectionLib/GnomonicProjection.h
+include/ProjectionLib/HotineObliqueMercatorProjection.h
+include/ProjectionLib/LambertAzimuthalProjection.h
+include/ProjectionLib/LambertConformalConicProjection.h
+include/ProjectionLib/MercatorProjection.h
+include/ProjectionLib/MillerCylindricalProjection.h
+include/ProjectionLib/OrthographicProjection.h
+include/ProjectionLib/PolarStereographicProjection.h
+include/ProjectionLib/PolyconicProjection.h
+include/ProjectionLib/Projection.h
+include/ProjectionLib/ProjectionTypes.h
+include/ProjectionLib/PseudocylindricalProjection.h
+include/ProjectionLib/RobinsonProjection.h
+include/ProjectionLib/SinusoidalProjection.h
+include/ProjectionLib/StatePlaneProjection.h
+include/ProjectionLib/StereographicProjection.h
+include/ProjectionLib/TransverseMercatorProjection.h
+include/ProjectionLib/UTMProjection.h
+include/ProjectionLib/UnknownProjection.h
+include/ProjectionLib/VanDerGrintenProjection.h
+include/ProjectionLib/ZonedProjection.h
+lib/libprojection.a
+lib/libprojection.so
+lib/libprojection.so.1
+@dirrm include/ProjectionLib
2014-02-12 18:15:56 +0800'>2014-02-122-3/+4 * - update MASTER_SITES and pass maintainership to submitterrm2014-02-121-10/+6 * Remove note re: IPv6. Updated luasocket enables Prosody to use it.lx2014-02-121-6/+2 * - Update to 3.9.1 [1]gahr2014-02-115-66/+53 * Update to 0.9.3.lx2014-02-112-3/+3 * Update to 0.46ehaupt2014-02-112-3/+3 * According to the Porter's Handbook (5.12.2.3.) default options must be added toehaupt2014-02-107-0/+16 * Back to the futurbapt2014-02-101-1/+1 * Mark as deprecated unmaintained ports for which no public distfiles arebapt2014-02-101-0/+3 * Fix invalid conditionalmm2014-02-101-1/+2 * Remove certificate-related makefile and .cnf files on deinstall.lx2014-02-091-2/+5 * Update to 0.9.2.lx2014-02-098-92/+94 * Chase boost and icu bumpbapt2014-02-077-1/+7 * Stagify.kwm2014-02-062-3/+5 * USES_GNOME=gnomehack -> USES=pathfixmandree2014-02-062-3/+4 * Force this port to build under GCC. This fixes an issue where meanwhilemarcus2014-02-061-1/+2 * Fix SILC dependency so the lib is found if installed.mandree2014-02-061-1/+1 * Update to 2.10.9. See https://developer.pidgin.im/wiki/ChangeLog for themarcus2014-02-062-3/+3 * - Fix brokenness on 10-RELEASE due to expat libraryashish2014-02-054-37/+32 * - fix build with clangdinoex2014-02-051-2/+1 * Update to 2.10.8.marcus2014-02-049-97/+43 * - Stage supportmiwi2014-01-311-2/+1 * - Stage supportmiwi2014-01-314-8/+14 * - Convert to USESmiwi2014-01-311-4/+2 * - Stage supportmiwi2014-01-312-3/+0 * - Stage supportmiwi2014-01-311-1/+0 * - Convert to PYDISTUTILS_AUTOPLISTmiwi2014-01-312-41/+2 * - Stage supportmiwi2014-01-313-5/+1 * - Stage supportmiwi2014-01-311-4/+2 * - Stage supportmiwi2014-01-312-3/+1 * - add stage supportaz2014-01-3013-67/+58 * Finish stage supportantoine2014-01-272-5/+4 * Support stagebapt2014-01-261-3/+2 * Support stagebapt2014-01-261-4/+3 * Fix on 10 and tweak rc script.lx2014-01-252-3/+3 * - Stage Safemiwi2014-01-242-2/+0 * - Stageifymiwi2014-01-241-1/+0 * Fix properties on pkg-plistbapt2014-01-225-5/+0 * - Fix build on head/10madpilot2014-01-179-7/+87 * - Convert to USES=tcl and USES=gmakegahr2014-01-171-19/+14 * - Convert to USES=tkgahr2014-01-171-6/+6 * - Convert to USES=tkgahr2014-01-173-17/+24 * - Convert to USES=tkgahr2014-01-171-11/+7 * Python cleanup:rene2014-01-1414-14/+14 * - add USE_GCC for CURRENTdinoex2014-01-112-0/+2 * - Update to 0.2.2.1476tota2014-01-102-4/+4 * Support stagingrakuco2014-01-0610-10/+1 * Support stagingrakuco2014-01-061-1/+0 * Support stagingrakuco2014-01-061-1/+0 * Support stagingrakuco2014-01-061-1/+0 * Remove expired ports:rene2014-01-045-45/+0 * - Update from 0.5.0.111 to 0.6.3danilo2014-01-045-46/+39 * Part 2 at removing now useless FETCH_ARGS redifitionbapt2014-01-031-1/+0 * - Add LICENSEsunpoet2013-12-311-3/+4 * - rename AL2 to APACHE20 in Mk/bsd.licenses.db.mkohauer2013-12-311-1/+1 * net-im/py-pyxmpp: fix PORTREVISIONwg2013-12-271-1/+1 * net-im/py-pyxmpp: allow staging and minor fixeswg2013-12-272-162/+4 * net-im/py-punjab: support stagingwg2013-12-272-58/+9 * Remove expired port:rene2013-12-236-94/+0 * - Fix build on 10.0 and 11-CURRENTswills2013-12-201-2/+2 * - Support USE_GITHUBdanilo2013-12-191-16/+15 * Use new LIB_DEPENDS regimeehaupt2013-12-182-2/+2 * - Update to 0.10.2dhn2013-12-183-4/+8 * - Update to 2.2.1dhn2013-12-184-7/+42 * - use STAGEDIRdinoex2013-12-175-60/+40 * Switch to MASTER_SITES LOCAL/matthew for the 8.x compatible locationmatthew2013-12-171-1/+1 * Update to 2.3.1matthew2013-12-1614-193/+212 * net-im/cjc: fix python usage and minor fixeswg2013-12-151-4/+6 * net-im/telepathy-idle: fix python dependswg2013-12-151-0/+1 * Update to r664:mandree2013-12-143-15/+16 * Convert LIB_DEPENDS for ports depending on boostbapt2013-12-125-7/+7 * New USES=twisted, to replace the old USE_TWISTED knob.mva2013-12-081-1/+1 * Mark as broken:bapt2013-12-061-0/+2 * - Update to 1.6.9olivierd2013-12-025-145/+49 * Remove expired ports:rene2013-12-0118-741/+0 * Fix the v4l2 GST plugin name. The gst_v4l2 is the port module name, not themarcus2013-11-301-1/+1 * - Fix build with clangsunpoet2013-11-301-0/+11 * Bump PORTREVISION as voice/video support is in the default OPTIONS set.marcus2013-11-291-1/+1 * Make sure gstreamer-plugins-v4l2 is installed if voice/video support ismarcus2013-11-291-0/+1 * - Support STAGEDIRlwhsu2013-11-291-1/+0 * - Update to 0.2.2.1430tota2013-11-262-8/+9 * - Update to 0.14.0sunpoet2013-11-252-4/+4 * Skype4Py is a Python library which allows you to control Skype clientnivit2013-11-234-0/+31 * - Convert to USES=qmakemakc2013-11-224-25/+22 * - Convert to USES=qmake (and other USES while I'm here)makc2013-11-222-10/+6 * - Update to 0.13.0sunpoet2013-11-222-4/+4 * - Convert to USE=tkgahr2013-11-221-10/+16 * - Remove now needless qmake_build from USE_QT4makc2013-11-221-1/+1 * Replace deprecated QMAKEFLAGS with QMAKE_ARGSmakc2013-11-212-3/+3 * - Convert to dos2unix.mkmat2013-11-202-5/+4 * Deprecate net-im/tapioca-qt and net-im/telepathy-qt.rakuco2013-11-182-0/+6 * Remove expired ports:rene2013-11-176-110/+0 * - Replace QT_.*_REL with QT_.* in PLIST_SUB.avilla2013-11-171-1/+1 * - Update to 13.2.0sunpoet2013-11-162-3/+3 * - Return maintainership back to poolsunpoet2013-11-152-29/+13 * - Convert to USES+=tkgahr2013-11-131-9/+6 * - STAGEify.avilla2013-11-131-29/+20 * Deprecate ports which depend on Linux GTK1 libraries and schedule them for re...rene2013-11-111-1/+4 * - Update to 0.2.2.1410tota2013-11-102-9/+5 * Update to 0.3.6.kwm2013-11-081-2/+2 * Welcome CMake 2.8.12!rakuco2013-11-062-0/+80 * Remove expired ports:rene2013-11-057-89/+0 * Support STAGEDIR.vanilla2013-11-0522-241/+228 * Deprecated, set an EXPIRATION_DATE of 2 months from now, because there's noolivierd2013-11-041-0/+3 * - Disable the MSN plugin, as it depends on the deprecated net-im/libmsnrakuco2013-11-04