aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/qpopper/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index b9bd9c8a699e..b82abd851fec 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -26,7 +26,7 @@ MAINTAINER= lioux@FreeBSD.org
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lmd -lutil" \
+CONFIGURE_ENV= LIBS="-lmd -lutil -L${LOCALBASE}/lib" \
OS_DEFS="-DSETPROCTITLE ${OS_DEFS}"
CONFIGURE_ARGS= --enable-apop=${PREFIX}/etc/qpopper/pop.auth \
--enable-nonauth-file=${POPUSERS_FILE} \
@@ -68,6 +68,8 @@ pre-everything::
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG} ""
@${ECHO_MSG} "WITH_APOP_ONLY=yes builds with APOP authentication only"
+ @${ECHO_MSG} "WITH_DRAC=yes builds with Dynamic Relay Authorization"
+ @${ECHO_MSG} " Control support"
@${ECHO_MSG} "WITH_FULL_POPD_DEBUG=yes buils with more verbose debugging"
@${ECHO_MSG} "WITH_POPPASSD=yes builds the poppassd daemon"
@${ECHO_MSG} "WITH_SAMPLE_POPUSERS_FILE=yes builds a default (otherwise,"
@@ -79,6 +81,13 @@ pre-everything::
OS_DEFS+= -DAPOP_ONLY
.endif
+# If WITH_DRAC variable present in the environment, qpopper builds
+# with Dynamic Relay Authorization Control support
+.if defined(WITH_DRAC)
+CONFIGURE_ARGS+= --with-drac
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
+.endif
+
# If WITH_FULL_POPD_DEBUG variable present in the environment, qpopper builds
# with more verbose debugging. See also -d option to qpopper
.if defined(FULL_POPD_DEBUG) || defined(WITH_FULL_POPD_DEBUG)