aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/gpscorrelate/Makefile24
-rw-r--r--astro/merkaartor/Makefile4
-rw-r--r--deskutils/libstreamanalyzer/Makefile2
-rw-r--r--deskutils/pinot/Makefile10
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--graphics/darktable/Makefile7
-rw-r--r--graphics/geeqie/Makefile5
-rw-r--r--graphics/gegl/Makefile13
-rw-r--r--graphics/gexiv2/Makefile8
-rw-r--r--graphics/gimp-lensfun-plugin/Makefile9
-rw-r--r--graphics/gthumb/Makefile5
-rw-r--r--graphics/gwenview-kde4/Makefile3
-rw-r--r--graphics/hugin-devel/Makefile6
-rw-r--r--graphics/hugin/Makefile5
-rw-r--r--graphics/kphotoalbum-kde4/Makefile5
-rw-r--r--graphics/libkexiv2-kde4/Makefile5
-rw-r--r--graphics/luminance/Makefile2
-rw-r--r--graphics/nomacs/Makefile6
-rw-r--r--graphics/oyranos/Makefile3
-rw-r--r--graphics/py-exiv2/Makefile5
-rw-r--r--graphics/rawstudio/Makefile9
-rw-r--r--graphics/ufraw/Makefile2
-rw-r--r--graphics/viewnior/Makefile1
-rw-r--r--sysutils/bulk_extractor/Makefile1
-rw-r--r--sysutils/krename-kde4/Makefile4
-rw-r--r--sysutils/nepomuk-core/Makefile1
-rw-r--r--textproc/libextractor/Makefile7
-rw-r--r--x11/kde4-runtime/Makefile1
28 files changed, 78 insertions, 77 deletions
diff --git a/astro/gpscorrelate/Makefile b/astro/gpscorrelate/Makefile
index 4e7225584a5b..11ff864772ae 100644
--- a/astro/gpscorrelate/Makefile
+++ b/astro/gpscorrelate/Makefile
@@ -1,9 +1,9 @@
-# Created by: Lukas Maly
+# Created by: Lukas Maly <Iam@LukasMaly.NET>
# $FreeBSD$
PORTNAME= gpscorrelate
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro geography
MASTER_SITES= GH
DIST_SUBDIR= repacked
@@ -16,20 +16,18 @@ LICENSE= GPLv2
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
-OPTIONS_DEFINE= DOCS
+USES= gmake pkgconfig
+USE_GNOME= libxml2
USE_GITHUB= yes
GH_ACCOUNT= freefoote
GH_COMMIT= a36646b
-USES= gmake pkgconfig
-USE_GNOME= libxml2
-
-PORTDOCS= *
PLIST_FILES= bin/gpscorrelate bin/gpscorrelate-gui \
man/man1/gpscorrelate.1.gz man/man1/gpscorrelate-gui.1.gz
+PORTDOCS= *
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e \
@@ -42,20 +40,20 @@ post-patch:
s|g++ $$(OFLAGS)|$$(CXX) $$(OFLAGS)| ; \
s|g++ $$(CFLAGS)|$$(CXX) $$(CXXFLAGS) $$(IFLAGS)| ; \
s|gcc $$(CFLAGS)|$$(CC) $$(CFLAGS) $$(IFLAGS)|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate-gui ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/gpscorrelate.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${LN} -sf gpscorrelate.1 ${STAGEDIR}${MANPREFIX}/man/man1/gpscorrelate-gui.1
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_MAN} ${FILESDIR}/gpscorrelate.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${LN} -sf gpscorrelate.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1/gpscorrelate-gui.1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/RELEASES ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.png ${STAGEDIR}${DOCSDIR}/html
-.endif
.include <bsd.port.mk>
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index ae5f3f166939..abe83ae6811b 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -1,9 +1,9 @@
-# Created by: slaven@rezic.de
+# Created by: Slaven Rezic <slaven@rezic.de>
# $FreeBSD$
PORTNAME= merkaartor
PORTVERSION= 0.18.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= http://merkaartor.be/attachments/download/301/ \
https://secure.ohos.nl/downloads/
diff --git a/deskutils/libstreamanalyzer/Makefile b/deskutils/libstreamanalyzer/Makefile
index e8f0f9707f59..5184d8216846 100644
--- a/deskutils/libstreamanalyzer/Makefile
+++ b/deskutils/libstreamanalyzer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libstreamanalyzer
PORTVERSION= ${STRIGI_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= ${STRIGI_MASTER_SITES}
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 33041cc2fa83..5ff01389370d 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -3,9 +3,9 @@
PORTNAME= pinot
PORTVERSION= 1.06
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= deskutils
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
#MASTER_SITES= http://colinf.chez.com/pinot/
# http://amra.dyndns.org/
@@ -45,11 +45,11 @@ CONFIGURE_ARGS= --with-http=curl --with-ssl=${OPENSSLBASE} --enable-libarchive \
CONFIGURE_ENV= MKDIR_P="${MKDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
-USE_XORG= pixman
USES= gettext pkgconfig shebangfix
-USE_SQLITE= 3
-USE_PYTHON= yes
USE_OPENSSL= yes
+USE_PYTHON= yes
+USE_SQLITE= 3
+USE_XORG= pixman
USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
SHEBANG_LANG= bash
SHEBANG_FILES= scripts/bash/*.sh
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 790e01edc30d..7b7aa97eaf02 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= calligra
PORTVERSION= ${CALLIGRA_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${CALLIGRA_BRANCH}/${PORTNAME}-${PORTVERSION}/
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index e32d0f58c4cd..27ac3b6d2268 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= darktable
PORTVERSION= 1.2.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -22,8 +22,7 @@ LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE extensions
-USES= cmake:outsource pkgconfig
-USE_XZ= yes
+USES= cmake:outsource pkgconfig tar:xz
USE_GNOME= librsvg2
USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
@@ -40,7 +39,7 @@ RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
GCC_DESC= Build with modern GCC (better OpenMP support)
-OPTIONS_DEFAULT= GPHOTO RAWSPEED GCC
+OPTIONS_DEFAULT= GPHOTO RAWSPEED #GCC
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 1c82e84b96ea..d91528c83d9a 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -3,6 +3,7 @@
PORTNAME= geeqie
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -11,13 +12,13 @@ COMMENT= Lightweight image viewer forked from GQview
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+USES= gettext gmake pkgconfig
USE_GNOME= gtk20 desktopfileutils
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir="${DOCSDIR}" \
--htmldir="${DOCSDIR}/html" \
--with-htmldir="${DOCSDIR}/html" \
--with-readmedir="${DOCSDIR}"
-USES= gettext gmake pkgconfig
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= ${CFLAGS}
@@ -31,7 +32,7 @@ OPTIONS_DEFAULT=EXIV2 LCMS
EXIV2_DESC= Metadata editing
LCMS_DESC= Color adjusting
LIRC_DESC= Remote control
-GPS_DESC= GPS map support (libchamplain) EXPERIMENTAL
+GPS_DESC= GPS map support via libchamplain (experimental!)
EXIV2_LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
EXIV2_CONFIGURE_ENABLE= exiv2
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index f2434bae5ec0..c166106f9f96 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -1,9 +1,9 @@
-# Created by: gahr
+# Created by: Pietro Cerutti <gahr@FreeBSD.org>
# $FreeBSD$
PORTNAME= gegl
PORTVERSION= 0.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.2/
@@ -21,14 +21,13 @@ ENSCRIPT_DESC= Enscript support
SPIRO_DESC= Spiro support
#UMFPACK_DESC= UMFpack support
+USES= gettext gmake pathfix pkgconfig shebangfix tar:bzip2
USE_GNOME= glib20 intltool
-USES= gettext pathfix pkgconfig shebangfix
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/gegl-0.2
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= ac_cv_header_execinfo_h=no
-CONFIGURE_ARGS+=--without-vala --disable-docs
+CONFIGURE_ENV= ac_cv_header_execinfo_h=no
+CONFIGURE_ARGS= --without-vala --disable-docs
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index 0a307cc43a37..9bf8de876be7 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -3,9 +3,10 @@
PORTNAME= gexiv2
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://yorba.org/download/${PORTNAME}/${PORTVERSION:R}/
-DISTNAME= libgexiv2_${PORTVERSION}
+DISTNAME= lib${PORTNAME}_${PORTVERSION}
WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -15,10 +16,9 @@ LICENSE= GPLv2
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool \
gm4:${PORTSDIR}/devel/m4
-LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2
+LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
-USES= gmake pkgconfig
-USE_XZ= yes
+USES= gmake pkgconfig tar:xz
USE_GNOME= glib20
USE_LDCONFIG= yes
MAKE_ARGS= REQUIRED_CFLAGS=""
diff --git a/graphics/gimp-lensfun-plugin/Makefile b/graphics/gimp-lensfun-plugin/Makefile
index 131fd3e92b13..fc36e6227454 100644
--- a/graphics/gimp-lensfun-plugin/Makefile
+++ b/graphics/gimp-lensfun-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lensfun
DISTVERSION= 0.2.4-dev
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= gimp-
PKGNAMESUFFIX= -plugin
@@ -15,9 +16,9 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/exiv2.pc:${PORTSDIR}/graphics/exiv2 \
${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
${LOCALBASE}/libdata/pkgconfig/lensfun.pc:${PORTSDIR}/graphics/lensfun
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/exiv2.pc:${PORTSDIR}/graphics/exiv2 \
- ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
- ${LOCALBASE}/libdata/pkgconfig/lensfun.pc:${PORTSDIR}/graphics/lensfun
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= gmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= seebk
@@ -25,8 +26,6 @@ GH_PROJECT= GIMP-Lensfun
GH_COMMIT= d0a0bd2
GH_TAGNAME= ${GH_COMMIT}
-USES= gmake pkgconfig
-
PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
PLUGINS= gimp-lensfun
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 9ca2a99d0430..329d0625a485 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gthumb
PORTVERSION= 2.14.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -14,8 +14,7 @@ COMMENT= Image viewer and browser for the GNOME 2 environment
LIB_DEPENDS= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gsettings-desktop-schemas.pc:${PORTSDIR}/devel/gsettings-desktop-schemas
-USE_XZ= yes
-USES= bison gmake pathfix pkgconfig gettext
+USES= bison gettext gmake pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix intlhack gnomedocutils gconf2
WANT_GSTREAMER= yes
USE_LDCONFIG= yes
diff --git a/graphics/gwenview-kde4/Makefile b/graphics/gwenview-kde4/Makefile
index b2e87c032291..d7b01ee34c94 100644
--- a/graphics/gwenview-kde4/Makefile
+++ b/graphics/gwenview-kde4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gwenview
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -12,9 +13,9 @@ COMMENT= Image viewer and browser for KDE 4
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexiv2.so:${PORTSDIR}/graphics/exiv2
+USES= cmake:outsource tar:xz
USE_KDE4= kactivities kdehier kdelibs kdeprefix libkipi libkonq \
automoc4 soprano
-USES= cmake:outsource tar:xz
USE_QT4= corelib gui opengl qmake_build moc_build uic_build rcc_build
USE_LDCONFIG= yes
diff --git a/graphics/hugin-devel/Makefile b/graphics/hugin-devel/Makefile
index 1fd60d3ceec3..89eebd95db8c 100644
--- a/graphics/hugin-devel/Makefile
+++ b/graphics/hugin-devel/Makefile
@@ -1,16 +1,16 @@
-# Created by: cartola (Carlos E. G. Carvalho)
+# Created by: Carlos Eduardo G. Carvalho <cartola@openit.com.br>
# $FreeBSD$
PORTNAME= hugin
PORTVERSION= 2013.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-2013.0
PKGNAMESUFFIX= -devel
DISTNAME= hugin-2013.0.0_beta1
MAINTAINER= grog@FreeBSD.org
-COMMENT= A GUI for Panorama Tools, to stitch panoramic images
+COMMENT= GUI for Panorama Tools, to stitch panoramic images
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 9108c7ae64c9..72925a1daf9b 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -1,13 +1,14 @@
-# Created by: cartola (Carlos E. G. Carvalho)
+# Created by: Carlos Eduardo G. Carvalho <cartola@openit.com.br>
# $FreeBSD$
PORTNAME= hugin
PORTVERSION= 2013.0.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
MAINTAINER= vd@FreeBSD.org
-COMMENT= A GUI for Panorama Tools, to stitch panoramic images
+COMMENT= GUI for Panorama Tools, to stitch panoramic images
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libImath.so:${PORTSDIR}/graphics/ilmbase \
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index e1a4e6aa1d01..42122682a8ac 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kphotoalbum
PORTVERSION= 4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
DIST_SUBDIR= KDE
@@ -14,11 +14,10 @@ COMMENT= Image viewer and organizer for KDE
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexiv2.so:${PORTSDIR}/graphics/exiv2
+USES= cmake:outsource pkgconfig tar:bzip2
USE_KDE4= kdehier kdelibs kdeprefix libkdcraw libkipi automoc4
USE_QT4= phonon sql \
qmake_build moc_build rcc_build uic_build
-USE_BZIP2= yes
-USES= cmake:outsource pkgconfig
OPTIONS_DEFINE= MARBLE NLS
OPTIONS_DEFAULT= MARBLE
diff --git a/graphics/libkexiv2-kde4/Makefile b/graphics/libkexiv2-kde4/Makefile
index dd21319becfc..a62ac5801f80 100644
--- a/graphics/libkexiv2-kde4/Makefile
+++ b/graphics/libkexiv2-kde4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libkexiv2
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -11,8 +12,8 @@ COMMENT= Exiv2 library interface for KDE
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
-USE_KDE4= automoc4 kdehier kdeprefix kdelibs
USES= cmake:outsource tar:xz
+USE_KDE4= automoc4 kdehier kdeprefix kdelibs
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
@@ -20,6 +21,6 @@ USE_LDCONFIG= yes
pre-configure:
${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_INSTALL_DIR}/libdata/' \
-e 's/${PORTNAME}.pc\([^.]\)/${PORTNAME}-kde4.pc\1/g' \
- ${WRKSRC}/CMakeLists.txt
+ ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index e0d9e35dd6d6..7ae2e827fc95 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= luminance-hdr
-PORTREVISION= 5
DISTVERSION= 2.3.0
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index 87da55de50f3..96123067ac42 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -2,20 +2,20 @@
PORTNAME= nomacs
PORTVERSION= 1.6.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/nomacs/nomacs-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= bsd@tuxproject.de
-COMMENT= Small, fast and free image viewer
+COMMENT= Small, fast, and free image viewer
LICENSE= GPLv3
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
libsysinfo.so:${PORTSDIR}/devel/libsysinfo
-USE_BZIP2= yes
-USES= cmake desktop-file-utils dos2unix pkgconfig
+USES= cmake desktop-file-utils dos2unix pkgconfig tar:bzip2
USE_QT4= gui network linguist_build moc_build \
qmake_build rcc_build uic_build
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 36c859814ccf..f2b25d634941 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -2,6 +2,7 @@
PORTNAME= oyranos
PORTVERSION= 0.9.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Oyranos/Oyranos%20${PORTVERSION:C|(.*)\.[0-9]*$|\1|}
@@ -24,7 +25,7 @@ LIB_DEPENDS= libraw.so:${PORTSDIR}/graphics/libraw \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libXcm.so:${PORTSDIR}/x11/libXcm
-USES= tar:bzip2 cmake gettext iconv pkgconfig
+USES= cmake gettext iconv pkgconfig tar:bzip2
USE_GL= yes
USE_LDCONFIG= yes
USE_GNOME= libxml2
diff --git a/graphics/py-exiv2/Makefile b/graphics/py-exiv2/Makefile
index fea39ecb3302..bd16c521d675 100644
--- a/graphics/py-exiv2/Makefile
+++ b/graphics/py-exiv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exiv2
PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= https://launchpadlibrarian.net/83595798/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,9 +15,8 @@ COMMENT= Python bindings for exiv2
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2\
libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-USES= gmake
+USES= gmake tar:bzip2
USE_PYTHON= 2
-USE_BZIP2= yes
USE_SCONS= yes
USE_LDCONFIG= yes
SCONS_ENV+= PREFIX=${PREFIX} CPPPATH=${PREFIX}/include LIBPATH=${PREFIX}/lib
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index 8c5e403d788c..f03e6d4d20fb 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rawstudio
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://rawstudio.org/files/release/
@@ -23,14 +23,15 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
USES= desktop-file-utils gettext gmake pathfix pkgconfig
+GNU_CONFIGURE= yes
USE_GNOME= gtk20 libxml2 gconf2
USE_SQLITE= 3
USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
post-patch:
@${REINPLACE_CMD} -e 's, libssl,,' ${WRKSRC}/configure
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 928d5436a505..b0d6a2acb1b7 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ufraw
PORTVERSION= 0.19.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/viewnior/Makefile b/graphics/viewnior/Makefile
index 9a2a53dfc8d4..105251f5a328 100644
--- a/graphics/viewnior/Makefile
+++ b/graphics/viewnior/Makefile
@@ -3,6 +3,7 @@
PORTNAME= viewnior
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= nemysis@FreeBSD.org
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index d94a4d5e1140..690a14a1ccc2 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bulk_extractor
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.digitalcorpora.org/downloads/bulk_extractor/
diff --git a/sysutils/krename-kde4/Makefile b/sysutils/krename-kde4/Makefile
index 242692a40915..fda432161a46 100644
--- a/sysutils/krename-kde4/Makefile
+++ b/sysutils/krename-kde4/Makefile
@@ -2,12 +2,12 @@
PORTNAME= krename
PORTVERSION= 4.0.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils kde
MASTER_SITES= SF/${PORTNAME}/KDE4%20${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
-COMMENT= Very powerful batch file renamer for KDE
+COMMENT= Powerful batch file renamer for KDE
LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
diff --git a/sysutils/nepomuk-core/Makefile b/sysutils/nepomuk-core/Makefile
index 5092d5851679..3d77fab87021 100644
--- a/sysutils/nepomuk-core/Makefile
+++ b/sysutils/nepomuk-core/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nepomuk-core
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index e726a9a47bd6..92a5dbb11c17 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -1,12 +1,11 @@
-# Created by: kevlo@FreeBSD.org
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
PORTNAME= libextractor
PORTVERSION= 0.6.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU
MAINTAINER= vd@FreeBSD.org
COMMENT= Library for keyword extraction
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 97b9a057ddbd..6d5909e4f81c 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kde-runtime
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}