aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LEGAL3
-rw-r--r--games/Makefile1
-rw-r--r--games/marathon2-data/Makefile34
-rw-r--r--games/marathon2-data/distinfo2
-rw-r--r--games/marathon2-data/pkg-descr8
-rw-r--r--games/marathon2-data/pkg-plist7
6 files changed, 55 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index 0ebb405f48e1..7d6bd3bfd4b1 100644
--- a/LEGAL
+++ b/LEGAL
@@ -391,6 +391,9 @@ macopix-*.tar.gz games/macopix Contains commercial character data
MarathonEvil-*.tar.gz games/marathon-evil Bungie/Microsoft do not
allow charging for Marathon data
files
+marathon2.zip games/marathon2-data Bungie/Microsoft do not
+ allow charging for Marathon data
+ files.
mathfonts-4.1/* x11-fonts/mathfonts No redistribution allowed
mbrola-freebsd/* audio/mbrola No commercial, military use
voices cannot be sold
diff --git a/games/Makefile b/games/Makefile
index cdf74f37a33a..05e989403ead 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -298,6 +298,7 @@
SUBDIR += maitretarot
SUBDIR += mangband
SUBDIR += marathon-evil
+ SUBDIR += marathon2-data
SUBDIR += marbles
SUBDIR += meqcc
SUBDIR += merlin
diff --git a/games/marathon2-data/Makefile b/games/marathon2-data/Makefile
new file mode 100644
index 000000000000..36379989b09f
--- /dev/null
+++ b/games/marathon2-data/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: marathon2-data
+# Date created: 19 March 2005
+# Whom: Evan T. Dower <evantd@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= marathon2-data
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://files3.bungie.org/trilogy/
+DISTNAME= marathon2
+
+MAINTAINER= evantd@yahoo.com
+COMMENT= Data files for the alephone port from Marathon 2
+
+RUN_DEPENDS= alephone:${PORTSDIR}/games/alephone
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+NO_BUILD= yes
+NO_CDROM= Bungie/Microsoft do not allow charging for Marathon data files.
+NO_WRKSUBDIR= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/AlephOne
+ ${INSTALL_DATA} ${WRKDIR}/Images ${PREFIX}/share/AlephOne/Durandal.Images
+ ${INSTALL_DATA} ${WRKDIR}/Map ${PREFIX}/share/AlephOne/Durandal.Map
+ ${INSTALL_DATA} ${WRKDIR}/Map.resources ${PREFIX}/share/AlephOne/Durandal.Map.resources
+ ${INSTALL_DATA} ${WRKDIR}/Music ${PREFIX}/share/AlephOne/Durandal.Music
+ ${INSTALL_DATA} ${WRKDIR}/Shapes ${PREFIX}/share/AlephOne/Durandal.Shapes
+ ${INSTALL_DATA} ${WRKDIR}/Sounds ${PREFIX}/share/AlephOne/Durandal.Sounds
+
+.include <bsd.port.mk>
diff --git a/games/marathon2-data/distinfo b/games/marathon2-data/distinfo
new file mode 100644
index 000000000000..9569a3089da9
--- /dev/null
+++ b/games/marathon2-data/distinfo
@@ -0,0 +1,2 @@
+MD5 (marathon2.zip) = cca9e8f68e8acc6da886073e685f65f1
+SIZE (marathon2.zip) = 30316515
diff --git a/games/marathon2-data/pkg-descr b/games/marathon2-data/pkg-descr
new file mode 100644
index 000000000000..2d8956c02dca
--- /dev/null
+++ b/games/marathon2-data/pkg-descr
@@ -0,0 +1,8 @@
+This port contains the Marathon 2: Durandal data files, converted to
+run on Aleph One. The Aleph One application itself is in the
+`alephone' port.
+
+Evan T. Dower
+evantd@yahoo.com
+
+WWW: http://bighouse.bungie.org/marathon2.html
diff --git a/games/marathon2-data/pkg-plist b/games/marathon2-data/pkg-plist
new file mode 100644
index 000000000000..710d7c51bda1
--- /dev/null
+++ b/games/marathon2-data/pkg-plist
@@ -0,0 +1,7 @@
+share/AlephOne/Durandal.Images
+share/AlephOne/Durandal.Map
+share/AlephOne/Durandal.Map.resources
+share/AlephOne/Durandal.Music
+share/AlephOne/Durandal.Shapes
+share/AlephOne/Durandal.Sounds
+@dirrm share/AlephOne