aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-PodToHTML/Makefile27
-rw-r--r--www/p5-PodToHTML/distinfo2
-rw-r--r--www/p5-PodToHTML/pkg-descr5
-rw-r--r--www/p5-PodToHTML/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index dd0aec498511..783faf860922 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -428,6 +428,7 @@
SUBDIR += p5-MasonX-Request-WithApacheSession
SUBDIR += p5-PHP-Session
SUBDIR += p5-ParallelUA
+ SUBDIR += p5-PodToHTML
SUBDIR += p5-Sledge
SUBDIR += p5-Sledge-Plugin-CacheContent
SUBDIR += p5-Sledge-Plugin-Download
diff --git a/www/p5-PodToHTML/Makefile b/www/p5-PodToHTML/Makefile
new file mode 100644
index 000000000000..4b8c7dc5a038
--- /dev/null
+++ b/www/p5-PodToHTML/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-PodToHTML
+# Date created: 27 February 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= PodToHTML
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Generating HTML from several files containg POD documentation
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= podtohtml.1
+MAN3= Pod::HTML_Elements.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-PodToHTML/distinfo b/www/p5-PodToHTML/distinfo
new file mode 100644
index 000000000000..72ea0e46eda3
--- /dev/null
+++ b/www/p5-PodToHTML/distinfo
@@ -0,0 +1,2 @@
+MD5 (PodToHTML-0.04.tar.gz) = b08e3351b171b719f40031a188fe5c26
+SIZE (PodToHTML-0.04.tar.gz) = 9199
diff --git a/www/p5-PodToHTML/pkg-descr b/www/p5-PodToHTML/pkg-descr
new file mode 100644
index 000000000000..ccb925bead99
--- /dev/null
+++ b/www/p5-PodToHTML/pkg-descr
@@ -0,0 +1,5 @@
+PodToHTML generates HTML from one or (more typically) several files
+containg POD documentation.
+
+It uses Pod::Parser to parse the PODs and HTML::Element to represent the
+HTML as it is generated.
diff --git a/www/p5-PodToHTML/pkg-plist b/www/p5-PodToHTML/pkg-plist
new file mode 100644
index 000000000000..5cb4c358aee9
--- /dev/null
+++ b/www/p5-PodToHTML/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/podtohtml
+%%SITE_PERL%%/Pod/Find.pm
+%%SITE_PERL%%/Pod/HTML_Elements.pm
+%%SITE_PERL%%/Pod/Links.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PodToHTML/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Pod 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/PodToHTML 2>/dev/null || true