aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/liborcus/Makefile2
-rw-r--r--devel/liborcus07/Makefile2
-rw-r--r--devel/mdds/Makefile24
-rw-r--r--devel/mdds/distinfo4
-rw-r--r--devel/mdds/files/patch-include_mdds_multi__type__vector__def.inl10
-rw-r--r--devel/mdds/files/patch-include_mdds_sorted__string__map__def.inl11
-rw-r--r--devel/mdds/pkg-plist63
-rw-r--r--devel/mdds0/Makefile30
-rw-r--r--devel/mdds0/distinfo2
-rw-r--r--devel/mdds0/files/patch-include_mdds_flat__segment__tree.hpp (renamed from devel/mdds/files/patch-include_mdds_flat__segment__tree.hpp)0
-rw-r--r--devel/mdds0/files/patch-include_mdds_flat__segment__tree__def.inl (renamed from devel/mdds/files/patch-include_mdds_flat__segment__tree__def.inl)0
-rw-r--r--devel/mdds0/files/patch-include_mdds_mixed__type__matrix__def.inl (renamed from devel/mdds/files/patch-include_mdds_mixed__type__matrix__def.inl)0
-rw-r--r--devel/mdds0/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl (renamed from devel/mdds/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl)0
-rw-r--r--devel/mdds0/files/patch-include_mdds_multi__type__vector__itr.hpp (renamed from devel/mdds/files/patch-include_mdds_multi__type__vector__itr.hpp)0
-rw-r--r--devel/mdds0/files/patch-include_mdds_point__quad__tree.hpp (renamed from devel/mdds/files/patch-include_mdds_point__quad__tree.hpp)0
-rw-r--r--devel/mdds0/pkg-descr4
-rw-r--r--devel/mdds0/pkg-plist35
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice4/Makefile2
-rw-r--r--graphics/libetonyek01/Makefile2
21 files changed, 142 insertions, 52 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 79d64df7a732..364f9a3d8123 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1481,6 +1481,7 @@
SUBDIR += maven33
SUBDIR += mcpp
SUBDIR += mdds
+ SUBDIR += mdds0
SUBDIR += memcheck
SUBDIR += menhir
SUBDIR += mercator
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index 9aa207d97505..5b89175ddded 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -10,7 +10,7 @@ COMMENT= Standalone file import filter library for spreadsheet documents
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0
LIB_DEPENDS= libboost_system.so:devel/boost-libs
GNU_CONFIGURE= yes
diff --git a/devel/liborcus07/Makefile b/devel/liborcus07/Makefile
index 93906e0bfbe5..3cfb352b8875 100644
--- a/devel/liborcus07/Makefile
+++ b/devel/liborcus07/Makefile
@@ -11,7 +11,7 @@ COMMENT= Standalone file import filter library for spreadsheet documents
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0
LIB_DEPENDS= libboost_system.so:devel/boost-libs
BROKEN_sparc64= cannot link with boost
diff --git a/devel/mdds/Makefile b/devel/mdds/Makefile
index 51548377c6ff..ce66f1d8d153 100644
--- a/devel/mdds/Makefile
+++ b/devel/mdds/Makefile
@@ -1,32 +1,36 @@
# $FreeBSD$
PORTNAME= mdds
-PORTVERSION= 0.12.1
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= devel
MASTER_SITES= http://kohei.us/files/mdds/src/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= office@FreeBSD.org
COMMENT= Multi-dimensional data index algorithm
LICENSE= MIT
-PROJECTHOST= multidimalgorithm
-
USES= tar:bzip2
NO_ARCH= yes
NO_BUILD= yes
+API_VERSION= 1.0
+PLIST_SUB= API_VERSION=${API_VERSION}
+
do-configure:
- @${SED} -e 's|@prefix@|${PREFIX}|' \
- -e 's|@includedir@|$${prefix}/include|' \
+ @${SED} -e 's|@API_VERSION@|${API_VERSION}|' \
-e 's|@VERSION@|${PORTVERSION}|' \
- ${WRKSRC}/misc/mdds.pc.in > ${WRKSRC}/misc/mdds.pc
+ -e 's|@includedir@|$${prefix}/include|' \
+ -e 's|@prefix@|${PREFIX}|' \
+ ${WRKSRC}/misc/mdds.pc.in > \
+ ${WRKSRC}/misc/mdds-${API_VERSION}.pc
do-install:
- cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
- ${INSTALL_DATA} ${WRKSRC}/misc/mdds.pc \
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/mdds-${API_VERSION}/mdds
+ (cd ${WRKSRC}/include && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${PREFIX}/include/mdds-${API_VERSION} \
+ "-not -name *.orig")
+ ${INSTALL_DATA} ${WRKSRC}/misc/mdds-${API_VERSION}.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig
.include <bsd.port.mk>
diff --git a/devel/mdds/distinfo b/devel/mdds/distinfo
index 77abc9e4d2ee..79ccc2391ff6 100644
--- a/devel/mdds/distinfo
+++ b/devel/mdds/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mdds_0.12.1.tar.bz2) = 23565e9d7810a6ac30478833813db847f80e927b414a7be07b7cc03ed3aae83d
-SIZE (mdds_0.12.1.tar.bz2) = 153265
+SHA256 (mdds-1.1.0.tar.bz2) = 4253ab93fe8bb579321a50e247f1f800191ab99fe2d8c6c181741b8bd3fb161f
+SIZE (mdds-1.1.0.tar.bz2) = 258691
diff --git a/devel/mdds/files/patch-include_mdds_multi__type__vector__def.inl b/devel/mdds/files/patch-include_mdds_multi__type__vector__def.inl
new file mode 100644
index 000000000000..99b17ee9e775
--- /dev/null
+++ b/devel/mdds/files/patch-include_mdds_multi__type__vector__def.inl
@@ -0,0 +1,10 @@
+--- include/mdds/multi_type_vector_def.inl.orig 2016-01-29 00:31:44 UTC
++++ include/mdds/multi_type_vector_def.inl
+@@ -1936,7 +1936,6 @@ multi_type_vector<_CellBlockFunc, _Event
+ else
+ {
+ // Just move the whole block over.
+- block* blk = m_blocks[block_index2];
+ dest.m_blocks[dest_block_pos] = blk;
+ if (blk->mp_data)
+ {
diff --git a/devel/mdds/files/patch-include_mdds_sorted__string__map__def.inl b/devel/mdds/files/patch-include_mdds_sorted__string__map__def.inl
new file mode 100644
index 000000000000..68a534b0221c
--- /dev/null
+++ b/devel/mdds/files/patch-include_mdds_sorted__string__map__def.inl
@@ -0,0 +1,11 @@
+--- include/mdds/sorted_string_map_def.inl.orig 2015-12-22 00:33:47 UTC
++++ include/mdds/sorted_string_map_def.inl
+@@ -65,7 +65,7 @@ sorted_string_map<_ValueT>::sorted_strin
+ m_entry_end(m_entries+m_entry_size)
+ {
+ #ifdef _GLIBCXX_DEBUG
+- assert(std::is_sorted(m_entries, m_entry_end, compare<_ValueT>));
++ assert(std::is_sorted(m_entries, m_entry_end, detail::compare<_ValueT>));
+ #endif
+ }
+
diff --git a/devel/mdds/pkg-plist b/devel/mdds/pkg-plist
index 3ece30ebabc4..58ab06ad2bfb 100644
--- a/devel/mdds/pkg-plist
+++ b/devel/mdds/pkg-plist
@@ -1,35 +1,28 @@
-include/mdds/compat/unique_ptr.hpp
-include/mdds/default_deleter.hpp
-include/mdds/flat_segment_tree.hpp
-include/mdds/flat_segment_tree_def.inl
-include/mdds/flat_segment_tree_itr.hpp
-include/mdds/global.hpp
-include/mdds/hash_container/map.hpp
-include/mdds/mixed_type_matrix.hpp
-include/mdds/mixed_type_matrix_def.inl
-include/mdds/mixed_type_matrix_element.hpp
-include/mdds/mixed_type_matrix_flag_storage.hpp
-include/mdds/mixed_type_matrix_storage.hpp
-include/mdds/mixed_type_matrix_storage_filled_linear.inl
-include/mdds/mixed_type_matrix_storage_sparse.inl
-include/mdds/multi_type_matrix.hpp
-include/mdds/multi_type_matrix_def.inl
-include/mdds/multi_type_vector.hpp
-include/mdds/multi_type_vector_custom_func1.hpp
-include/mdds/multi_type_vector_custom_func2.hpp
-include/mdds/multi_type_vector_custom_func3.hpp
-include/mdds/multi_type_vector_def.inl
-include/mdds/multi_type_vector_itr.hpp
-include/mdds/multi_type_vector_macro.hpp
-include/mdds/multi_type_vector_trait.hpp
-include/mdds/multi_type_vector_types.hpp
-include/mdds/node.hpp
-include/mdds/point_quad_tree.hpp
-include/mdds/quad_node.hpp
-include/mdds/rectangle_set.hpp
-include/mdds/rectangle_set_def.inl
-include/mdds/segment_tree.hpp
-include/mdds/segment_tree_def.inl
-include/mdds/sorted_string_map.hpp
-include/mdds/sorted_string_map_def.inl
-libdata/pkgconfig/mdds.pc
+include/mdds-%%API_VERSION%%/mdds/default_deleter.hpp
+include/mdds-%%API_VERSION%%/mdds/flat_segment_tree.hpp
+include/mdds-%%API_VERSION%%/mdds/flat_segment_tree_def.inl
+include/mdds-%%API_VERSION%%/mdds/flat_segment_tree_itr.hpp
+include/mdds-%%API_VERSION%%/mdds/global.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_matrix.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_matrix_def.inl
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_custom_func1.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_custom_func2.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_custom_func3.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_def.inl
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_itr.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_macro.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_trait.hpp
+include/mdds-%%API_VERSION%%/mdds/multi_type_vector_types.hpp
+include/mdds-%%API_VERSION%%/mdds/node.hpp
+include/mdds-%%API_VERSION%%/mdds/point_quad_tree.hpp
+include/mdds-%%API_VERSION%%/mdds/quad_node.hpp
+include/mdds-%%API_VERSION%%/mdds/rectangle_set.hpp
+include/mdds-%%API_VERSION%%/mdds/rectangle_set_def.inl
+include/mdds-%%API_VERSION%%/mdds/segment_tree.hpp
+include/mdds-%%API_VERSION%%/mdds/segment_tree_def.inl
+include/mdds-%%API_VERSION%%/mdds/sorted_string_map.hpp
+include/mdds-%%API_VERSION%%/mdds/sorted_string_map_def.inl
+include/mdds-%%API_VERSION%%/mdds/trie_map.hpp
+include/mdds-%%API_VERSION%%/mdds/trie_map_def.inl
+libdata/pkgconfig/mdds-%%API_VERSION%%.pc
diff --git a/devel/mdds0/Makefile b/devel/mdds0/Makefile
new file mode 100644
index 000000000000..25a91687efea
--- /dev/null
+++ b/devel/mdds0/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= mdds
+PORTVERSION= 0.12.1
+CATEGORIES= devel
+MASTER_SITES= http://kohei.us/files/mdds/src/
+PKGNAMESUFFIX= 0
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Multi-dimensional data index algorithm
+
+LICENSE= MIT
+
+USES= tar:bzip2
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-configure:
+ @${SED} -e 's|@prefix@|${PREFIX}|' \
+ -e 's|@includedir@|$${prefix}/include|' \
+ -e 's|@VERSION@|${PORTVERSION}|' \
+ ${WRKSRC}/misc/mdds.pc.in > ${WRKSRC}/misc/mdds.pc
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
+ ${INSTALL_DATA} ${WRKSRC}/misc/mdds.pc \
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+
+.include <bsd.port.mk>
diff --git a/devel/mdds0/distinfo b/devel/mdds0/distinfo
new file mode 100644
index 000000000000..77abc9e4d2ee
--- /dev/null
+++ b/devel/mdds0/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mdds_0.12.1.tar.bz2) = 23565e9d7810a6ac30478833813db847f80e927b414a7be07b7cc03ed3aae83d
+SIZE (mdds_0.12.1.tar.bz2) = 153265
diff --git a/devel/mdds/files/patch-include_mdds_flat__segment__tree.hpp b/devel/mdds0/files/patch-include_mdds_flat__segment__tree.hpp
index ad0652bfe740..ad0652bfe740 100644
--- a/devel/mdds/files/patch-include_mdds_flat__segment__tree.hpp
+++ b/devel/mdds0/files/patch-include_mdds_flat__segment__tree.hpp
diff --git a/devel/mdds/files/patch-include_mdds_flat__segment__tree__def.inl b/devel/mdds0/files/patch-include_mdds_flat__segment__tree__def.inl
index d193b6ffdd37..d193b6ffdd37 100644
--- a/devel/mdds/files/patch-include_mdds_flat__segment__tree__def.inl
+++ b/devel/mdds0/files/patch-include_mdds_flat__segment__tree__def.inl
diff --git a/devel/mdds/files/patch-include_mdds_mixed__type__matrix__def.inl b/devel/mdds0/files/patch-include_mdds_mixed__type__matrix__def.inl
index 53c88946b30f..53c88946b30f 100644
--- a/devel/mdds/files/patch-include_mdds_mixed__type__matrix__def.inl
+++ b/devel/mdds0/files/patch-include_mdds_mixed__type__matrix__def.inl
diff --git a/devel/mdds/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl b/devel/mdds0/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl
index a91f65f4a3f5..a91f65f4a3f5 100644
--- a/devel/mdds/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl
+++ b/devel/mdds0/files/patch-include_mdds_mixed__type__matrix__storage__filled__linear.inl
diff --git a/devel/mdds/files/patch-include_mdds_multi__type__vector__itr.hpp b/devel/mdds0/files/patch-include_mdds_multi__type__vector__itr.hpp
index 3bfde43204de..3bfde43204de 100644
--- a/devel/mdds/files/patch-include_mdds_multi__type__vector__itr.hpp
+++ b/devel/mdds0/files/patch-include_mdds_multi__type__vector__itr.hpp
diff --git a/devel/mdds/files/patch-include_mdds_point__quad__tree.hpp b/devel/mdds0/files/patch-include_mdds_point__quad__tree.hpp
index 87864a0755fa..87864a0755fa 100644
--- a/devel/mdds/files/patch-include_mdds_point__quad__tree.hpp
+++ b/devel/mdds0/files/patch-include_mdds_point__quad__tree.hpp
diff --git a/devel/mdds0/pkg-descr b/devel/mdds0/pkg-descr
new file mode 100644
index 000000000000..ab2be66abb43
--- /dev/null
+++ b/devel/mdds0/pkg-descr
@@ -0,0 +1,4 @@
+Multi-Dimensional Data Structure (mdds) is a collection of multi-dimensional
+data structure and indexing algorithm.
+
+WWW: https://gitlab.com/mdds/mdds
diff --git a/devel/mdds0/pkg-plist b/devel/mdds0/pkg-plist
new file mode 100644
index 000000000000..3ece30ebabc4
--- /dev/null
+++ b/devel/mdds0/pkg-plist
@@ -0,0 +1,35 @@
+include/mdds/compat/unique_ptr.hpp
+include/mdds/default_deleter.hpp
+include/mdds/flat_segment_tree.hpp
+include/mdds/flat_segment_tree_def.inl
+include/mdds/flat_segment_tree_itr.hpp
+include/mdds/global.hpp
+include/mdds/hash_container/map.hpp
+include/mdds/mixed_type_matrix.hpp
+include/mdds/mixed_type_matrix_def.inl
+include/mdds/mixed_type_matrix_element.hpp
+include/mdds/mixed_type_matrix_flag_storage.hpp
+include/mdds/mixed_type_matrix_storage.hpp
+include/mdds/mixed_type_matrix_storage_filled_linear.inl
+include/mdds/mixed_type_matrix_storage_sparse.inl
+include/mdds/multi_type_matrix.hpp
+include/mdds/multi_type_matrix_def.inl
+include/mdds/multi_type_vector.hpp
+include/mdds/multi_type_vector_custom_func1.hpp
+include/mdds/multi_type_vector_custom_func2.hpp
+include/mdds/multi_type_vector_custom_func3.hpp
+include/mdds/multi_type_vector_def.inl
+include/mdds/multi_type_vector_itr.hpp
+include/mdds/multi_type_vector_macro.hpp
+include/mdds/multi_type_vector_trait.hpp
+include/mdds/multi_type_vector_types.hpp
+include/mdds/node.hpp
+include/mdds/point_quad_tree.hpp
+include/mdds/quad_node.hpp
+include/mdds/rectangle_set.hpp
+include/mdds/rectangle_set_def.inl
+include/mdds/segment_tree.hpp
+include/mdds/segment_tree_def.inl
+include/mdds/sorted_string_map.hpp
+include/mdds/sorted_string_map_def.inl
+libdata/pkgconfig/mdds.pc
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 62f23fceab78..6dd3b4a0da3e 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
cppunit-config:devel/cppunit \
dmake:devel/dmake \
${LOCALBASE}/bin/gperf:devel/gperf \
- mdds>=0.9.0:devel/mdds \
+ ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0 \
gpatch:devel/patch \
ucpp:devel/ucpp \
${LOCALBASE}/include/sane/sane.h:graphics/sane-backends \
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index c1e2e6031630..916af3a9d2cc 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
cppunit-config:devel/cppunit \
dmake:devel/dmake \
${LOCALBASE}/bin/gperf:devel/gperf \
- mdds>=0.9.0:devel/mdds \
+ ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0 \
gpatch:devel/patch \
ucpp:devel/ucpp \
vigra-config:graphics/vigra \
diff --git a/graphics/libetonyek01/Makefile b/graphics/libetonyek01/Makefile
index 95d085dc2617..40157e05198b 100644
--- a/graphics/libetonyek01/Makefile
+++ b/graphics/libetonyek01/Makefile
@@ -14,7 +14,7 @@ COMMENT= Library to interpret and import Apple Keynote presentations
LICENSE= LGPL21 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= mdds>=0.12.1_1:devel/mdds \
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0 \
${LOCALBASE}/include/glm/glm.hpp:math/glm
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
librevenge-0.0.so:textproc/librevenge \