aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LEGAL2
-rw-r--r--audio/Makefile1
-rw-r--r--audio/optimfrog/Makefile32
-rw-r--r--audio/optimfrog/distinfo3
-rw-r--r--audio/optimfrog/pkg-descr19
5 files changed, 57 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index dba3b28f78d9..312b6530a604 100644
--- a/LEGAL
+++ b/LEGAL
@@ -453,6 +453,8 @@ onion-fec net/onion-fec Some uses of FEC
openssl-* security/openssl Crypto; export/import-controlled
opera-* www/linux-opera No redistribution, commercial
software
+optimfrog-* audio/optimfrog No commercial use, no distribution
+ of a modified package
oracle/* databases/jdbc-oracle* This software is under license
and export controls
otojiro*.txt japanese/otojiro-fpw The original dictionary is not free
diff --git a/audio/Makefile b/audio/Makefile
index 46fcd92ec092..af28de6b6d2c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -400,6 +400,7 @@
SUBDIR += openal
SUBDIR += openspc
SUBDIR += opmixer
+ SUBDIR += optimfrog
SUBDIR += orpheus
SUBDIR += osalp
SUBDIR += p5-Audio
diff --git a/audio/optimfrog/Makefile b/audio/optimfrog/Makefile
new file mode 100644
index 000000000000..69c0d40a0a4f
--- /dev/null
+++ b/audio/optimfrog/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: optimfrog
+# Date created: 22 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= optimfrog
+DISTVERSION= 4.520b1
+CATEGORIES= audio linux
+MASTER_SITES= http://bsd1.csme.ru/myports/ \
+ http://bsd2.csme.ru/myports/ \
+ http://bsd3.csme.ru/myports/
+DISTNAME= OptimFROG_All_Linux_x86_${DISTVERSION:S/.//}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Lossless audio codec
+
+ONLY_FOR_ARCHS= amd64 i386
+
+NO_CDROM= No commercial use
+NO_PACKAGE= No distribution of a modified package
+NO_BUILD= yes
+USE_LINUX= yes
+USE_ZIP= yes
+PLIST_FILES= bin/off bin/ofr bin/ofs
+
+do-install:
+ @${BRANDELF} -t Linux ${WRKSRC}/off ${WRKSRC}/ofr ${WRKSRC}/ofs
+ @${INSTALL_PROGRAM} ${WRKSRC}/off ${WRKSRC}/ofr ${WRKSRC}/ofs ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/audio/optimfrog/distinfo b/audio/optimfrog/distinfo
new file mode 100644
index 000000000000..be0663d4e8a9
--- /dev/null
+++ b/audio/optimfrog/distinfo
@@ -0,0 +1,3 @@
+MD5 (OptimFROG_All_Linux_x86_4520b1.zip) = 05a8560bd68874332f50cd1ad28f4a7e
+SHA256 (OptimFROG_All_Linux_x86_4520b1.zip) = 69d2aeb581be15278920576cc35b5398c1d22d79abf017bedc04f8aba295710d
+SIZE (OptimFROG_All_Linux_x86_4520b1.zip) = 1171509
diff --git a/audio/optimfrog/pkg-descr b/audio/optimfrog/pkg-descr
new file mode 100644
index 000000000000..d1b7663f717c
--- /dev/null
+++ b/audio/optimfrog/pkg-descr
@@ -0,0 +1,19 @@
+OptimFROG is a lossless audio compression program. Its main goal is to
+reduce at maximum the size of audio files, while permitting bit identical
+restoration for all input. It is similar with the ZIP compression, but it
+is highly specialized to compress audio data.
+
+OptimFROG obtains asymptotically the best lossless audio compression
+ratios. It has Windows, Linux, and Mac versions, fully featured input
+plug-ins for the Windows Media Player, foobar2000, Winamp2/3/5, dBpowerAMP,
+XMPlay, QCD, and XMMS audio players (with bitstream error resilience,
+ID3v1.1 and APEv2 read tagging support, ID3v2 compatible), optimal support
+for all integer PCM wave formats up to 32 bits and an extensible streamable
+(error tolerant) compressed format. It is also fast, the default mode
+encodes CD quality audio data at 12.4x real-time and decodes at 17.4x real-
+time on AMD Athlon XP 1800+ (the fastest mode encodes at 28.1x real-time
+and decodes at 24.7x real-time). Self-extracting (sfx) archives can also be
+created with a small overhead of just 54 KB.
+
+WWW: http://www.losslessaudio.org/
+Author: Florin Ghido <FlorinGhido@yahoo.com>