aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/gnats/Makefile2
-rw-r--r--databases/gnats/files/patch-gnats::misc.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/databases/gnats/Makefile b/databases/gnats/Makefile
index 87270d70cc62..0edc0d896400 100644
--- a/databases/gnats/Makefile
+++ b/databases/gnats/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnats
PORTVERSION= 3.113.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= databases elisp
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gnats
diff --git a/databases/gnats/files/patch-gnats::misc.c b/databases/gnats/files/patch-gnats::misc.c
new file mode 100644
index 000000000000..12955843b738
--- /dev/null
+++ b/databases/gnats/files/patch-gnats::misc.c
@@ -0,0 +1,11 @@
+--- gnats/misc.c.orig Sun Nov 14 17:59:15 2004
++++ gnats/misc.c Sun Nov 14 17:56:58 2004
+@@ -79,7 +79,7 @@
+ {
+ #ifdef HAVE_SYSLOG_H
+ if (log_method == SYSLOG)
+- syslog (severity, buf);
++ syslog (severity, "%s", buf);
+ else
+ #endif
+ if (gnats_logfile != (FILE *) NULL)