aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/fetchmail/Makefile6
-rw-r--r--mail/fetchmail/files/fetchmail.in2
-rw-r--r--mail/fetchmail/pkg-install2
3 files changed, 7 insertions, 3 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 6336cf297a76..2da5a6ee1fcd 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,6 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.4
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
@@ -111,10 +112,11 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/fetchmailconf.py ${PREFIX}/libexec
- ${INSTALL} -d -m 755 -o fetchmail -g fetchmail /var/run/fetchmail
+
${INSTALL} -m 644 -o fetchmail -g fetchmail ${FILESDIR}/fetchmailrc.sample ${PREFIX}/etc/fetchmailrc.sample
if [ ! -f ${PREFIX}/etc/fetchmailrc ]; then \
- ${CP} -p ${PREFIX}/etc/fetchmailrc.sample ${PREFIX}/etc/fetchmailrc ; \
+ cp -p ${PREFIX}/etc/fetchmailrc.sample ${PREFIX}/etc/fetchmailrc ; \
fi
+
.include <bsd.port.post.mk>
diff --git a/mail/fetchmail/files/fetchmail.in b/mail/fetchmail/files/fetchmail.in
index 14078f2676ee..5fc35e05fefa 100644
--- a/mail/fetchmail/files/fetchmail.in
+++ b/mail/fetchmail/files/fetchmail.in
@@ -52,7 +52,7 @@ name=fetchmail
rcvar=`set_rcvar`
command=%%PREFIX%%/bin/${name}
-pidfile=/var/run/${name}.pid
+pidfile=/var/run/fetchmail/${name}.pid
extra_commands="awaken"
awaken_cmd="fetchmail_awaken"
diff --git a/mail/fetchmail/pkg-install b/mail/fetchmail/pkg-install
index f7b4a2857948..179729e50461 100644
--- a/mail/fetchmail/pkg-install
+++ b/mail/fetchmail/pkg-install
@@ -42,3 +42,5 @@ if [ x"$2" = xPRE-INSTALL ]; then
fi
fi
fi
+
+/usr/bin/install -d -m 755 -o fetchmail -g fetchmail /var/run/fetchmail