aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/morla/Makefile4
-rw-r--r--german/bsdgroup-firefox-searchplugin/Makefile4
-rw-r--r--java/eclipse-devel/Makefile4
-rw-r--r--multimedia/gxine/Makefile4
-rw-r--r--multimedia/vlc/Makefile4
-rw-r--r--www/ruby-gtkmozembed/Makefile4
6 files changed, 12 insertions, 12 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index 4b01203f3fb2..8b4511f21b76 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -7,7 +7,7 @@
PORTNAME= morla
PORTVERSION= 0.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors textproc
MASTER_SITES= http://www.morlardf.net/src/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
@@ -46,7 +46,7 @@ post-patch:
.include <bsd.port.pre.mk>
.if defined(WITH_XULRUNNER)
-USE_GECKO= xulrunner
+USE_GECKO= libxul
CONFIGURE_ARGS+= --with-javascript=xulrunner
.else
CONFIGURE_ARGS+= --with-javascript=none
diff --git a/german/bsdgroup-firefox-searchplugin/Makefile b/german/bsdgroup-firefox-searchplugin/Makefile
index fca60b3fadd9..4ce93e352df0 100644
--- a/german/bsdgroup-firefox-searchplugin/Makefile
+++ b/german/bsdgroup-firefox-searchplugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bsdgroup-firefox-searchplugin
PORTVERSION= 0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= german www
MASTER_SITES= http://www.crashmail.de/files/ \
http://people.bsdgroup.de/~steve/files/
@@ -18,7 +18,7 @@ MAINTAINER= stefan.tell@crashmail.de
COMMENT= Firefox searchplugins for the www.BSDGroup.de board
NO_BUILD= yes
-USE_GECKO= firefox
+USE_GECKO= libxul
do-extract:
@${MKDIR} ${WRKSRC}
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index abdcdbee3055..cefd6788ea45 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse-devel
PORTVERSION= 3.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${PORTVERSION}-200809111700
@@ -32,7 +32,7 @@ USE_GL= glu
PATCH= ${LOCALBASE}/bin/gpatch
.if !defined(WITHOUT_MOZILLA)
-USE_GECKO= firefox xulrunner seamonkey
+USE_GECKO= libxul seamonkey
.endif
USE_JAVA= yes
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index bb301d90ea72..d978edac069e 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gxine
PORTVERSION= 0.5.904
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= SF/xine/${PORTNAME}%20%28GTK%20front%20end%29/${PORTVERSION}
@@ -73,7 +73,7 @@ LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
CONFIGURE_ARGS+=--without-browser-plugin --with-spidermonkey
PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.else
-USE_GECKO= firefox mozilla seamonkey xulrunner
+USE_GECKO= seamonkey
USE_WEBPLUGINS= native
WEBPLUGINS_DIR= ${PREFIX}/lib/gxine
WEBPLUGINS_FILES=gxineplugin.so
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 7bc73dbf3b68..93e0a10fca50 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -10,7 +10,7 @@
PORTNAME= vlc
DISTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -414,7 +414,7 @@ CONFIGURE_ARGS+=--disable-a52
.endif
.if defined(WITH_VLC_MOZILLA_PLUGIN) && !defined(WITHOUT_VLC_MOZILLA_PLUGIN)
-USE_GECKO= firefox xulrunner seamonkey
+USE_GECKO= libxul seamonkey
USE_WEBPLUGINS= gecko*
WEBPLUGINS_FILES=libvlcplugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
diff --git a/www/ruby-gtkmozembed/Makefile b/www/ruby-gtkmozembed/Makefile
index eb7bb229a535..1e53d3a5517c 100644
--- a/www/ruby-gtkmozembed/Makefile
+++ b/www/ruby-gtkmozembed/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtkmozembed
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ruby
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
@@ -22,7 +22,7 @@ COMMENT= Ruby binding for GtkMozEmbed a widget embedding a Gecko renderer
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
USE_RUBY= yes
-USE_GECKO= firefox mozilla xulrunner
+USE_GECKO= seamonkey
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"