aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/p5-XML-Xerces/Makefile5
-rw-r--r--textproc/p5-XML-Xerces/files/patch-Makefile.PL25
2 files changed, 29 insertions, 1 deletions
diff --git a/textproc/p5-XML-Xerces/Makefile b/textproc/p5-XML-Xerces/Makefile
index 8548a574ba55..f81d9d65a8ab 100644
--- a/textproc/p5-XML-Xerces/Makefile
+++ b/textproc/p5-XML-Xerces/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML-Xerces
PORTVERSION= 2.7.0
+PORTREVISION?= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,11 +18,13 @@ COMMENT= The Perl API to the Apache project's Xerces XML parser
LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
-BROKEN= does not compile
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
USE_GMAKE= YES
PERL_CONFIGURE= YES
CONFIGURE_ENV+= XERCES_LIB="${LOCALBASE}/lib" \
XERCES_INCLUDE="${LOCALBASE}/include" \
+ XERCES_DEVEL="YES" \
+ CXX="g++" \
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Xerces/files/patch-Makefile.PL b/textproc/p5-XML-Xerces/files/patch-Makefile.PL
new file mode 100644
index 000000000000..25d537093d8f
--- /dev/null
+++ b/textproc/p5-XML-Xerces/files/patch-Makefile.PL
@@ -0,0 +1,25 @@
+--- Makefile.PL.orig 2006-03-10 06:50:23.000000000 -0500
++++ Makefile.PL 2009-03-17 14:46:12.000000000 -0500
+@@ -290,16 +290,16 @@
+ my $CC_DEF;
+ if ($^O eq 'linux') {
+ $OS_DEF = '-DXML_LINUX';
+- } elsif($^O eq 'darwin') {
+- $OS_DEF = '-DXML_MACOSX';
++ } elsif($^O eq 'freebsd') {
++ $OS_DEF = '-DXML_FREEBSD';
+ } else {
+ die 'unsupported operating system';
+ }
+- if ($CXX =~ /g\+\+/) {
++ #if ($CXX =~ /g\+\+/) {
+ $CC_DEF = '-DXML_GCC';
+- } else {
+- die 'unsupported compiler';
+- }
++ #} else {
++ #die 'unsupported compiler';
++ #}
+ my $SWIG_ARGS = qq[-Wall $OS_DEF $CC_DEF -DXERCES_OLD -DXERCES_VERSION="$XERCES_PERL_VERSION" \$(INC) -perl5 -c++ -shadow];
+
+ my $MAKE = ' \$(MAKE) -C Handler static';