aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/sqlite/Makefile3
-rw-r--r--databases/sqlite/distinfo2
-rw-r--r--databases/sqlite/files/Makefile.bsd7
-rw-r--r--databases/sqlite/files/patch-test6
-rw-r--r--databases/sqlite2/Makefile3
-rw-r--r--databases/sqlite2/distinfo2
-rw-r--r--databases/sqlite2/files/Makefile.bsd7
-rw-r--r--databases/sqlite2/files/patch-test6
8 files changed, 24 insertions, 12 deletions
diff --git a/databases/sqlite/Makefile b/databases/sqlite/Makefile
index 58fbbf04c943..f33929278187 100644
--- a/databases/sqlite/Makefile
+++ b/databases/sqlite/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sqlite
-PORTVERSION= 1.0.30
-PORTREVISION= 1
+PORTVERSION= 1.0.32
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
DISTNAME= ${PORTNAME}
diff --git a/databases/sqlite/distinfo b/databases/sqlite/distinfo
index 61af13e284fe..5e5c8be201b1 100644
--- a/databases/sqlite/distinfo
+++ b/databases/sqlite/distinfo
@@ -1 +1 @@
-MD5 (sqlite.tar.gz) = bbadbd14ccca04f55f5202ee2fe3411b
+MD5 (sqlite.tar.gz) = c6dd5c8894c1c4515e08a6545c2533d8
diff --git a/databases/sqlite/files/Makefile.bsd b/databases/sqlite/files/Makefile.bsd
index a7b9955d3ca3..1e04897443de 100644
--- a/databases/sqlite/files/Makefile.bsd
+++ b/databases/sqlite/files/Makefile.bsd
@@ -10,9 +10,10 @@ LDADD += -lreadline -L${PREFIX}/lib -ltcl${TCL_DVER} -lm -lgdbm
.PATH: ${.CURDIR}/src
-SRCS = build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c insert.c \
- main.c parse.y printf.c random.c select.c table.c tokenize.c \
- update.c util.c vdbe.c where.c tclsqlite.c
+SRCS = btree.c build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c \
+ insert.c main.c pager.c parse.y printf.c random.c select.c \
+ shell.c table.c tokenize.c update.c util.c vdbe.c where.c \
+ tclsqlite.c
INCS = sqlite.h
diff --git a/databases/sqlite/files/patch-test b/databases/sqlite/files/patch-test
index e2a38cc43568..3adee03362f9 100644
--- a/databases/sqlite/files/patch-test
+++ b/databases/sqlite/files/patch-test
@@ -4,3 +4,9 @@
set testdir [file dirname $argv0]
+load [lindex $argv 0]
source $testdir/tester.tcl
+--- test/tableapi.test.orig Wed Apr 11 23:28:43 2001
++++ test/tableapi.test Mon Sep 3 21:24:06 2001
+@@ -30,2 +30,3 @@
+ source $testdir/tester.tcl
++set ::big_str ""
+
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 58fbbf04c943..f33929278187 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sqlite
-PORTVERSION= 1.0.30
-PORTREVISION= 1
+PORTVERSION= 1.0.32
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
DISTNAME= ${PORTNAME}
diff --git a/databases/sqlite2/distinfo b/databases/sqlite2/distinfo
index 61af13e284fe..5e5c8be201b1 100644
--- a/databases/sqlite2/distinfo
+++ b/databases/sqlite2/distinfo
@@ -1 +1 @@
-MD5 (sqlite.tar.gz) = bbadbd14ccca04f55f5202ee2fe3411b
+MD5 (sqlite.tar.gz) = c6dd5c8894c1c4515e08a6545c2533d8
diff --git a/databases/sqlite2/files/Makefile.bsd b/databases/sqlite2/files/Makefile.bsd
index a7b9955d3ca3..1e04897443de 100644
--- a/databases/sqlite2/files/Makefile.bsd
+++ b/databases/sqlite2/files/Makefile.bsd
@@ -10,9 +10,10 @@ LDADD += -lreadline -L${PREFIX}/lib -ltcl${TCL_DVER} -lm -lgdbm
.PATH: ${.CURDIR}/src
-SRCS = build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c insert.c \
- main.c parse.y printf.c random.c select.c table.c tokenize.c \
- update.c util.c vdbe.c where.c tclsqlite.c
+SRCS = btree.c build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c \
+ insert.c main.c pager.c parse.y printf.c random.c select.c \
+ shell.c table.c tokenize.c update.c util.c vdbe.c where.c \
+ tclsqlite.c
INCS = sqlite.h
diff --git a/databases/sqlite2/files/patch-test b/databases/sqlite2/files/patch-test
index e2a38cc43568..3adee03362f9 100644
--- a/databases/sqlite2/files/patch-test
+++ b/databases/sqlite2/files/patch-test
@@ -4,3 +4,9 @@
set testdir [file dirname $argv0]
+load [lindex $argv 0]
source $testdir/tester.tcl
+--- test/tableapi.test.orig Wed Apr 11 23:28:43 2001
++++ test/tableapi.test Mon Sep 3 21:24:06 2001
+@@ -30,2 +30,3 @@
+ source $testdir/tester.tcl
++set ::big_str ""
+