aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/ruby-serialport/Makefile3
-rw-r--r--databases/ruby-search-namazu/Makefile3
-rw-r--r--databases/ruby-sqlite/Makefile3
-rw-r--r--databases/rubygem-kirbybase/Makefile3
-rw-r--r--devel/ruby-eet/Makefile3
-rw-r--r--devel/ruby-filelock/Makefile3
-rw-r--r--devel/ruby-filemagic/Makefile3
-rw-r--r--devel/ruby-metaruby/Makefile3
-rw-r--r--devel/ruby-poll/Makefile3
-rw-r--r--devel/ruby-rrb/Makefile3
-rw-r--r--devel/ruby-strongtyping/Makefile3
-rw-r--r--devel/ruby-textbuf/Makefile3
-rw-r--r--graphics/ruby-graph/Makefile3
-rw-r--r--graphics/ruby-libpng/Makefile3
-rw-r--r--japanese/ruby-kakasi/Makefile3
-rw-r--r--lang/ruby-extensions/Makefile3
-rw-r--r--lang/ruby-lua/Makefile3
-rw-r--r--lang/ruby-perl/Makefile3
-rw-r--r--mail/ruby-tmail/Makefile3
-rw-r--r--math/ruby-bitset/Makefile3
-rw-r--r--math/ruby-bitvector/Makefile3
-rw-r--r--math/ruby-gmp/Makefile3
-rw-r--r--net/ruby-mpi/Makefile3
-rw-r--r--net/ruby-nis/Makefile3
-rw-r--r--net/ruby-pcap/Makefile3
-rw-r--r--net/ruby-romp/Makefile3
-rw-r--r--net/ruby-spread/Makefile3
-rw-r--r--print/ruby-pdflib/Makefile3
-rw-r--r--security/ruby-aes/Makefile3
-rw-r--r--security/ruby-blowfish/Makefile3
-rw-r--r--security/ruby-cast_256/Makefile3
-rw-r--r--security/ruby-mcrypt/Makefile3
-rw-r--r--security/ruby-pam/Makefile3
-rw-r--r--sysutils/ruby-log4r/Makefile3
-rw-r--r--textproc/ruby-csv/Makefile3
-rw-r--r--textproc/ruby-formvalidator/Makefile3
-rw-r--r--textproc/ruby-gdome/Makefile3
-rw-r--r--textproc/ruby-htmltools/Makefile3
-rw-r--r--textproc/ruby-nqxml/Makefile3
-rw-r--r--textproc/ruby-quixml/Makefile3
-rw-r--r--textproc/ruby-raspell/Makefile3
-rw-r--r--textproc/ruby-tempura/Makefile3
-rw-r--r--textproc/ruby-xtemplate/Makefile3
-rw-r--r--www/ruby-tmpl/Makefile3
44 files changed, 132 insertions, 0 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
index e1d186590dab..fabc367ea99c 100644
--- a/comms/ruby-serialport/Makefile
+++ b/comms/ruby-serialport/Makefile
@@ -18,6 +18,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby library to communicate via the RS232 port
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
RUBY_EXTCONF= ext/extconf.rb
diff --git a/databases/ruby-search-namazu/Makefile b/databases/ruby-search-namazu/Makefile
index 34707f5f70f3..221fa2b2c118 100644
--- a/databases/ruby-search-namazu/Makefile
+++ b/databases/ruby-search-namazu/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby library which wraps libnmz of Namazu
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= nmz.8:${PORTSDIR}/japanese/namazu2
USE_RUBY= yes
diff --git a/databases/ruby-sqlite/Makefile b/databases/ruby-sqlite/Makefile
index ec9e229c715e..ce44d540c71e 100644
--- a/databases/ruby-sqlite/Makefile
+++ b/databases/ruby-sqlite/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to the SQLite DB engine version 2
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
USE_BZIP2= yes
diff --git a/databases/rubygem-kirbybase/Makefile b/databases/rubygem-kirbybase/Makefile
index 9486bd75ac8e..426bd5cfeca7 100644
--- a/databases/rubygem-kirbybase/Makefile
+++ b/databases/rubygem-kirbybase/Makefile
@@ -13,6 +13,9 @@ DISTNAME= KirbyBase-${PORTVERSION}
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Small and Plain-text DBMS Written in Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
diff --git a/devel/ruby-eet/Makefile b/devel/ruby-eet/Makefile
index 894bbfcbf750..8a2ecc926a5b 100644
--- a/devel/ruby-eet/Makefile
+++ b/devel/ruby-eet/Makefile
@@ -15,6 +15,9 @@ DISTNAME= ruby-eet-${PORTVERSION}
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby support for reading and writing EET files
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= eet.5:${PORTSDIR}/devel/eet
USE_RUBY= yes
diff --git a/devel/ruby-filelock/Makefile b/devel/ruby-filelock/Makefile
index e2121e336382..95893ba9a468 100644
--- a/devel/ruby-filelock/Makefile
+++ b/devel/ruby-filelock/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby module which provides file locking mechanism
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/devel/ruby-filemagic/Makefile b/devel/ruby-filemagic/Makefile
index d711abb4d6a7..5cb8c50e0434 100644
--- a/devel/ruby-filemagic/Makefile
+++ b/devel/ruby-filemagic/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby binding to libmagic(3)
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= magic.1:${PORTSDIR}/sysutils/file
USE_RUBY= yes
diff --git a/devel/ruby-metaruby/Makefile b/devel/ruby-metaruby/Makefile
index fa3b7b6df19b..5ef027003b6a 100644
--- a/devel/ruby-metaruby/Makefile
+++ b/devel/ruby-metaruby/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A reimplementations of some Ruby parts in Ruby, Perl's tie equivalent
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/devel/ruby-poll/Makefile b/devel/ruby-poll/Makefile
index c1dd68f4b0f0..c1e227009d87 100644
--- a/devel/ruby-poll/Makefile
+++ b/devel/ruby-poll/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= An object-oriented interface to the poll(2) system call for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_BZIP2= yes
USE_RUBY= yes
diff --git a/devel/ruby-rrb/Makefile b/devel/ruby-rrb/Makefile
index ba2e879de949..a01eb2c1d978 100644
--- a/devel/ruby-rrb/Makefile
+++ b/devel/ruby-rrb/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby Refactoring Browser for FreeRIDE and EMACS
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/devel/ruby-strongtyping/Makefile b/devel/ruby-strongtyping/Makefile
index 7fb411a99164..1969eac4aa06 100644
--- a/devel/ruby-strongtyping/Makefile
+++ b/devel/ruby-strongtyping/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A little Ruby module that adds strong typing facilities
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/devel/ruby-textbuf/Makefile b/devel/ruby-textbuf/Makefile
index 824c5ce9a8c1..210121cd1258 100644
--- a/devel/ruby-textbuf/Makefile
+++ b/devel/ruby-textbuf/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Gapped text buffer extention for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_AMSTD= yes
USE_RUBY_SETUP= yes
diff --git a/graphics/ruby-graph/Makefile b/graphics/ruby-graph/Makefile
index c06972ffa270..faee099be800 100644
--- a/graphics/ruby-graph/Makefile
+++ b/graphics/ruby-graph/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Graph-related Ruby classes
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
RUN_DEPENDS= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz
USE_RUBY= yes
diff --git a/graphics/ruby-libpng/Makefile b/graphics/ruby-libpng/Makefile
index 67dbf7845bdc..db8682f5a353 100644
--- a/graphics/ruby-libpng/Makefile
+++ b/graphics/ruby-libpng/Makefile
@@ -18,6 +18,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A libpng wrapper class for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
USE_RUBY= yes
diff --git a/japanese/ruby-kakasi/Makefile b/japanese/ruby-kakasi/Makefile
index 36641d14c1b6..7be00f0d14d0 100644
--- a/japanese/ruby-kakasi/Makefile
+++ b/japanese/ruby-kakasi/Makefile
@@ -14,6 +14,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= KAKASI module for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= kakasi.3:${PORTSDIR}/japanese/kakasi
USE_RUBY= yes
diff --git a/lang/ruby-extensions/Makefile b/lang/ruby-extensions/Makefile
index 585ea4e9260c..8977a814e698 100644
--- a/lang/ruby-extensions/Makefile
+++ b/lang/ruby-extensions/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Useful extensions for Ruby's standard classes
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
RUBY_SETUP= install.rb
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/lang/ruby-lua/Makefile b/lang/ruby-lua/Makefile
index 3c61a0301a4f..43687de8d303 100644
--- a/lang/ruby-lua/Makefile
+++ b/lang/ruby-lua/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension to make Lua script language as a class
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_LUA= 5.0
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
index 0e2335b89597..d26c217a9c96 100644
--- a/lang/ruby-perl/Makefile
+++ b/lang/ruby-perl/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension module to use the functions of Perl from Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_PERL5= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/mail/ruby-tmail/Makefile b/mail/ruby-tmail/Makefile
index 452e806241e0..a151c5a537a9 100644
--- a/mail/ruby-tmail/Makefile
+++ b/mail/ruby-tmail/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A RFC2822/MIME compliant mail manipulating library for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_SETUP= yes
USE_RUBY_FEATURES= racc-runtime
diff --git a/math/ruby-bitset/Makefile b/math/ruby-bitset/Makefile
index 2bdbda5a32df..c8f7582a8e39 100644
--- a/math/ruby-bitset/Makefile
+++ b/math/ruby-bitset/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A bit set library for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/math/ruby-bitvector/Makefile b/math/ruby-bitvector/Makefile
index 4e40c2671a7f..1bafdbf08347 100644
--- a/math/ruby-bitvector/Makefile
+++ b/math/ruby-bitvector/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Efficient Ruby bit vector extension
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/math/ruby-gmp/Makefile b/math/ruby-gmp/Makefile
index bebedef858b4..610994aa2c0e 100644
--- a/math/ruby-gmp/Makefile
+++ b/math/ruby-gmp/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby bindings to GNU Multiprecision Library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_RUBY= yes
diff --git a/net/ruby-mpi/Makefile b/net/ruby-mpi/Makefile
index bef57a49a758..4e75fef5551f 100644
--- a/net/ruby-mpi/Makefile
+++ b/net/ruby-mpi/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby binding of MPI (Message Passing Interface)
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
RUN_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
diff --git a/net/ruby-nis/Makefile b/net/ruby-nis/Makefile
index 0c2a4171389f..a0e7b662ee2e 100644
--- a/net/ruby-nis/Makefile
+++ b/net/ruby-nis/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby library to use the NIS/YP API
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/net/ruby-pcap/Makefile b/net/ruby-pcap/Makefile
index c10b9cc08477..89bbce17b9a8 100644
--- a/net/ruby-pcap/Makefile
+++ b/net/ruby-pcap/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to LBL Packet Capture library (libpcap)
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/net/ruby-romp/Makefile b/net/ruby-romp/Makefile
index 0701be5dfc45..5ed0d2e6ab39 100644
--- a/net/ruby-romp/Makefile
+++ b/net/ruby-romp/Makefile
@@ -17,6 +17,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ruby@FreeBSD.org
COMMENT= The Ruby Object Message Proxy
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
IGNOREFILES= romp.html
USE_RUBY= yes
diff --git a/net/ruby-spread/Makefile b/net/ruby-spread/Makefile
index 3f021a480861..c150d861ca3c 100644
--- a/net/ruby-spread/Makefile
+++ b/net/ruby-spread/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to the Spread library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= tspread.1:${PORTSDIR}/net/spread
USE_RUBY= yes
diff --git a/print/ruby-pdflib/Makefile b/print/ruby-pdflib/Makefile
index 668517ee1524..4274a853fef8 100644
--- a/print/ruby-pdflib/Makefile
+++ b/print/ruby-pdflib/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension library to access PDFlib
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
diff --git a/security/ruby-aes/Makefile b/security/ruby-aes/Makefile
index 8cd6ca20c38a..a9477e359f61 100644
--- a/security/ruby-aes/Makefile
+++ b/security/ruby-aes/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension library which implements AES (Rijndael) encryption
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-blowfish/Makefile b/security/ruby-blowfish/Makefile
index 8541bd96e7a2..1146b47dadc2 100644
--- a/security/ruby-blowfish/Makefile
+++ b/security/ruby-blowfish/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to the Blowfish cipher
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_OPENSSL= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-cast_256/Makefile b/security/ruby-cast_256/Makefile
index 4a243f2a2009..02718ec232d5 100644
--- a/security/ruby-cast_256/Makefile
+++ b/security/ruby-cast_256/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension library which implements CAST-256 encryption
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_ZIP= yes
USE_RUBY= yes
diff --git a/security/ruby-mcrypt/Makefile b/security/ruby-mcrypt/Makefile
index 1268d24881ce..f046eeda807f 100644
--- a/security/ruby-mcrypt/Makefile
+++ b/security/ruby-mcrypt/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to the mcrypt library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt/
USE_RUBY= yes
diff --git a/security/ruby-pam/Makefile b/security/ruby-pam/Makefile
index 9febd4f4146d..653f5047a685 100644
--- a/security/ruby-pam/Makefile
+++ b/security/ruby-pam/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby extension to use PAM library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/sysutils/ruby-log4r/Makefile b/sysutils/ruby-log4r/Makefile
index 4b89ff4cf986..c32f89051178 100644
--- a/sysutils/ruby-log4r/Makefile
+++ b/sysutils/ruby-log4r/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A flexible logging library written in Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
NO_BUILD= yes
diff --git a/textproc/ruby-csv/Makefile b/textproc/ruby-csv/Makefile
index 5f52d56488c9..7977231b1bec 100644
--- a/textproc/ruby-csv/Makefile
+++ b/textproc/ruby-csv/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby library to parse or generate data in CSV format
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
NO_BUILD= yes
diff --git a/textproc/ruby-formvalidator/Makefile b/textproc/ruby-formvalidator/Makefile
index 15d7362ca0d1..cf9a11d93da2 100644
--- a/textproc/ruby-formvalidator/Makefile
+++ b/textproc/ruby-formvalidator/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby module to validate data coming in from HTML forms
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_RDOC= yes
diff --git a/textproc/ruby-gdome/Makefile b/textproc/ruby-gdome/Makefile
index f72e5a334836..2a158e61abf5 100644
--- a/textproc/ruby-gdome/Makefile
+++ b/textproc/ruby-gdome/Makefile
@@ -18,6 +18,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension that wraps around gdome2
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= gdome.8:${PORTSDIR}/textproc/gdome2
USE_BZIP2= yes
diff --git a/textproc/ruby-htmltools/Makefile b/textproc/ruby-htmltools/Makefile
index 60131c742155..0037cfe47d2d 100644
--- a/textproc/ruby-htmltools/Makefile
+++ b/textproc/ruby-htmltools/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Tools for parsing and manipulating HTML text in Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_DOS2UNIX= tc_stacking-parser.rb
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/textproc/ruby-nqxml/Makefile b/textproc/ruby-nqxml/Makefile
index 23120eae2f1a..c39d9f24872f 100644
--- a/textproc/ruby-nqxml/Makefile
+++ b/textproc/ruby-nqxml/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A pure Ruby implementasion of a non-validating XML processor
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
NO_BUILD= yes
diff --git a/textproc/ruby-quixml/Makefile b/textproc/ruby-quixml/Makefile
index 60c4b3317d1d..87926db4fef1 100644
--- a/textproc/ruby-quixml/Makefile
+++ b/textproc/ruby-quixml/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Fast XML API for Ruby written in C
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_RUBY= yes
diff --git a/textproc/ruby-raspell/Makefile b/textproc/ruby-raspell/Makefile
index a3c1f670f9bb..501a4fbadcc5 100644
--- a/textproc/ruby-raspell/Makefile
+++ b/textproc/ruby-raspell/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface binding to aspell
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= aspell.16:${PORTSDIR}/textproc/aspell
USE_RUBY= yes
diff --git a/textproc/ruby-tempura/Makefile b/textproc/ruby-tempura/Makefile
index d770f0423c35..00960f645cae 100644
--- a/textproc/ruby-tempura/Makefile
+++ b/textproc/ruby-tempura/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= TEMPlate Utility for Ruby Application
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
RUBY_FEATURES= rexml
diff --git a/textproc/ruby-xtemplate/Makefile b/textproc/ruby-xtemplate/Makefile
index f7aba3de729b..edcbd23e2dd0 100644
--- a/textproc/ruby-xtemplate/Makefile
+++ b/textproc/ruby-xtemplate/Makefile
@@ -15,6 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A lightweight XML template engine for Ruby
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
RUN_DEPENDS= ${RUBY_SITELIBDIR}/xmlscan/parser.rb:${PORTSDIR}/textproc/ruby-xmlscan
USE_RUBY= yes
diff --git a/www/ruby-tmpl/Makefile b/www/ruby-tmpl/Makefile
index 7108748b291a..ba078b9f02de 100644
--- a/www/ruby-tmpl/Makefile
+++ b/www/ruby-tmpl/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= An online/offline templating system a la eRuby/ERb
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
NO_BUILD= yes