aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/spidermonkey/Makefile30
-rw-r--r--lang/spidermonkey/distinfo1
-rw-r--r--lang/spidermonkey/pkg-descr6
-rw-r--r--lang/spidermonkey/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 1b8b84561ae5..0f759c3cd6b7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -208,6 +208,7 @@
SUBDIR += sml-nj
SUBDIR += sml-nj-devel
SUBDIR += snobol
+ SUBDIR += spidermonkey
SUBDIR += spl
SUBDIR += squeak2
SUBDIR += squeak3
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
new file mode 100644
index 000000000000..f7336959307a
--- /dev/null
+++ b/lang/spidermonkey/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: spidermonkey
+# Date created: Fri Apr 18, 2003
+# Whom: Dan Rench (drench@xnet.com)
+#
+# $FreeBSD$
+
+PORTNAME= js
+PORTVERSION= 1.5.p5
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= js
+DISTNAME= js-1.5-rc5
+
+MAINTAINER= drench@xnet.com
+COMMENT= A standalone JavaScript interpreter from the Mozilla project
+
+USE_GMAKE= YES
+
+post-extract:
+ ${MV} ${WRKDIR}/js/src ${WRKSRC} && \
+ ${RM} -rf js && \
+ ${CP} ${WRKSRC}/config/Linux_All.mk \
+ ${WRKSRC}/config/`uname -s``uname -r`.mk && \
+ ${CP} ${WRKSRC}/Makefile.ref ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/`uname -s``uname -r`_DBG.OBJ/js \
+ ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/lang/spidermonkey/distinfo b/lang/spidermonkey/distinfo
new file mode 100644
index 000000000000..b2eb91ebd208
--- /dev/null
+++ b/lang/spidermonkey/distinfo
@@ -0,0 +1 @@
+MD5 (js-1.5-rc5.tar.gz) = 3c720a8af00ff5590e623c00a683c53b
diff --git a/lang/spidermonkey/pkg-descr b/lang/spidermonkey/pkg-descr
new file mode 100644
index 000000000000..25b64883d7ac
--- /dev/null
+++ b/lang/spidermonkey/pkg-descr
@@ -0,0 +1,6 @@
+Spidermonkey is the JavaScript interpreter from the Mozilla project.
+
+WWW: http://www.mozilla.org/js/spidermonkey/
+
+- Dan Rench
+drench@xnet.com
diff --git a/lang/spidermonkey/pkg-plist b/lang/spidermonkey/pkg-plist
new file mode 100644
index 000000000000..41d2c80ae0b3
--- /dev/null
+++ b/lang/spidermonkey/pkg-plist
@@ -0,0 +1 @@
+bin/js