aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/apsfilter/Makefile11
-rw-r--r--russian/prawda/Makefile8
-rw-r--r--security/bdc/Makefile4
-rw-r--r--security/cyrus-sasl/Makefile4
-rw-r--r--security/ipfilter2dshield/Makefile8
-rw-r--r--security/lsh/Makefile8
-rw-r--r--security/openbsm/Makefile7
-rw-r--r--security/ppars/Makefile8
8 files changed, 7 insertions, 51 deletions
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 7b0005ca7e83..c760152ff52e 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -139,17 +139,6 @@ post-clean:
.endif
post-install:
-.if defined(OSVERSION) && ${OSVERSION} < 400012
- @${ECHO} "********************************************************"
- @${ECHO} "* Please Note: *"
- @${ECHO} "********************************************************"
- @${ECHO} "You have FreeBSD version <= 4.0. If you want to print "
- @${ECHO} "troff files then you have to install the grog utility "
- @${ECHO} "from groff sources: "
- @${ECHO} " cp /usr/src/contrib/groff/grog/grog.sh /usr/bin/grog"
- @${ECHO} " chmod 555 /usr/bin/grog "
- @${ECHO} "--------------------------------------------------------"
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/russian/prawda/Makefile b/russian/prawda/Makefile
index ed72acc15f9f..450acf0f8ea6 100644
--- a/russian/prawda/Makefile
+++ b/russian/prawda/Makefile
@@ -19,12 +19,6 @@ NO_WRKSUBDIR= yes
USE_X_PREFIX= yes
CXXFLAGS+= -I${X11BASE}/include -L${X11BASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|ulong|unsigned long|g;;s|malloc.h|stdlib.h|g" ${WRKSRC}/src/face/video_x.cpp
@${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g" ${WRKSRC}/src/bin/makefile.exe
@@ -36,4 +30,4 @@ do-build:
do-install:
@cd ${WRKSRC}/bin && ${MAKE} install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index a175943d2f6f..6e791058e73b 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -19,10 +19,8 @@ COMMENT= BitDefender Console Antivirus for FreeBSD
.if ${OSVERSION} >= 600000
LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
.endif
-.if ${OSVERSION} < 490000 || ${OSVERSION} >= 500000 && ${OSVERSION} < 502001
+.if ${OSVERSION} >= 500000 && ${OSVERSION} < 502001
IGNORE= requires FreeBSD-STABLE \(4.9 or later\), or FreeBSD-CURRENT \(5.2.1 or later\)
-.elif ${OSVERSION} < 500000
-BDREL= 4
.else
BDREL= 5
.endif
diff --git a/security/cyrus-sasl/Makefile b/security/cyrus-sasl/Makefile
index 25f71f1de955..4538114fdf51 100644
--- a/security/cyrus-sasl/Makefile
+++ b/security/cyrus-sasl/Makefile
@@ -171,11 +171,7 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PKGINSTALL= ${WRKDIR}/pkg-install
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if ${OSVERSION} < 450000
-FMT= /usr/bin/fmt
-.else
FMT= /usr/bin/fmt -w 67
-.endif
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.sasl
diff --git a/security/ipfilter2dshield/Makefile b/security/ipfilter2dshield/Makefile
index cbb8b4f20103..2d9bfa61a833 100644
--- a/security/ipfilter2dshield/Makefile
+++ b/security/ipfilter2dshield/Makefile
@@ -22,11 +22,7 @@ USE_PERL5= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 490000
-IGNORE= "Not supported on releases prior to 4.9"
-.endif
+.include <bsd.port.mk>
do-extract:
[ -d ${WRKDIR} ] || ${MKDIR} ${WRKDIR}
@@ -52,4 +48,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index d85a2bd7b8d8..50ab29e9d2e2 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -45,12 +45,6 @@ MAN5= secsh.5 SPKI.5 SHA.5 DSA.5
MAN8= sftp-server.8 lshd.8
INFO= lsh nettle
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400014
-CONFIGURE_ARGS+= --without-ipv6
-.endif
-
post-install:
.for BIN in lsh lsh-keygen lsh-writekey sexp-conv srp-gen lsh-decode-key
${STRIP_CMD} ${PREFIX}/bin/${BIN}
@@ -63,4 +57,4 @@ test:
(cd ${WRKSRC}/src/testsuite && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openbsm/Makefile b/security/openbsm/Makefile
index 1f84e3a4d6d4..d1d46bfd8f37 100644
--- a/security/openbsm/Makefile
+++ b/security/openbsm/Makefile
@@ -46,16 +46,11 @@ MAN8= auditfilterd.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.X
-.else
.if ${OSVERSION} < 600000
BROKEN= does not package on 5.X
.endif
-.endif
-.if ( ( ${OSVERSION} < 500000 && ${OSVERSION} > 491101 ) || \
- ( ${OSVERSION} < 600000 && ${OSVERSION} > 503100 ) || \
+.if ( ( ${OSVERSION} < 600000 && ${OSVERSION} > 503100 ) || \
${OSVERSION} >= 600000 )
MAN8+= audit.8 \
auditd.8
diff --git a/security/ppars/Makefile b/security/ppars/Makefile
index 893cca121dfc..a3505d597177 100644
--- a/security/ppars/Makefile
+++ b/security/ppars/Makefile
@@ -22,15 +22,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 490000
-IGNORE= "Not supported on releases prior to 4.9"
-.endif
-
do-install:
@${MKDIR} ${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/sbin
${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>