aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/musicbox/Makefile9
-rw-r--r--games/pp/Makefile1
-rw-r--r--math/xgfe/Makefile1
-rw-r--r--misc/peq/Makefile1
-rw-r--r--net/icqnix/Makefile8
-rw-r--r--x11-toolkits/qt145/Makefile5
6 files changed, 19 insertions, 6 deletions
diff --git a/audio/musicbox/Makefile b/audio/musicbox/Makefile
index d3523eb8d527..8afbd3107743 100644
--- a/audio/musicbox/Makefile
+++ b/audio/musicbox/Makefile
@@ -18,6 +18,7 @@ COMMENT= X11 front-end for mpg123
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+USE_GCC= 2.95
USE_QT_VER= 1
DOCS= ChangeLog README
EVAL_PREFIX+= QT1DIR=qt1
@@ -26,6 +27,12 @@ PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/musicbox-1.01
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501013
+BROKEN= "compilation error"
+.endif
+
pre-install:
${ECHO_CMD} bin/musicbox > ${PLIST}
.if !defined(NOPORTDOCS)
@@ -44,4 +51,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pp/Makefile b/games/pp/Makefile
index ce518a1b7630..8f4ed0dd9309 100644
--- a/games/pp/Makefile
+++ b/games/pp/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Prometeus Project - real time strategy game for X Window System
WRKSRC= ${WRKDIR}/ppsrc
+USE_GCC= 2.95
USE_QT_VER= 1
USE_X_PREFIX= yes
diff --git a/math/xgfe/Makefile b/math/xgfe/Makefile
index 4c1856458a54..5cc2f3a00669 100644
--- a/math/xgfe/Makefile
+++ b/math/xgfe/Makefile
@@ -16,6 +16,7 @@ COMMENT= An X11 front-end for Gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+USE_GCC= 2.95
USE_QT_VER= 1
USE_X_PREFIX= yes
diff --git a/misc/peq/Makefile b/misc/peq/Makefile
index a2377b6a8dca..3855341ffc06 100644
--- a/misc/peq/Makefile
+++ b/misc/peq/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://www.shrubbery.org.za/peq/
MAINTAINER= gordon@shrubbery.org.za
COMMENT= Fortune like program
+USE_GCC= 2.95
USE_QT_VER= 1
post-install:
diff --git a/net/icqnix/Makefile b/net/icqnix/Makefile
index 1b76790dd59f..b7bd690988ef 100644
--- a/net/icqnix/Makefile
+++ b/net/icqnix/Makefile
@@ -22,8 +22,14 @@ USE_QT_VER= 1
CONFIGURE_ARGS= --with-qt-libraries=${X11BASE}/lib --with-qt-includes=${X11BASE}/include/X11/qt1
CONFIGURE_ENV= QT_MOC="${MOC}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501013
+BROKEN= "Configure fails"
+.endif
+
post-install:
@strip ${PREFIX}/bin/icqnix
@strip ${PREFIX}/bin/icqnix.install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt145/Makefile b/x11-toolkits/qt145/Makefile
index 2dc886276ed8..4743c361386f 100644
--- a/x11-toolkits/qt145/Makefile
+++ b/x11-toolkits/qt145/Makefile
@@ -21,6 +21,7 @@ MAINTAINER= kris@FreeBSD.org
COMMENT= A C++ X GUI toolkit
LATEST_LINK= qt1
+USE_GCC= 2.95
USE_GMAKE= yes
USE_X_PREFIX= yes
.if defined(MAKE_JOBS)
@@ -40,10 +41,6 @@ PLIST_SUB+= VERSION="${VER_MAJ}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
MAN1= moc.1
.include "${FILESDIR}/man3"