aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--databases/Makefile1
-rw-r--r--databases/freetds-msdblib/Makefile12
-rw-r--r--databases/freetds/Makefile10
-rw-r--r--databases/freetds/pkg-plist1
-rw-r--r--databases/py-mssql/Makefile4
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile2
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/php55/Makefile2
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/Makefile.ext4
14 files changed, 19 insertions, 34 deletions
diff --git a/MOVED b/MOVED
index 4a9d685a7cca..c66a5cfd4164 100644
--- a/MOVED
+++ b/MOVED
@@ -7131,3 +7131,4 @@ sysutils/rubygem-chef-server||2014-09-25|Has expired: Depends on broken rubygem-
sysutils/rubygem-chef-solr||2014-09-25|Has expired: Depends on broken rubygem-dep_selector
www/rubygem-chef-server-webui||2014-09-25|Has expired: Depends on broken rubygem-dep_selector
www/rubygem-chef-server-api||2014-09-25|Has expired: Depends on broken rubygem-dep_selector
+databases/freetds-msdblib||2014-09-27|No longer required, now covered by databases/freetds
diff --git a/databases/Makefile b/databases/Makefile
index 5253f335ad55..1af4c0a34c97 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -70,7 +70,6 @@
SUBDIR += fpc-sqlite
SUBDIR += freetds
SUBDIR += freetds-devel
- SUBDIR += freetds-msdblib
SUBDIR += frontbase-jdbc
SUBDIR += gadfly
SUBDIR += galera
diff --git a/databases/freetds-msdblib/Makefile b/databases/freetds-msdblib/Makefile
deleted file mode 100644
index 6a98c121bf9f..000000000000
--- a/databases/freetds-msdblib/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-PKGNAMESUFFIX= -msdblib
-
-MAINTAINER= ports@FreeBSD.org
-
-WITH_MSDBLIB= yes
-
-MASTERDIR= ${.CURDIR}/../freetds
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 4655a92207e1..457be04f03bf 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freetds
PORTVERSION= 0.91.103
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ftp://ftp.freetds.org/pub/freetds/stable/
@@ -22,16 +23,16 @@ USE_AUTOTOOLS= autoconf:env
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -lgcrypt
-CONFIGURE_ARGS= --with-tdsver=${TDS_VER} --sysconfdir=${ETCDIR}
+CONFIGURE_ARGS= --with-tdsver=${TDS_VER} --sysconfdir=${ETCDIR} \
+ --enable-sybase-compat --enable-msdblib
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
-OPTIONS_DEFINE= OPENSSL GNUTLS MSDBLIB DOCS
+OPTIONS_DEFINE= OPENSSL GNUTLS DOCS
OPTIONS_RADIO= ODBC
OPTIONS_RADIO_ODBC= IODBC UNIXODBC
-MSDBLIB_DESC= MS SQL Server support (breaks databases/sybtcl)
OPENSSL_USE= OPENSSL=yes
OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
@@ -41,9 +42,6 @@ IODBC_CONFIGURE_ON= --with-iodbc=${LOCALBASE}
IODBC_CPPFLAGS= -I${LOCALBASE}/include/libiodbc
UNIXODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
UNIXODBC_CONFIGURE_ON= --with-unixodbc=${LOCALBASE}
-# We cannot use msdblib-style by default, because port databases/sybtcl
-# relies on sybase-style dblib
-MSDBLIB_CONFIGURE_ON= --enable-msdblib
.include <bsd.port.options.mk>
diff --git a/databases/freetds/pkg-plist b/databases/freetds/pkg-plist
index 2ff9e2eb8cf9..f3f08469d5d2 100644
--- a/databases/freetds/pkg-plist
+++ b/databases/freetds/pkg-plist
@@ -46,4 +46,3 @@ man/man5/freetds.conf.5.gz
%%ODBC%%lib/libtdsodbc.so.0.0.0
%%ODBC%%lib/libtdsodbc.la
%%ODBC%%lib/libtdsodbc.a
-@dirrm %%ETCDIR%%
diff --git a/databases/py-mssql/Makefile b/databases/py-mssql/Makefile
index 302fd015d80e..10021ccbebc5 100644
--- a/databases/py-mssql/Makefile
+++ b/databases/py-mssql/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mssql
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ COMMENT= Python database interface for simple MS-SQL access
LICENSE= LGPL21
-LIB_DEPENDS= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS= libsybdb.so:${PORTSDIR}/databases/freetds
USES= dos2unix python:2
USE_PYTHON= autoplist distutils
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 22cdd9d460a1..2ea6c6ccbd4e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php5
PORTVERSION= 5.4.33
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 2bd34ba59ea4..dd15b6851644 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -557,7 +557,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 2b96d3df0db7..b0f539a07c2a 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php53
PORTVERSION= 5.3.29
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index d2271e7a5805..721fa72e9817 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -181,7 +181,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -563,7 +563,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.if ${PHP_MODNAME} == "pdo_dblib"
.if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds
.else
LIB_DEPENDS+= libct.so.4:${PORTSDIR}/databases/freetds
.endif
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index 9b30650401b7..770658ca43d1 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php55
PORTVERSION= 5.5.17
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index 8d4077162553..c330c85aae91 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -561,7 +561,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 98d5a19af4ea..e2716e6d3e8c 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php56
PORTVERSION= 5.6.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index a6e6175b19a3..d293fa272e8b 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -564,7 +564,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif