aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/Makefile1
-rw-r--r--editors/hexer/Makefile31
-rw-r--r--editors/hexer/distinfo3
-rw-r--r--editors/hexer/pkg-descr5
-rw-r--r--editors/hexer/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 733ed6fe42a8..5c521f869791 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -69,6 +69,7 @@
SUBDIR += heme
SUBDIR += hexcurse
SUBDIR += hexedit
+ SUBDIR += hexer
SUBDIR += hexpert
SUBDIR += hnb
SUBDIR += hte
diff --git a/editors/hexer/Makefile b/editors/hexer/Makefile
new file mode 100644
index 000000000000..9c378b5073f8
--- /dev/null
+++ b/editors/hexer/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= hexer
+PORTVERSION= 1.0.3
+CATEGORIES= editors
+MASTER_SITES= http://devel.ringlet.net/files/editors/hexer/ \
+ LOCAL/ehaupt
+
+MAINTAINER= anastasios@mageirias.com
+COMMENT= Multi buffer editor for binary files
+
+LICENSE= DEMETRIO
+LICENSE_NAME= Sascha Demetrio Custom License
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+OPTIONS_DEFINE= MYC
+MYC_DESC= Builtin calculator
+OPTIONS_SUB= yes
+OPTIONS_DEFAULT=MYC
+
+ALL_TARGET= all
+MYC_ALL_TARGET= myc
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hexer
+
+post-install-MYC-on:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/myc
+
+.include <bsd.port.mk>
diff --git a/editors/hexer/distinfo b/editors/hexer/distinfo
new file mode 100644
index 000000000000..895f97bee8f6
--- /dev/null
+++ b/editors/hexer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481880979
+SHA256 (hexer-1.0.3.tar.gz) = 74149464a713efc34d6bae1cb95e82727ead12dc8a8444f9dfd66f6e459c8191
+SIZE (hexer-1.0.3.tar.gz) = 129665
diff --git a/editors/hexer/pkg-descr b/editors/hexer/pkg-descr
new file mode 100644
index 000000000000..11ff5000280b
--- /dev/null
+++ b/editors/hexer/pkg-descr
@@ -0,0 +1,5 @@
+Hexer is a multi buffer editor for binary files for UN*X that displays its
+buffer(s) as hex dump. The user interface is kept similar to vi/ex. All
+POSIX-compatible environments should be supported.
+
+WWW: https://gitlab.com/hexer/hexer
diff --git a/editors/hexer/pkg-plist b/editors/hexer/pkg-plist
new file mode 100644
index 000000000000..dc38d46a5601
--- /dev/null
+++ b/editors/hexer/pkg-plist
@@ -0,0 +1,4 @@
+bin/hexer
+man/man1/hexer.1.gz
+%%MYC%%bin/myc
+%%MYC%%man/man1/myc.1.gz