aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/opencore-amr/Makefile21
-rw-r--r--audio/opencore-amr/distinfo3
-rw-r--r--audio/opencore-amr/pkg-descr4
-rw-r--r--audio/opencore-amr/pkg-plist15
5 files changed, 44 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6e220d0a388c..afdf9a07bf46 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -495,6 +495,7 @@
SUBDIR += oggsplit
SUBDIR += openal
SUBDIR += openal-soft
+ SUBDIR += opencore-amr
SUBDIR += openspc
SUBDIR += opmixer
SUBDIR += optimfrog
diff --git a/audio/opencore-amr/Makefile b/audio/opencore-amr/Makefile
new file mode 100644
index 000000000000..a47c98af244a
--- /dev/null
+++ b/audio/opencore-amr/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: opencore-amr
+# Date created: 2009-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opencore-amr
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= gslin@gslin.org
+COMMENT= OpenCORE implementation of AMR Narrowband & Wideband speech codec
+
+CFLAGS+= -fPIC
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/opencore-amr/distinfo b/audio/opencore-amr/distinfo
new file mode 100644
index 000000000000..ea2ca10e59b2
--- /dev/null
+++ b/audio/opencore-amr/distinfo
@@ -0,0 +1,3 @@
+MD5 (opencore-amr-0.1.1.tar.gz) = d2e18436202fc14e03e5a254f8eb1df4
+SHA256 (opencore-amr-0.1.1.tar.gz) = c5614a0e8c2fcaa1574738e79a402c82c92ee26545bd4cc73134147defd65ebe
+SIZE (opencore-amr-0.1.1.tar.gz) = 559148
diff --git a/audio/opencore-amr/pkg-descr b/audio/opencore-amr/pkg-descr
new file mode 100644
index 000000000000..8fc113b8aff3
--- /dev/null
+++ b/audio/opencore-amr/pkg-descr
@@ -0,0 +1,4 @@
+Library of OpenCORE Framework implementation of Adaptive Multi Rate
+Narrowband and Wideband speech codec.
+
+WWW: http://sourceforge.net/projects/opencore-amr/
diff --git a/audio/opencore-amr/pkg-plist b/audio/opencore-amr/pkg-plist
new file mode 100644
index 000000000000..8f63e2786696
--- /dev/null
+++ b/audio/opencore-amr/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+include/opencore-amrnb/interf_dec.h
+include/opencore-amrnb/interf_enc.h
+include/opencore-amrwb/dec_if.h
+include/opencore-amrwb/if_rom.h
+lib/libopencore-amrnb.a
+lib/libopencore-amrnb.so
+lib/libopencore-amrnb.so.0
+lib/libopencore-amrnb.so.0.1.1
+lib/libopencore-amrwb.a
+lib/libopencore-amrwb.so
+lib/libopencore-amrwb.so.0
+lib/libopencore-amrwb.so.0.1.1
+@dirrmtry include/opencore-amrwb
+@dirrmtry include/opencore-amrnb