aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/viking/Makefile6
-rw-r--r--audio/py-karaoke/Makefile8
-rw-r--r--audio/xmms-curses/Makefile6
-rw-r--r--cad/brlcad/Makefile8
-rw-r--r--cad/openvsp/Makefile7
-rw-r--r--devel/libpthread-stubs/Makefile6
-rw-r--r--devel/libpthread-stubs/distinfo5
-rw-r--r--devel/libpthread-stubs/files/patch-Makefile.in25
-rw-r--r--devel/libpthread-stubs/files/patch-stubs.c28
-rw-r--r--devel/libpthread-stubs/pkg-plist5
-rw-r--r--games/capicity/Makefile6
-rw-r--r--games/capitalism/Makefile6
-rw-r--r--games/spellathon/Makefile6
-rw-r--r--graphics/gbm/Makefile4
-rw-r--r--graphics/libEGL/Makefile4
-rw-r--r--graphics/libdrm/Makefile5
-rw-r--r--graphics/libglapi/Makefile2
-rw-r--r--graphics/libreatlas/Makefile4
-rw-r--r--net/x11vnc/Makefile6
-rw-r--r--science/massxpert/Makefile6
-rw-r--r--x11-wm/echinus/Makefile6
-rw-r--r--x11/slim/Makefile10
22 files changed, 56 insertions, 113 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 795e0cabb14e..f76cbc1d3f8c 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -3,7 +3,7 @@
PORTNAME= viking
PORTVERSION= 1.6.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/
@@ -13,14 +13,14 @@ COMMENT= Program to manage GPS data (tracks, waypoints, etc.)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgexiv2.so:graphics/gexiv2 \
libpcre.so:devel/pcre \
- libpng.so:graphics/png \
- libpthread-stubs.so:devel/libpthread-stubs
+ libpng.so:graphics/png
RUN_DEPENDS= gpsbabel:astro/gpsbabel
USES= compiler:c++11-lib gmake iconv desktop-file-utils perl5 pkgconfig tar:bzip2
diff --git a/audio/py-karaoke/Makefile b/audio/py-karaoke/Makefile
index 52b25d4dffc1..3c1672a3822c 100644
--- a/audio/py-karaoke/Makefile
+++ b/audio/py-karaoke/Makefile
@@ -3,7 +3,7 @@
PORTNAME= karaoke
PORTVERSION= 0.7.5
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= audio python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,9 +14,9 @@ COMMENT= Python karaoke application (Plays CD+G, MP3+G, OGG+G files)
LICENSE= LGPL21+
-BUILD_DEPENDS= ${PYGAME}
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libaa.so:graphics/aalib
+BUILD_DEPENDS= ${PYGAME} \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libaa.so:graphics/aalib
RUN_DEPENDS= dejavu>0:x11-fonts/dejavu \
${PYGAME} \
${PYNUMPY}
diff --git a/audio/xmms-curses/Makefile b/audio/xmms-curses/Makefile
index 71a064997031..b4faafe731fa 100644
--- a/audio/xmms-curses/Makefile
+++ b/audio/xmms-curses/Makefile
@@ -3,16 +3,16 @@
PORTNAME= xmms-curses
PORTVERSION= 0.2.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses program for (remote) controlling multimedia/xmms
-BUILD_DEPENDS= xmms:multimedia/xmms
+BUILD_DEPENDS= xmms:multimedia/xmms \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
RUN_DEPENDS= xmms:multimedia/xmms
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs
USES= gettext iconv ncurses
USE_GNOME= gtk12
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 876e9075a93d..6485ba7b5e49 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= brlcad
PORTVERSION= 7.24.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/BRL-CAD%20Source/${PORTVERSION}
@@ -13,10 +13,10 @@ COMMENT= CSG modelling system from the US Ballistic Research Laboratory
DEPRECATED= Depends on expring graphics/urt
EXPIRATION_DATE=2017-04-01
-BUILD_DEPENDS= ${LOCALBASE}/include/tnt/jama_lu.h:math/jama \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs \
+ ${LOCALBASE}/include/tnt/jama_lu.h:math/jama \
xsltproc:textproc/libxslt
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libdrm.so:graphics/libdrm \
+LIB_DEPENDS= libdrm.so:graphics/libdrm \
libpng.so:graphics/png \
librle.so:graphics/urt \
libfreetype.so:print/freetype2 \
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 7dcdf6847f44..9d47d3c4da6c 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openvsp
PORTVERSION= 3.10.0
+PORTREVISION= 1
DISTVERSIONPREFIX= ${GH_PROJECT}_
CATEGORIES= cad
@@ -14,8 +15,7 @@ LICENSE_NAME= NASA Open Source Agreement version 1.3
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libdrm.so:graphics/libdrm \
+LIB_DEPENDS= libdrm.so:graphics/libdrm \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
@@ -26,7 +26,8 @@ LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs \
${LOCALBASE}/include/eli/code_eli.hpp:graphics/code-eli \
${LOCALBASE}/include/glm/glm.hpp:math/glm \
- ${LOCALBASE}/include/eigen3/Eigen/Array:math/eigen3
+ ${LOCALBASE}/include/eigen3/Eigen/Array:math/eigen3 \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
USE_GITHUB= yes
GH_PROJECT= OpenVSP
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index b351f46489b3..927d19a4b3d1 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libpthread-stubs
-PORTVERSION= 0.3
-PORTREVISION= 6
+PORTVERSION= 0.4
CATEGORIES= devel
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -12,7 +11,8 @@ COMMENT= This library provides weak aliases for pthread functions
USES= libtool pathfix tar:bzip2
USE_LDCONFIG= yes
-
GNU_CONFIGURE= yes
+PLIST_FILES= libdata/pkgconfig/pthread-stubs.pc
+
.include <bsd.port.mk>
diff --git a/devel/libpthread-stubs/distinfo b/devel/libpthread-stubs/distinfo
index 25e9f1bfd3a9..d7153dd96114 100644
--- a/devel/libpthread-stubs/distinfo
+++ b/devel/libpthread-stubs/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libpthread-stubs-0.3.tar.bz2) = 35b6d54e3cc6f3ba28061da81af64b9a92b7b757319098172488a660e3d87299
-SIZE (libpthread-stubs-0.3.tar.bz2) = 203468
+TIMESTAMP = 1490198411
+SHA256 (libpthread-stubs-0.4.tar.bz2) = e4d05911a3165d3b18321cc067fdd2f023f06436e391c6a28dff618a78d2e733
+SIZE (libpthread-stubs-0.4.tar.bz2) = 57565
diff --git a/devel/libpthread-stubs/files/patch-Makefile.in b/devel/libpthread-stubs/files/patch-Makefile.in
deleted file mode 100644
index 6d3234911187..000000000000
--- a/devel/libpthread-stubs/files/patch-Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.in.orig
-+++ Makefile.in
-@@ -75,9 +75,9 @@
- LTLIBRARIES = $(lib_LTLIBRARIES)
- libpthread_stubs_la_LIBADD =
- am__libpthread_stubs_la_SOURCES_DIST = stubs.c
--@BUILD_LIB_TRUE@am_libpthread_stubs_la_OBJECTS = stubs.lo
-+am_libpthread_stubs_la_OBJECTS = stubs.lo
- libpthread_stubs_la_OBJECTS = $(am_libpthread_stubs_la_OBJECTS)
--@BUILD_LIB_TRUE@am_libpthread_stubs_la_rpath = -rpath $(libdir)
-+am_libpthread_stubs_la_rpath = -rpath $(libdir)
- DEFAULT_INCLUDES = -I.@am__isrc@
- depcomp = $(SHELL) $(top_srcdir)/depcomp
- am__depfiles_maybe = depfiles
-@@ -221,8 +221,8 @@
- top_srcdir = @top_srcdir@
- pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = pthread-stubs.pc
--@BUILD_LIB_TRUE@lib_LTLIBRARIES = libpthread-stubs.la
--@BUILD_LIB_TRUE@libpthread_stubs_la_SOURCES = stubs.c
-+lib_LTLIBRARIES = libpthread-stubs.la
-+libpthread_stubs_la_SOURCES = stubs.c
- all: config.h
- $(MAKE) $(AM_MAKEFLAGS) all-am
-
diff --git a/devel/libpthread-stubs/files/patch-stubs.c b/devel/libpthread-stubs/files/patch-stubs.c
deleted file mode 100644
index 4290eb2e6987..000000000000
--- a/devel/libpthread-stubs/files/patch-stubs.c
+++ /dev/null
@@ -1,28 +0,0 @@
-XXX This is a big hack as we cannot define pthread_condattr_{init,destroy}
-here, or we will conflict with the weak symbols in libthr. The way our linker
-works, the weak symbols will be resolved here, and pthread_condattr functions
-will not work even in threaded applications.
-
-I am working to get these symbols added to libc, but in the meantime, this
-is needed to avoid crashes in threaded applications which make use of
-pthread_condattr*.
---- stubs.c.orig 2009-11-27 17:15:30.000000000 -0500
-+++ stubs.c 2009-11-27 17:16:29.000000000 -0500
-@@ -91,7 +91,7 @@ int pthread_cond_destroy() __attribute__
- # endif
- #endif
-
--#ifndef HAVE_PTHREAD_CONDATTR_INIT
-+#if 0
- #define NEED_ZERO_STUB
- # ifdef SUPPORT_ATTRIBUTE_ALIAS
- int pthread_condattr_init() __attribute__ ((weak, alias ("__pthread_zero_stub")));
-@@ -100,7 +100,7 @@ int pthread_condattr_init() __attribute_
- # endif
- #endif
-
--#ifndef HAVE_PTHREAD_CONDATTR_DESTROY
-+#if 0
- #define NEED_ZERO_STUB
- # ifdef SUPPORT_ATTRIBUTE_ALIAS
- int pthread_condattr_destroy() __attribute__ ((weak, alias ("__pthread_zero_stub")));
diff --git a/devel/libpthread-stubs/pkg-plist b/devel/libpthread-stubs/pkg-plist
deleted file mode 100644
index d027c649d4ba..000000000000
--- a/devel/libpthread-stubs/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-lib/libpthread-stubs.a
-lib/libpthread-stubs.so
-lib/libpthread-stubs.so.0
-lib/libpthread-stubs.so.0.0.0
-libdata/pkgconfig/pthread-stubs.pc
diff --git a/games/capicity/Makefile b/games/capicity/Makefile
index 4f68da62716d..d92b0b8fa3b4 100644
--- a/games/capicity/Makefile
+++ b/games/capicity/Makefile
@@ -3,7 +3,7 @@
PORTNAME= capicity
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/capitalism/Capi%20City/${PORTVERSION}/
DISTNAME= CapiCity_${DISTVERSION}
@@ -14,8 +14,8 @@ COMMENT= Qt client for the Monopd server
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/copying.txt
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libpcre.so:devel/pcre \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
diff --git a/games/capitalism/Makefile b/games/capitalism/Makefile
index 5de58fa6d48d..e9d030909808 100644
--- a/games/capitalism/Makefile
+++ b/games/capitalism/Makefile
@@ -3,7 +3,7 @@
PORTNAME= capitalism
PORTVERSION= 0.5.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Capitalism/0.5/
EXTRACT_SUFX= .tbz
@@ -14,8 +14,8 @@ COMMENT= Qt client for the Monopd server
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/copying.txt
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libpcre.so:devel/pcre \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
diff --git a/games/spellathon/Makefile b/games/spellathon/Makefile
index f36913fb2d68..5caeb4d3d5d2 100644
--- a/games/spellathon/Makefile
+++ b/games/spellathon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spellathon
PORTVERSION= 6.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Spellathon%20${PORTVERSION}
@@ -12,8 +12,8 @@ COMMENT= Word game to test your English vocabulary skills
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libpcre.so:devel/pcre \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
diff --git a/graphics/gbm/Makefile b/graphics/gbm/Makefile
index cd8bf5826219..7db148fedcf9 100644
--- a/graphics/gbm/Makefile
+++ b/graphics/gbm/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= graphics
COMMENT= gbm library
-LIB_DEPENDS+= libpthread-stubs.so:devel/libpthread-stubs \
- libexpat.so:textproc/expat2 \
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS+= libexpat.so:textproc/expat2 \
libdrm.so:graphics/libdrm \
libglapi.so:graphics/libglapi
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index 2e4925685b48..3da0c811e80a 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= graphics
COMMENT= OpenEGL library
-LIB_DEPENDS+= libpthread-stubs.so:devel/libpthread-stubs \
- libexpat.so:textproc/expat2 \
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS+= libexpat.so:textproc/expat2 \
libdrm.so:graphics/libdrm
USE_GL= gbm
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index 4538dee79513..beb2356a9404 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -13,10 +13,9 @@ COMMENT= Userspace interface to kernel Direct Rendering Module services
LICENSE= MIT
-BUILD_DEPENDS= libdevq>=0.0.4:devel/libdevq
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
- libdevq.so:devel/libdevq \
- libpthread-stubs.so:devel/libpthread-stubs
+ libdevq.so:devel/libdevq
USES= libtool pkgconfig tar:bzip2
GNU_CONFIGURE= yes
diff --git a/graphics/libglapi/Makefile b/graphics/libglapi/Makefile
index 42f4e2bbc11c..bbf5bc75f1f1 100644
--- a/graphics/libglapi/Makefile
+++ b/graphics/libglapi/Makefile
@@ -10,7 +10,7 @@ COMMENT= Common GL api library used by Mesa based ports
LICENSE= MIT
-LIB_DEPENDS+= libpthread-stubs.so:devel/libpthread-stubs
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
USE_XORG= x11 xau xcb xdmcp xvmc
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
index 2915a1542522..b7a4f3b29b3d 100644
--- a/graphics/libreatlas/Makefile
+++ b/graphics/libreatlas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libreatlas
PORTVERSION= 1.0.0a
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= graphics geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
@@ -12,10 +12,10 @@ COMMENT= Open Source Geography Education application
LICENSE= GPLv3
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libmspack.so:archivers/libmspack \
libspatialite.so:databases/spatialite \
libsqlite3.so:databases/sqlite3 \
- libpthread-stubs.so:devel/libpthread-stubs \
libpcre.so:devel/pcre \
libcairo.so:graphics/cairo \
libgeos.so:graphics/geos \
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 6c0119c799f4..8da677e4b1a7 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= x11vnc
PORTVERSION= 0.9.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= SF/libvncserver/${PORTNAME}/${PORTVERSION}
@@ -12,8 +12,8 @@ COMMENT= VNC server for use with real X displays
LICENSE= GPLv2
-LIB_DEPENDS= libdbus-1.so:devel/dbus \
- libpthread-stubs.so:devel/libpthread-stubs
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libdbus-1.so:devel/dbus
USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
xdmcp recordproto
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 3a8a986c1ea6..3dbd00101301 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -3,7 +3,7 @@
PORTNAME= massxpert
PORTVERSION= 3.4.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
MASTER_SITES= http://download.tuxfamily.org/massxpert/source/
@@ -12,8 +12,8 @@ COMMENT= massXpert software for (bio)chemists
LICENSE= GPLv3
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libpcre.so:devel/pcre \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
diff --git a/x11-wm/echinus/Makefile b/x11-wm/echinus/Makefile
index c34d23caf2f3..57989d372d93 100644
--- a/x11-wm/echinus/Makefile
+++ b/x11-wm/echinus/Makefile
@@ -3,15 +3,15 @@
PORTNAME= echinus
PORTVERSION= 0.4.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= http://plhk.ru/static/echinus/
MAINTAINER= hrkfdn@gmail.com
COMMENT= Dynamic window manager for X11 based on dwm
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libfreetype.so:print/freetype2 \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2 \
libfontconfig.so:x11-fonts/fontconfig
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index c19e1317e170..dd86ceb64e73 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
@@ -13,8 +13,8 @@ COMMENT= Graphical login manager for X11, derived from Login.app
LICENSE= GPLv2
-LIB_DEPENDS= libpthread-stubs.so:devel/libpthread-stubs \
- libpng.so:graphics/png \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
+LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
@@ -26,8 +26,8 @@ USE_LDCONFIG= yes
SUB_FILES= pkg-message
CMAKE_ARGS= -DUSE_CONSOLEKIT=yes \
- -DBUILD_SLIMLOCK=no \
- -DBUILD_SHARED_LIBS=yes
+ -DBUILD_SLIMLOCK=no \
+ -DBUILD_SHARED_LIBS=yes
OPTIONS_DEFINE= PAM UTF8 CONSOLEKIT
OPTIONS_DEFAULT= PAM CONSOLEKIT