aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES11
-rw-r--r--Mk/bsd.options.mk29
2 files changed, 40 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 8755cec4cace..60a738cab981 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,17 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150828:
+AUTHOR: mat@FreeBSD.org
+
+ <opt>_VARS and <opt>_VARS_OFF have been introduced to allow for a generic way
+ to set/append to variables.
+
+ OPT1_VARS= foo=bar baz+=bam
+
+ will set FOO to bar and append bam to BAZ if OPT1 is enabled. <opt>_VARS_OFF
+ works the same way, if the option is disabled.
+
20150818:
AUTHOR: kde@FreeBSD.org
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 22ec6a6562a1..bfdf348c1cda 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -110,6 +110,15 @@
# ${opt}_USE_OFF= FOO=bar When option is disabled, it will enable
# USE_FOO+= bar
#
+# ${opt}_VARS= FOO=bar When option is enabled, it will run
+# FOO= bar
+# ${opt}_VARS= FOO+=bar When option is enabled, it will run
+# FOO+= bar
+# ${opt}_VARS_OFF= FOO=bar When option is disabled, it will run
+# FOO= bar
+# ${opt}_VARS_OFF= FOO+=bar When option is disabled, it will run
+# FOO+= bar
+#
# For each of:
# ALL_TARGET BROKEN CATEGORIES CFLAGS CONFIGURE_ENV CONFLICTS CONFLICTS_BUILD
# CONFLICTS_INSTALL CPPFLAGS CXXFLAGS DISTFILES EXTRA_PATCHES EXTRACT_ONLY
@@ -463,6 +472,16 @@ _u= ${option:C/=.*//g}
USE_${_u:tu}+= ${option:C/.*=//g:C/,/ /g}
. endfor
. endif
+. if defined(${opt}_VARS)
+. for var in ${${opt}_VARS}
+_u= ${var:C/=.*//}
+. if ${_u:M*+}
+${_u:C/.$//:tu}+= ${var:C/[^+]*\+=//:C/^"(.*)"$$/\1/}
+. else
+${_u:tu}= ${var:C/[^=]*=//:C/^"(.*)"$$/\1/}
+. endif
+. endfor
+. endif
. if defined(${opt}_CONFIGURE_ENABLE)
. for iopt in ${${opt}_CONFIGURE_ENABLE}
CONFIGURE_ARGS+= --enable-${iopt}
@@ -501,6 +520,16 @@ _u= ${option:C/=.*//g}
USE_${_u:tu}+= ${option:C/.*=//g:C/,/ /g}
. endfor
. endif
+. if defined(${opt}_VARS_OFF)
+. for var in ${${opt}_VARS_OFF}
+_u= ${var:C/=.*//}
+. if ${_u:M*+}
+${_u:C/.$//:tu}+= ${var:C/[^+]*\+=//:C/^"(.*)"$$/\1/}
+. else
+${_u:tu}= ${var:C/[^=]*=//:C/^"(.*)"$$/\1/}
+. endif
+. endfor
+. endif
. if defined(${opt}_CONFIGURE_ENABLE)
. for iopt in ${${opt}_CONFIGURE_ENABLE}
CONFIGURE_ARGS+= --disable-${iopt:C/=.*//}
tgraph'>* set_release on the sequence we create.Rodrigo Moya2003-03-152-0/+4 * don't leak the string sequence returned by CalFactory_uriList.Rodrigo Moya2003-03-142-1/+8 * use a weak ref instead of connecting to backend's "destroy" signal.Rodrigo Moya2003-03-132-9/+12 * don't use GNOME_STOCK_* defines, but GTK_STOCK_*.Rodrigo Moya2003-03-132-3/+8 * corrected button ordering and changed the return type to be aRodrigo Moya2003-03-134-10/+25 * Update for timezone dialog API changes.Dan Winship2003-03-123-102/+38 * issue more descriptive warnings.Rodrigo Moya2003-03-122-2/+7 * if we already have the client loaded, don't remove it, just increment itsRodrigo Moya2003-03-103-50/+72 * create the array to be returned only once.Rodrigo Moya2003-03-072-3/+8 * ref the CalClient. (notify_dialog_cb): unref the CalClient.Rodrigo Moya2003-03-062-0/+7 * new function. (alarm_notify_dialog): made it return a pointer to theRodrigo Moya2003-03-064-37/+144 * Fixes #31382Rodrigo Moya2003-03-062-2/+10 * fix defaults and descriptions to match what calendar-config wants them toJP Rosevear2003-03-062-30/+35 * g_objectify ref/unrefJP Rosevear2003-03-054-7/+16 * override finalize, not destroy (start_calendar_server): take itip as aJP Rosevear2003-03-052-46/+138 * cast CalClient's to GObject, not GtkObject.Rodrigo Moya2003-03-052-4/+9 * don't let the user change to an email organizer if the back end is not anJP Rosevear2003-03-052-3/+11 * Fixes #37881JP Rosevear2003-03-052-2/+52 * Fixes #37881JP Rosevear2003-03-052-1/+8 * Fixes #37883JP Rosevear2003-03-052-1/+8 * Fixes #37806, #37697JP Rosevear2003-03-052-4/+14 * implementJP Rosevear2003-03-059-20/+164 * call cal_client_get_cal_address instead of cal_client_get_email_addressJP Rosevear2003-03-0510-44/+75 * fix commentJP Rosevear2003-03-052-1/+5 * update FIXME noteJP Rosevear2003-03-052-3/+6 * fix copyrightJP Rosevear2003-03-053-7/+15 * Partially Fixes #23606 (from Jack Jia <jack.jia@sun.com>)JP Rosevear2003-03-053-2/+22 * Shush.JP Rosevear2003-03-051-1/+3 * Commit missed files.JP Rosevear2003-03-052-0/+126 * If only the pipe wouldn't break.JP Rosevear2003-03-0551-2399/+3298 * Merging in 1.2 stuffJP Rosevear2003-03-053-32/+237 * Fixes #35598JP Rosevear2003-03-051-0/+463 * gui/dialogs/alarm-page.c gui/dialogs/event-page.cHans Petter Jansson2003-03-048-7/+19 * Do importers after the other dirs, as it relies on generated files fromHans Petter Jansson2003-03-022-1/+7 * Shlibify.Hans Petter Jansson2003-03-015-60/+59 * build libcal-dialogs as an uninstalled shared library ($(IDL_GENERATED_H),Dan Winship2003-03-014-13/+19 * Forgot to mention server file move.Hans Petter2003-03-011-0/+3 * Add calendar/importers/Makefile to output.Hans Petter Jansson2003-03-015-6/+20 * Remove libalarm.a, which was not being used by the calendar.Dan Winship2003-03-014-17/+23 * link to versist libtool objectJP Rosevear2003-02-283-2/+8 * This makes alarm notification work.Hans Petter Jansson2003-02-272-1/+8 * This makes creating appointments and tasks from the "New" button work.Hans Petter Jansson2003-02-272-6/+16 * Fixes Ximian #37895.Hans Petter Jansson2003-02-273-3/+13 * Fixes Ximian #38306.Hans Petter Jansson2003-02-272-19/+44 * Use fixed margins of 5% of page width/height. This is the same cheat asHans Petter Jansson2003-02-262-12/+43 * Get default view from correct key.Hans Petter Jansson2003-02-262-1/+6 * Show start/end-of-day widgets.Hans Petter Jansson2003-02-262-0/+7 * Don't warn if calendar isn't loaded... Doesn't seem to hurt, but thisHans Petter Jansson2003-02-245-5/+28 * gconf settings upgradesMichael Zucci2003-02-2413-419/+224 * dont unref accounts anymore. (change_status): itipAddress -> EAccount.Not Zed2003-02-241-1/+1 * dont unref accounts anymore. (change_status): itipAddress -> EAccount.Not Zed2003-02-242-2/+148 * Appease the compiler. (gnome_calendar_update_paned_quanta): Don't actuallyHans Petter Jansson2003-02-244-2/+34 * CVS server broke again. Here's the rest...Hans Petter Jansson2003-02-231-2/+2 * Eliminate e_utf8_to_gtk_string ().Hans Petter Jansson2003-02-237-18/+40 * Show the custom widgets, since libglade appears to not want to do that.Hans Petter Jansson2003-02-233-10/+44 * Add an iteration statement. Fixes hang in wombat.Hans Petter Jansson2003-02-232-0/+7 * Commit fixes from Grzegorz Goawski <grzegol@pld.org.pl>.Hans Petter Jansson2003-02-232-28/+35 * GObject, not GtkObject. (calendar_model_destroy): ->Hans Petter Jansson2003-02-227-30/+58 * Make libversit a shared library, update stuff for that, and clean upDan Winship2003-02-225-20/+27 * Add GConf schemas.Hans Petter Jansson2003-02-213-2/+365 * Make libemiscwidgets, libefilterbar, and libetimezonedialog dynamicDan Winship2003-02-212-2/+8 * revert previous changeDan Winship2003-02-206-22/+9 * Remove libversit. We haven't depended on that in forever.Dan Winship2003-02-206-9/+22 * Split $(CORBA_GENERATED_H) rule from the $(CORBA_GENERATED_C) rule to thatEttore Perazzoli2003-02-204-10/+23 * add .server.in filesDan Winship2003-02-201-0/+1 * Enable printing for calendar and tasks.Hans Petter Jansson2003-02-123-217/+189 * Don't use gtk_scrolled_window_set_scrollbar_spacing() anymore.Hans Petter Jansson2003-02-122-1/+5 * Don't try to make an error string from an uninitialized GnomeVFSResult.Hans Petter Jansson2003-02-112-4/+15 * Make the CORBA IDL compilation work with parallel makes. Likewise.Ettore Perazzoli2003-02-114-19/+61 * remove this file, as it's generated now Add this file to generate theRodney Dawes2003-02-083-3/+13 * Fixes #37706Rodrigo Moya2003-02-082-2/+25 * Use e_auto_kill_popup_menu_on_selection_done() instead ofEttore Perazzoli2003-02-073-2/+10 * show the widget before returning it.Dan Winship2003-02-072-1/+8 * s/PACKAGE/GETTEXT_PACKAGE/ in gettext initDan Winship2003-02-072-2/+7 * makefile and warnings fixesDan Winship2003-02-061-0/+105 * Update this some although it's not currently being builtDan Winship2003-02-061-6/+4 * Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir,Dan Winship2003-02-0613-41/+35 * Use privlibexecdir. (INCLUDES): Remove cruft. (gladedir, serversdir):Dan Winship2003-02-063-19/+11 * Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir): RemoveDan Winship2003-02-066-20/+11 * Define in terms of privincludedirDan Winship2003-02-063-8/+4 * Remove cruft. (libcal_utilincludedir): Define in terms of privincludedirDan Winship2003-02-061-2/+1 * Remove cruft. (pcsincludedir): Define in terms of privincludedirDan Winship2003-02-062-3/+1 * s/BonoboXObject/BonoboObject/Dan Winship2003-02-065-18/+24 * array of localized month day names ("1st" - "31st")Dan Winship2003-02-067-75/+294 * The CVS server exited after applying everything from my last commit,Hans Petter2003-02-051-10/+22 * Rename to e_meeting_time_selector_on_invite_others_button_expose() andHans Petter Jansson2003-02-052-9/+26 * Fix badly formatted ChangeLog entry. This has been bothering me since itHans Petter2003-02-051-2/+2 * Use PangoLayout to draw text.Hans Petter Jansson2003-02-052-12/+23 * updated for e scroll frame --> gtk scrolled windowRadek Doulik2003-02-052-18/+18 * Skip setting the "font_gdk" arg for now.Hans Petter Jansson2003-02-026-0/+29 * Fixes #35572Ronald Kuetemeier2003-01-312-0/+9 * CalClient and CalComponent are GObjects.Chris Toshok2003-01-273-19/+26 * fix warning. (get_default_timezone): BonoboConfigDatabase ->Chris Toshok2003-01-274-94/+36 * Make clicks, drags and resizes work, and pangoize remaining strings. FixHans Petter Jansson2003-01-274-50/+89 * Mainly making all views use PangoLayouts for text. When drawing aHans Petter Jansson2003-01-2617