aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-mysql2/Makefile18
-rw-r--r--databases/rubygem-mysql2/distinfo2
-rw-r--r--databases/rubygem-mysql2/pkg-descr5
4 files changed, 26 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 191802820cc1..0d8dff47604f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -836,6 +836,7 @@
SUBDIR += rubygem-jdbc-mysql
SUBDIR += rubygem-memcache
SUBDIR += rubygem-memcache-client
+ SUBDIR += rubygem-mysql2
SUBDIR += rubygem-pg
SUBDIR += rubygem-rbase
SUBDIR += rubygem-redis
diff --git a/databases/rubygem-mysql2/Makefile b/databases/rubygem-mysql2/Makefile
new file mode 100644
index 000000000000..566f8eb33c29
--- /dev/null
+++ b/databases/rubygem-mysql2/Makefile
@@ -0,0 +1,18 @@
+# Created by: Kimo <kimor79@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= mysql2
+PORTVERSION= 0.3.11
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Simple, fast MySQL library for Ruby, binding to libmysql
+
+USE_MYSQL= yes
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-mysql2/distinfo b/databases/rubygem-mysql2/distinfo
new file mode 100644
index 000000000000..9cea67ee78bc
--- /dev/null
+++ b/databases/rubygem-mysql2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/mysql2-0.3.11.gem) = 134f848e91d60756083873b66fc471a029b5df51c35852ef5a3a0f9f7a496641
+SIZE (rubygem/mysql2-0.3.11.gem) = 41984
diff --git a/databases/rubygem-mysql2/pkg-descr b/databases/rubygem-mysql2/pkg-descr
new file mode 100644
index 000000000000..895cc0fa1963
--- /dev/null
+++ b/databases/rubygem-mysql2/pkg-descr
@@ -0,0 +1,5 @@
+The Mysql2 gem is meant to serve the extremely common use-case of connecting,
+querying and iterating on results. Some database libraries out there serve as
+direct 1:1 mappings of the already complex C API's available. This one is not.
+
+WWW: http://github.com/brianmario/mysql2