aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/grepip/Makefile35
-rw-r--r--net-mgmt/grepip/distinfo2
-rw-r--r--net-mgmt/grepip/pkg-descr5
3 files changed, 42 insertions, 0 deletions
diff --git a/net-mgmt/grepip/Makefile b/net-mgmt/grepip/Makefile
new file mode 100644
index 000000000000..77e42c5f7aa7
--- /dev/null
+++ b/net-mgmt/grepip/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: grepip
+# Date created: 2 Nov 2005
+# Whom: Serge Maslov <serge@maslov.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grepip
+PORTVERSION= 1.0
+PORTREVISION= 1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://komquats.com/distfiles/ \
+ ${MASTER_SITE_LOCAL}/cy/
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Print lines contans IP matching a pattern in CIDR format
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+PLIST_FILES= bin/grepip
+PORTDOCS= README.txt
+
+do-build:
+ cd ${WRKSRC}; \
+ ${CC} ${CFLAGS} -c patricia.c; \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o -L${LOCALBASE}/lib -lpcre
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/grepip ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/grepip/distinfo b/net-mgmt/grepip/distinfo
new file mode 100644
index 000000000000..3bdef2e4fe84
--- /dev/null
+++ b/net-mgmt/grepip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (grepip-1.0.tar.gz) = ef4d9a9e239a4e5b3ca5671f83eaf3ef349e641a10a6d8d47e609ec9c0dcd526
+SIZE (grepip-1.0.tar.gz) = 15490
diff --git a/net-mgmt/grepip/pkg-descr b/net-mgmt/grepip/pkg-descr
new file mode 100644
index 000000000000..17e34337ef6e
--- /dev/null
+++ b/net-mgmt/grepip/pkg-descr
@@ -0,0 +1,5 @@
+grepip searches the named input FILE (or standard input if no files are named),
+for lines containing an IP address matched to the given CIDR.
+grepip finds IP in any context of a line, while grepcidr only if all line is IP.
+
+WWW: http://www.lexa.ru/lexa/
64-112/+91 * Use pure_install target instead of install, to prevent writing tojmz2005-04-122-8/+4 * Insist on a few more Gnome goodies.markm2005-04-122-0/+4 * - Update to 0.40vs2005-04-123-9/+20 * Update to 1.06mat2005-04-122-3/+3 * Update to 1.05mat2005-04-113-4/+4 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-1164-91/+112 * Update to 5.2hq2005-04-113-203/+216 * BROKEN on 4.x: Does not buildkris2005-04-111-1/+7 * Now builds on amd64kris2005-04-111-7/+1 * Update nip to latest version 7.10.10.lev2005-04-119-414/+241 * Update to latest version 7.10.10lev2005-04-113-247/+275 * - Update to 2.7.6.2pav2005-04-112-7/+8 * - Update to 2.2.6ahze2005-04-1115-2550/+2550 * Add UFRaw, a plugin for Gimp to read "posh" digital cameras' rawmarkm2005-04-1011-0/+115 * - Update ports/graphics/aqsis to 1.0.0leeym2005-04-103-7/+7 * Remove XAWVER from Xaw3d LIB_DEPENDS re. Xaw3d will be depended upon justlesi2005-04-102-2/+2 * - Fix WITH_IMAGEMAGICK_MODULES [1]pav2005-04-103-9/+26 * - Reflect plist changes in gauche portpav2005-04-092-4/+2 * - Unbreak: fix plistpav2005-04-092-5/+4 * - Unbreak: don't remove file installed by another portpav2005-04-092-4/+1 * Fix INDEX: x11-toolkits/libsx -> x11/libsx in BUILD_DEPENDShq2005-04-081-1/+1 * . Add a port of GrADS:glewis2005-04-0811-0/+574 * - Fix build on 4.x by commenting out a line that should be ignored by gcc2.95ahze2005-04-081-0/+15 * List missing directories in plistvs2005-04-082-0/+4 * Fix Xaw3d-build on 4.11vs2005-04-061-9/+17 * Update to 0.2.0.kwm2005-04-066-9/+19 * Update to 20050310 (distfile was updated and rerolled under the same name).danfe2005-04-062-7/+4 * - Fix plist and unbreakpav2005-04-061-5/+3 * - Update to 0.87 to unbreak buildahze2005-04-062-5/+3 * - Unmark BROKEN, works with new scons againpav2005-04-051-2/+0 * Unbreak: Dependency got fixedvs2005-04-041-4/+0 * - Chase libexif updateahze2005-04-041-2/+3 * - libexif library version change to .12clsung2005-04-041-1/+2 * - update to 2.23clsung2005-04-043-9/+8 * - Chase libexif updateahze2005-04-041-1/+2 * - Chase libexif updateahze2005-04-043-6/+6 * - exif library version now became .12clsung2005-04-042-3/+4 * - libexif library now became .12clsung2005-04-041-2/+2 * - update to 6.0.12clsung2005-04-044-19/+9 * - Update to 2.7.6pav2005-04-043-13/+59 * - Update to 0.9.11pav2005-04-042-5/+3 * Reset inactive maintainer. Thanks for your work in the past!kris2005-04-042-2/+2 * Update to 2.10.0.mezz2005-04-033-5/+6 * - Update to 1.9.2ahze2005-04-035-129/+4 * Fix build on i386 4: a hunk of a patch in ports/77257 wasn't committed.thierry2005-04-032-0/+8 * Fix up the pkg-config files so they don't reference a non-existentmarcus2005-04-031-0/+7 * - update to 10.26.6dinoex2005-04-022-4/+3 * Fix MASTER_SITES.krion2005-03-311-3/+1 * Properly cleanout mt locale.krion2005-03-301-2/+0 * BROKEN: Incomplete pkg-plistkris2005-03-271-0/+2 * BROKEN: Does not compilekris2005-03-271-0/+2 * Add NOT_FOR_ARCHS=sparc64 ia64 since this port uses inb/outb which do notkris2005-03-271-0/+2 * BROKEN: Incorrectly installs a perllocal.pod filekris2005-03-272-0/+4 * BROKEN: Unfetchablekris2005-03-272-0/+4 * BROKEN: Broken dependencykris2005-03-271-0/+2 * BROKEN: Incomplete pkg-plistkris2005-03-271-0/+2 * BROKEN: Does not buildkris2005-03-271-0/+2 * BROKEN: Size mismatchkris2005-03-261-0/+2 * Spell LIB_DEPENDS correctly for the jpeg-mmx plugin. [1]kwm2005-03-262-0/+2 * Add mxp (Mandelbrot explorer). Mxp is an X application for computing and expl...maho2005-03-257-0/+124 * - fix segfault in ppmcolormask with stdindinoex2005-03-232-0/+21 * Make fetchable again.thierry2005-03-233-3/+4 * - Add missed build dependency to fix plist on i386pav2005-03-221-1/+7 * Add MASTER_SITE_SUBDIR to fix fetching.lesi2005-03-221-0/+1 * Fix plist.krion2005-03-221-0/+2 * Add gnomehier to fix plist.krion2005-03-221-2/+2 * Fix pkg-plist.danfe2005-03-221-0/+2 * BROKEN: Size mismatchkris2005-03-221-0/+2 * Fix format string vulnerability.simon2005-03-222-1/+12 * Link the loaders/filters with libImlib2. This makes p5-Image-Imlib2 workphilip2005-03-213-1/+213 * This photo gallery software makes web albums of your digital images.hq2005-03-216-0/+1643 * x-face-e21.el has been updated to 0.128.yoichi2005-03-212-5/+3 * Add digit to OSVERSION.kwm2005-03-212-2/+2 * Update to version 0.2.0.kwm2005-03-2110-34/+60 * update to 0.3.4.kwm2005-03-212-3/+4 * Update to KDE 3.4lofi2005-03-2120-169/+104 * Update to 0.56.perky2005-03-212-3/+3 * Update to 0.3.3.kwm2005-03-213-5/+7 * No longer BROKEN because leeym@ updated pkg-plist.danfe2005-03-201-2/+0 * - Update WWW: lineahze2005-03-202-2/+2 * - Transfer MAINTAINER to gnome@ahze2005-03-191-1/+1 * Reindent header.danfe2005-03-191-3/+3 * Update to version 1.8.1.danfe2005-03-193-5/+5 * fix build on 5.x/6.x and all archs.krion2005-03-182-0/+5 * Updated to 0.39skv2005-03-182-3/+3 * Remove gnome-vfs support.adamw2005-03-181-9/+3 * Fully-qualify the path to update-desktop-database and update-mime-database inmezz2005-03-1716-21/+24 * Update to 4.1.44vs2005-03-162-3/+3 * Update to 0.7.2vs2005-03-1615-138/+659 * Upgrade to 1.08.thierry2005-03-164-21/+90 * Drop maintainership of my ports.josef2005-03-161-1/+1 * - Upgrade to 5.0;thierry2005-03-164-34/+355 * - Update to 2.7.4ahze2005-03-163-10/+23 * - Update to 4.87ahze2005-03-154-6/+6 * Update to 0.38skv2005-03-152-3/+3 * Fix plist.krion2005-03-151-0/+1 * - Update to 0.1.9ahze2005-03-152-3/+3 * - Fix build on amd64.flz2005-03-142-4/+5 * - Fix build on amd64.flz2005-03-141-1/+1 * - Add WWW: line, http://poppler.freedesktop.org/ahze2005-03-141-0/+2 * - Update to 0.1.2ahze2005-03-142-4/+4 * Add p5-SVG-Metadataahze2005-03-145-0/+48 * - Add pear-Image_Barcode 0.5, PEAR class for barcode generation.flz2005-03-144-0/+37 * - Update to 0.4.0ahze2005-03-142-5/+4 * Update to 2.00arved2005-03-142-4/+4 * - Prepare to build cad/brlcad with framebuffer supportbarner2005-03-1418-13/+324 * 1) Update graphics/libkipi to version 0.1.1vs2005-03-1314-114/+422 * Bump shlib version due to latest version of graphics/libkexifkrion2005-03-132-4/+4 * Update to 0.2.1krion2005-03-133-7/+8 * - Update to 2.6.4pav2005-03-133-4/+12 * - Don't remove directories that belong to libglade portpav2005-03-132-2/+1 * - Update to 0.1.8ahze2005-03-123-3/+4 * Update to 2.10.0. Note: this release is API and ABI compatible withmarcus2005-03-123-19/+14 * Add evince, a multi-format (e.g. PDF, PS, Fig) document viewer for themarcus2005-03-125-0/+69 * Add poppler, a PDF rendering library using cairo as its backend. Thismarcus2005-03-126-0/+156 * -Update to 0.12.0, works with GTK 2.6/GNOME 2.10.mezz2005-03-124-3/+9 * Update to 0.41.marcus2005-03-1212-380/+178 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-1252-31/+52 * Presenting GNOME 2.10 for FreeBSD!marcus2005-03-1217-89/+127 * Update WWW.novel2005-03-111-1/+1 * Upgrade to 1.6.0ache2005-03-113-4/+15 * - Latest version of cairo fixes build on 4.xahze2005-03-111-7/+1 * Add graphics/svg2pngahze2005-03-115-0/+43 * - Update to 1.7ahze2005-03-112-3/+3 * - Update WWW: lineahze2005-03-112-2/+2 * - Remove two patch that were needed for a cvs snapshot we had on marcuscom cvsahze2005-03-113-26/+1 * Chase ImageMagick shlib version.krion2005-03-111-2/+2 * Fix mispelings of PTHREAD_{CFLAGS,LIBS}.vs2005-03-102-3/+3 * - Update to 1.3.2pav2005-03-105-38/+58 * Unbreak WITHOUT_X11vs2005-03-092-3/+8 * - update to netpbm-10.26.5dinoex2005-03-092-3/+3 * Add more info to pkg-descrahze2005-03-091-0/+5 * - Update to 0.4.0ahze2005-03-097-189/+61 * - Update to 0.44.4 and unbreak on 5.Xpav2005-03-092-11/+7 * - Fix MASTER_SITES.flz2005-03-092-3/+4 * Unbreak (on 4.x) by picking up 'stderr' from stdio.hvs2005-03-081-0/+10 * Fix lround() on RELENG_4.vanilla2005-03-081-1/+5 * - Update to 0.1.4ahze2005-03-082-3/+3 * Fix bogus CONFIGURE_ENV: PTHREAD_CLFAGS & _LDFLAGS don't existvs2005-03-081-2/+2 * Add missing category 'print'vs2005-03-081-1/+1 * Use @freebsd.org address for my ports.novel2005-03-081-1/+1 * - Add graphics/gstreamer-plugins-cairoahze2005-03-083-0/+29 * Add pear-Image_Graph 0.3.0, an OO PEAR graph rendering package.thierry2005-03-085-0/+142 * Bump PORTREVISION on all ports that received the imlib2 shlib chase.adamw2005-03-0814-5/+14 * 1: Upgrade imlib2 to 1.2.0vanilla2005-03-0722-143/+201 * - Update to 1.3.1pav2005-03-075-37/+46 * - Chase ImageMagick shlib bumppav2005-03-07