aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/lxrandr/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/x11/lxrandr/Makefile b/x11/lxrandr/Makefile
index 51e00d06db48..fb80a6ca1786 100644
--- a/x11/lxrandr/Makefile
+++ b/x11/lxrandr/Makefile
@@ -23,24 +23,16 @@ OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MNLS}
+post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|po man|man|' \
${WRKSRC}/Makefile.in
-.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>