aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--german/webalizer2/Makefile1
-rw-r--r--www/webalizer/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/german/webalizer2/Makefile b/german/webalizer2/Makefile
index f472a2498fef..b9eb65b29164 100644
--- a/german/webalizer2/Makefile
+++ b/german/webalizer2/Makefile
@@ -37,6 +37,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-src$//}
PLIST_SUB+= PKGNAMEPREFIX=${PKGNAMEPREFIX}
pre-configure:
+ @${PERL5} -pi -e "s=/etc=${PREFIX}/etc=" ${WRKSRC}/webalizer.1
@${PERL5} -pi -e "s=webalizer.conf=${PKGNAMEPREFIX}webalizer.conf=" \
${WRKSRC}/webalizer.c
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 7a56c3845f87..d7c60e435ebd 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -45,6 +45,7 @@ CONFIGURE_ARGS+= --with-language=${WEBALIZER_LANG}
.endif
pre-configure:
+ @${PERL5} -pi -e "s=/etc=${PREFIX}/etc=" ${WRKSRC}/webalizer.1
.if !defined(WEBALIZER_LANG)
@${ECHO_MSG} "You can customize the language by typing"
@${ECHO_MSG} " make WEBALIZER_LANG=<lang>"