aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CVSROOT/modules2
-rw-r--r--Mk/bsd.gstreamer.mk8
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gstreamer-plugins-wavpack/Makefile15
-rw-r--r--audio/gstreamer-plugins-wavpack80/Makefile15
-rw-r--r--graphics/gstreamer-plugins-cairo/Makefile2
-rw-r--r--graphics/gstreamer-plugins-cairo80/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common26
-rw-r--r--multimedia/gstreamer-plugins/distinfo4
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_cdparanoia_gstcdparanoia.c33
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist7
-rw-r--r--multimedia/gstreamer-plugins80/Makefile2
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common26
-rw-r--r--multimedia/gstreamer-plugins80/distinfo4
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c33
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist7
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/gstreamer-plugins-cdio/Makefile17
-rw-r--r--sysutils/gstreamer-plugins-cdio80/Makefile17
20 files changed, 186 insertions, 38 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index 4e86d0a3937f..912773834db1 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -3245,6 +3245,7 @@ gstreamer-plugins-artsd ports/audio/gstreamer-plugins-artsd
gstreamer-plugins-audiofile ports/audio/gstreamer-plugins-audiofile
gstreamer-plugins-cairo ports/graphics/gstreamer-plugins-cairo
gstreamer-plugins-cdaudio ports/audio/gstreamer-plugins-cdaudio
+gstreamer-plugins-cdio ports/sysutils/gstreamer-plugins-cdio
gstreamer-plugins-cdparanoia ports/audio/gstreamer-plugins-cdparanoia
gstreamer-plugins-core ports/multimedia/gstreamer-plugins-core
gstreamer-plugins-dirac ports/multimedia/gstreamer-plugins-dirac
@@ -3293,6 +3294,7 @@ gstreamer-plugins-speex ports/audio/gstreamer-plugins-speex
gstreamer-plugins-swfdec ports/graphics/gstreamer-plugins-swfdec
gstreamer-plugins-theora ports/multimedia/gstreamer-plugins-theora
gstreamer-plugins-vorbis ports/audio/gstreamer-plugins-vorbis
+gstreamer-plugins-wavpack ports/audio/gstreamer-plugins-wavpack
gstreamer-plugins-xvid ports/multimedia/gstreamer-plugins-xvid
gsubedit ports/multimedia/gsubedit
gsystem ports/science/gsystem
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index d2673cf5f7d1..5800561acccb 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -52,14 +52,14 @@ GST_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdparanoia \
+_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
dirac dts dv dvd esound faac faad ffmpeg flac \
gconf gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
jpeg-mmx ladspa lame libcaca libfame libmms libmng \
libpng libvisual mad mikmod mpeg2dec mpeg2enc mplex \
musepack musicbrainz nas sdl shout shout2 sidplay \
smoothwave sndfile speex theora ogg pango polypaudio \
- swfdec vorbis xvid
+ swfdec vorbis wavpack xvid
# other plugins
OTHER_GSTREAMER_PLUGINS+= core yes
@@ -72,6 +72,9 @@ core_GST_EXT= .keep
yes_DEPENDS= multimedia/gstreamer-plugins
yes_PLIST= libgstac3parse
+cdio_DEPENDS= sysutils/gstreamer-plugins-cdio
+cdio_PLIST= libgstcddasrc
+
gconf_DEPENDS= devel/gstreamer-plugins-gconf
gconf_PLIST= libgstgconfelements
@@ -138,6 +141,7 @@ speex_DEPENDS= audio/gstreamer-plugins-speex
vorbis_DEPENDS= audio/gstreamer-plugins-vorbis
+wavpack_DEPENDS= audio/gstreamer-plugins-wavpack
# Devel Plugins Section
gnomevfs_DEPENDS= devel/gstreamer-plugins-gnomevfs
diff --git a/audio/Makefile b/audio/Makefile
index bd650da25a95..052afc89ffde 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -200,6 +200,7 @@
SUBDIR += gstreamer-plugins-sndfile
SUBDIR += gstreamer-plugins-speex
SUBDIR += gstreamer-plugins-vorbis
+ SUBDIR += gstreamer-plugins-wavpack
SUBDIR += gtick
SUBDIR += gtkgep
SUBDIR += gtkguitune
diff --git a/audio/gstreamer-plugins-wavpack/Makefile b/audio/gstreamer-plugins-wavpack/Makefile
new file mode 100644
index 000000000000..8a8fcec56e6a
--- /dev/null
+++ b/audio/gstreamer-plugins-wavpack/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: gstreamer-plugins-wavpack
+# Date created: 5 July 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio
+PORTREVISION= 0
+
+GST_PLUGIN= wavpack
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/gstreamer-plugins-wavpack80/Makefile b/audio/gstreamer-plugins-wavpack80/Makefile
new file mode 100644
index 000000000000..8a8fcec56e6a
--- /dev/null
+++ b/audio/gstreamer-plugins-wavpack80/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: gstreamer-plugins-wavpack
+# Date created: 5 July 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio
+PORTREVISION= 0
+
+GST_PLUGIN= wavpack
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-cairo/Makefile b/graphics/gstreamer-plugins-cairo/Makefile
index 70d0cebc3cca..441657a26408 100644
--- a/graphics/gstreamer-plugins-cairo/Makefile
+++ b/graphics/gstreamer-plugins-cairo/Makefile
@@ -14,4 +14,6 @@ GST_PLUGIN= cairo
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+IGNORE= Cairo needs to be updated to 0.5 for plugin to work.
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-cairo80/Makefile b/graphics/gstreamer-plugins-cairo80/Makefile
index 70d0cebc3cca..441657a26408 100644
--- a/graphics/gstreamer-plugins-cairo80/Makefile
+++ b/graphics/gstreamer-plugins-cairo80/Makefile
@@ -14,4 +14,6 @@ GST_PLUGIN= cairo
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+IGNORE= Cairo needs to be updated to 0.5 for plugin to work.
+
.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index f1b66829a769..d3fb13ac5d81 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index dcfb94ba5014..dad62b30045b 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -2,7 +2,6 @@ GST_ALL_PLUGINS= \
a52dec \
aalib \
aalibtest \
- amrnb \
arts \
artstest \
artsc \
@@ -10,6 +9,7 @@ GST_ALL_PLUGINS= \
audioresample \
cairo \
cdaudio \
+ cdio \
cdparanoia \
dirac \
directfb \
@@ -70,11 +70,11 @@ GST_ALL_PLUGINS= \
sndfile \
speex \
swfdec \
- tarkin \
theora \
vcd \
vorbis \
vorbistest \
+ wavpack \
xvid
# Disable all plugins by default\
@@ -84,6 +84,7 @@ CONFIGURE_ARGS+= --disable-${d}
CONFIGURE_ARGS+=--disable-tests \
--disable-examples \
+ --disable-amrnb \
--disable-alsa \
--disable-http \
--enable-cdrom \
@@ -93,12 +94,12 @@ CONFIGURE_ARGS+=--disable-tests \
--enable-oss \
--disable-osx_audio \
--disable-osx_video \
+ --disable-tarkin \
--enable-static \
- --disable-spc \
+ --enable-spc \
--disable-sunaudio \
--disable-gst_v4l \
--disable-gst_v4l2 \
- --enable-wavpack \
--disable-xine \
--enable-x \
--enable-xshm \
@@ -224,6 +225,12 @@ LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
LIB_DEPENDS+= cdaudio.1:${PORTSDIR}/audio/libcdaudio
.endif
+# libcdio
+.if ${GST_PLUGIN}=="cdio"
+LIB_DEPENDS+= cdio.5:${PORTSDIR}/sysutils/libcdio
+PLIST_FILES= ${GST_LIB_DIR}/libgstcddasrc.so
+.endif
+
# libvisual
.if ${GST_PLUGIN}=="libvisual"
LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
@@ -395,7 +402,7 @@ PLIST_FILES= ${GST_LIB_DIR}/libgsttextoverlay.so \
${GST_LIB_DIR}/libgsttimeoverlay.so
.endif
-# libpng
+# libpng and the snapshot plugin
.if ${GST_PLUGIN}=="libpng"
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
GST_PLUGIN_DIR= ext/libpng \
@@ -443,6 +450,11 @@ LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
.endif
+# wavpack
+.if ${GST_PLUGIN}=="wavpack"
+LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
+.endif
+
# xvid
.if ${GST_PLUGIN}=="xvid"
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
@@ -450,8 +462,8 @@ LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
LIB_DEPENDS+= gstplay-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
-PLIST_FILES+= '@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
-PLIST_FILES+= '@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
+PLIST_FILES+= '@exec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
+PLIST_FILES+= '@unexec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
do-build:
.if ${GST_PLUGIN} == "gconf"
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index a0b5018d8e3d..4b35ca59720c 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.9.tar.bz2) = 663461ef7b16e9bd7f2605e4ed0db5ba
-SIZE (gnome2/gst-plugins-0.8.9.tar.bz2) = 2356958
+MD5 (gnome2/gst-plugins-0.8.10.tar.bz2) = 99f36ba2b91015a23d3c20a8f424b232
+SIZE (gnome2/gst-plugins-0.8.10.tar.bz2) = 2397528
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_cdparanoia_gstcdparanoia.c b/multimedia/gstreamer-plugins/files/patch-ext_cdparanoia_gstcdparanoia.c
index 17e8469ad897..b45d5baf4f91 100644
--- a/multimedia/gstreamer-plugins/files/patch-ext_cdparanoia_gstcdparanoia.c
+++ b/multimedia/gstreamer-plugins/files/patch-ext_cdparanoia_gstcdparanoia.c
@@ -1,6 +1,6 @@
---- ext/cdparanoia/gstcdparanoia.c.orig Fri Jun 3 06:59:43 2005
-+++ ext/cdparanoia/gstcdparanoia.c Fri Jun 3 07:00:13 2005
-@@ -561,6 +561,7 @@
+--- ext/cdparanoia/gstcdparanoia.c.orig Tue Jul 5 13:24:21 2005
++++ ext/cdparanoia/gstcdparanoia.c Tue Jul 5 13:24:27 2005
+@@ -562,6 +562,7 @@
gint16 *cdda_buf;
gint64 timestamp;
GstFormat format;
@@ -8,7 +8,7 @@
/* convert the sequence sector number to a timestamp */
format = GST_FORMAT_TIME;
-@@ -574,7 +575,6 @@
+@@ -575,7 +576,6 @@
gst_pad_convert (src->srcpad, sector_format,
get_relative (src, src->cur_track, src->cur_sector), &format,
&timestamp);
@@ -16,3 +16,28 @@
if (src->flush_pending) {
src->flush_pending = FALSE;
+@@ -790,7 +790,11 @@
+ if (src->d == NULL) {
+ GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
+ (_("Could not open CD device %s for reading."),
+- src->d->cdda_device_name), ("cdda_identify failed"));
++#if defined(__FreeBSD__)
++ src->d->dev->device_path), ("cdda_identify failed"));
++#else
++ src->d->cdda_device_name), ("cdda_identify failed"));
++#endif
+ return FALSE;
+ }
+
+@@ -807,7 +811,11 @@
+ if (cdda_open (src->d)) {
+ GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
+ (_("Could not open CD device %s for reading."),
++#if defined(__FreeBSD__)
++ src->d->dev->device_path), ("cdda_open failed"));
++#else
+ src->d->cdda_device_name), ("cdda_open failed"));
++#endif
+ cdda_close (src->d);
+ src->d = NULL;
+ return FALSE;
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 5bf665b1fd9f..18a73b2e9fac 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -101,7 +101,7 @@ lib/gstreamer-%%VERSION%%/libgstsilence.so
lib/gstreamer-%%VERSION%%/libgstsinesrc.so
lib/gstreamer-%%VERSION%%/libgstsmooth.so
lib/gstreamer-%%VERSION%%/libgstsmpte.so
-@comment lib/gstreamer-%%VERSION%%/libgstspc.so
+lib/gstreamer-%%VERSION%%/libgstspc.so
lib/gstreamer-%%VERSION%%/libgstspectrum.so
lib/gstreamer-%%VERSION%%/libgstspeed.so
lib/gstreamer-%%VERSION%%/libgststereo.so
@@ -129,7 +129,6 @@ lib/gstreamer-%%VERSION%%/libgstvideotestsrc.so
lib/gstreamer-%%VERSION%%/libgstvolenv.so
lib/gstreamer-%%VERSION%%/libgstvolume.so
lib/gstreamer-%%VERSION%%/libgstwavenc.so
-lib/gstreamer-%%VERSION%%/libgstwavpack.so
lib/gstreamer-%%VERSION%%/libgstwavparse.so
lib/gstreamer-%%VERSION%%/libgstximagesink.so
lib/gstreamer-%%VERSION%%/libgstxvimagesink.so
@@ -183,5 +182,5 @@ share/locale/zh_TW/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/audio
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
-@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
-@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@exec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@unexec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index f1b66829a769..d3fb13ac5d81 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index dcfb94ba5014..dad62b30045b 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -2,7 +2,6 @@ GST_ALL_PLUGINS= \
a52dec \
aalib \
aalibtest \
- amrnb \
arts \
artstest \
artsc \
@@ -10,6 +9,7 @@ GST_ALL_PLUGINS= \
audioresample \
cairo \
cdaudio \
+ cdio \
cdparanoia \
dirac \
directfb \
@@ -70,11 +70,11 @@ GST_ALL_PLUGINS= \
sndfile \
speex \
swfdec \
- tarkin \
theora \
vcd \
vorbis \
vorbistest \
+ wavpack \
xvid
# Disable all plugins by default\
@@ -84,6 +84,7 @@ CONFIGURE_ARGS+= --disable-${d}
CONFIGURE_ARGS+=--disable-tests \
--disable-examples \
+ --disable-amrnb \
--disable-alsa \
--disable-http \
--enable-cdrom \
@@ -93,12 +94,12 @@ CONFIGURE_ARGS+=--disable-tests \
--enable-oss \
--disable-osx_audio \
--disable-osx_video \
+ --disable-tarkin \
--enable-static \
- --disable-spc \
+ --enable-spc \
--disable-sunaudio \
--disable-gst_v4l \
--disable-gst_v4l2 \
- --enable-wavpack \
--disable-xine \
--enable-x \
--enable-xshm \
@@ -224,6 +225,12 @@ LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
LIB_DEPENDS+= cdaudio.1:${PORTSDIR}/audio/libcdaudio
.endif
+# libcdio
+.if ${GST_PLUGIN}=="cdio"
+LIB_DEPENDS+= cdio.5:${PORTSDIR}/sysutils/libcdio
+PLIST_FILES= ${GST_LIB_DIR}/libgstcddasrc.so
+.endif
+
# libvisual
.if ${GST_PLUGIN}=="libvisual"
LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
@@ -395,7 +402,7 @@ PLIST_FILES= ${GST_LIB_DIR}/libgsttextoverlay.so \
${GST_LIB_DIR}/libgsttimeoverlay.so
.endif
-# libpng
+# libpng and the snapshot plugin
.if ${GST_PLUGIN}=="libpng"
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
GST_PLUGIN_DIR= ext/libpng \
@@ -443,6 +450,11 @@ LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
.endif
+# wavpack
+.if ${GST_PLUGIN}=="wavpack"
+LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
+.endif
+
# xvid
.if ${GST_PLUGIN}=="xvid"
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
@@ -450,8 +462,8 @@ LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
LIB_DEPENDS+= gstplay-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
-PLIST_FILES+= '@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
-PLIST_FILES+= '@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
+PLIST_FILES+= '@exec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
+PLIST_FILES+= '@unexec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
do-build:
.if ${GST_PLUGIN} == "gconf"
diff --git a/multimedia/gstreamer-plugins80/distinfo b/multimedia/gstreamer-plugins80/distinfo
index a0b5018d8e3d..4b35ca59720c 100644
--- a/multimedia/gstreamer-plugins80/distinfo
+++ b/multimedia/gstreamer-plugins80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.9.tar.bz2) = 663461ef7b16e9bd7f2605e4ed0db5ba
-SIZE (gnome2/gst-plugins-0.8.9.tar.bz2) = 2356958
+MD5 (gnome2/gst-plugins-0.8.10.tar.bz2) = 99f36ba2b91015a23d3c20a8f424b232
+SIZE (gnome2/gst-plugins-0.8.10.tar.bz2) = 2397528
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c b/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c
index 17e8469ad897..b45d5baf4f91 100644
--- a/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c
@@ -1,6 +1,6 @@
---- ext/cdparanoia/gstcdparanoia.c.orig Fri Jun 3 06:59:43 2005
-+++ ext/cdparanoia/gstcdparanoia.c Fri Jun 3 07:00:13 2005
-@@ -561,6 +561,7 @@
+--- ext/cdparanoia/gstcdparanoia.c.orig Tue Jul 5 13:24:21 2005
++++ ext/cdparanoia/gstcdparanoia.c Tue Jul 5 13:24:27 2005
+@@ -562,6 +562,7 @@
gint16 *cdda_buf;
gint64 timestamp;
GstFormat format;
@@ -8,7 +8,7 @@
/* convert the sequence sector number to a timestamp */
format = GST_FORMAT_TIME;
-@@ -574,7 +575,6 @@
+@@ -575,7 +576,6 @@
gst_pad_convert (src->srcpad, sector_format,
get_relative (src, src->cur_track, src->cur_sector), &format,
&timestamp);
@@ -16,3 +16,28 @@
if (src->flush_pending) {
src->flush_pending = FALSE;
+@@ -790,7 +790,11 @@
+ if (src->d == NULL) {
+ GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
+ (_("Could not open CD device %s for reading."),
+- src->d->cdda_device_name), ("cdda_identify failed"));
++#if defined(__FreeBSD__)
++ src->d->dev->device_path), ("cdda_identify failed"));
++#else
++ src->d->cdda_device_name), ("cdda_identify failed"));
++#endif
+ return FALSE;
+ }
+
+@@ -807,7 +811,11 @@
+ if (cdda_open (src->d)) {
+ GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
+ (_("Could not open CD device %s for reading."),
++#if defined(__FreeBSD__)
++ src->d->dev->device_path), ("cdda_open failed"));
++#else
+ src->d->cdda_device_name), ("cdda_open failed"));
++#endif
+ cdda_close (src->d);
+ src->d = NULL;
+ return FALSE;
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index 5bf665b1fd9f..18a73b2e9fac 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -101,7 +101,7 @@ lib/gstreamer-%%VERSION%%/libgstsilence.so
lib/gstreamer-%%VERSION%%/libgstsinesrc.so
lib/gstreamer-%%VERSION%%/libgstsmooth.so
lib/gstreamer-%%VERSION%%/libgstsmpte.so
-@comment lib/gstreamer-%%VERSION%%/libgstspc.so
+lib/gstreamer-%%VERSION%%/libgstspc.so
lib/gstreamer-%%VERSION%%/libgstspectrum.so
lib/gstreamer-%%VERSION%%/libgstspeed.so
lib/gstreamer-%%VERSION%%/libgststereo.so
@@ -129,7 +129,6 @@ lib/gstreamer-%%VERSION%%/libgstvideotestsrc.so
lib/gstreamer-%%VERSION%%/libgstvolenv.so
lib/gstreamer-%%VERSION%%/libgstvolume.so
lib/gstreamer-%%VERSION%%/libgstwavenc.so
-lib/gstreamer-%%VERSION%%/libgstwavpack.so
lib/gstreamer-%%VERSION%%/libgstwavparse.so
lib/gstreamer-%%VERSION%%/libgstximagesink.so
lib/gstreamer-%%VERSION%%/libgstxvimagesink.so
@@ -183,5 +182,5 @@ share/locale/zh_TW/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/audio
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
-@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
-@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@exec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@unexec %D/bin/gst-register-${VERSION} --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 41661681b9ff..34fd05ac8331 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -202,6 +202,7 @@
SUBDIR += growspd
SUBDIR += grub
SUBDIR += gstopd
+ SUBDIR += gstreamer-plugins-cdio
SUBDIR += gtk-imonc
SUBDIR += gtk-send-pr
SUBDIR += gtoaster
diff --git a/sysutils/gstreamer-plugins-cdio/Makefile b/sysutils/gstreamer-plugins-cdio/Makefile
new file mode 100644
index 000000000000..a342c79e8fcb
--- /dev/null
+++ b/sysutils/gstreamer-plugins-cdio/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-cdio
+# Date created: 5 July 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio
+PORTREVISION= 0
+
+COMMENT= Gstreamer compact disc input and control library
+
+GST_PLUGIN= cdio
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/gstreamer-plugins-cdio80/Makefile b/sysutils/gstreamer-plugins-cdio80/Makefile
new file mode 100644
index 000000000000..a342c79e8fcb
--- /dev/null
+++ b/sysutils/gstreamer-plugins-cdio80/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-cdio
+# Date created: 5 July 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio
+PORTREVISION= 0
+
+COMMENT= Gstreamer compact disc input and control library
+
+GST_PLUGIN= cdio
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"