aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/ocaml-mysql/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/databases/ocaml-mysql/Makefile b/databases/ocaml-mysql/Makefile
index 746fce2c92d5..fd936d3a2ba4 100644
--- a/databases/ocaml-mysql/Makefile
+++ b/databases/ocaml-mysql/Makefile
@@ -11,9 +11,8 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jyyou@cs.nctu.edu.tw
COMMENT= OCaml bindings to libmysqlclient
-USE_GMAKE= yes
+USES= gmake
USE_MYSQL= yes
-
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAMLFIND_PLIST= yes
@@ -22,16 +21,24 @@ USE_OCAML_LDCONFIG= yes
GNU_CONFIGURE= yes
ALL_TARGET= all opt
-NO_STAGE= yes
-.if !defined(NOPORTDOCS)
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= htdoc
-PORTDOCS= *
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/mysql/html/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/mysql/html/* ${STAGEDIR}${DOCSDIR}
.endif
+post-patch:
+ ${REINPLACE_CMD} 's,OCAMLFIND_INSTFLAGS=,OCAMLFIND_INSTFLAGS=-ldconf ignore ,' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>