aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ngpt/Makefile8
-rw-r--r--net-mgmt/net-snmp53/Makefile4
-rw-r--r--net/pimdd/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/devel/ngpt/Makefile b/devel/ngpt/Makefile
index 475027e13dc5..b89cd1821476 100644
--- a/devel/ngpt/Makefile
+++ b/devel/ngpt/Makefile
@@ -24,7 +24,13 @@ USE_GMAKE= yes
ONLY_FOR_ARCHS= amd64 i386
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+BROKEN= does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index cecdf3b3b06b..558d14590885 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -56,6 +56,10 @@ CONFIGURE_ARGS+=--with-dummy-values
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800000
+BROKEN= does not compile
+.endif
+
.if defined(WITHOUT_PERL)
PLIST_SUB+= WITH_PERL="@comment "
CONFIGURE_ARGS+=--disable-embedded-perl --without-perl-modules
diff --git a/net/pimdd/Makefile b/net/pimdd/Makefile
index 64db7eceea12..5526545e1512 100644
--- a/net/pimdd/Makefile
+++ b/net/pimdd/Makefile
@@ -18,6 +18,12 @@ COMMENT= \
NO_MAN= defined
PIMDD_DOCS= pimd-dense.html README CHANGES RELEASE.NOTES
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800070
+BROKEN= does not compile: error: IGMP_HOST_MEMBERSHIP_REPORT undeclared
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/etc/pimd.conf|${PREFIX}/etc/pimd.conf|g' ${WRKSRC}/pathnames.h
@@ -31,4 +37,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>